summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-04-02 19:46:45 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-04-02 19:46:45 +0000
commit755040f94b1d6286a693d2e4d40edf40d7b107c4 (patch)
treec2dc3e4e64d57e5ad3d170a1f4f8e962bc8c6910 /dev-python/pychecker/files
parentUse debian patchset, rework ebuild a bit, bug #336245 (diff)
downloadhistorical-755040f94b1d6286a693d2e4d40edf40d7b107c4.tar.gz
historical-755040f94b1d6286a693d2e4d40edf40d7b107c4.tar.bz2
historical-755040f94b1d6286a693d2e4d40edf40d7b107c4.zip
Version bump (bug #352668).
Package-Manager: portage-2.2.0_alpha29_p5/cvs/Linux x86_64
Diffstat (limited to 'dev-python/pychecker/files')
-rw-r--r--dev-python/pychecker/files/pychecker-0.8.19-create_script.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/dev-python/pychecker/files/pychecker-0.8.19-create_script.patch b/dev-python/pychecker/files/pychecker-0.8.19-create_script.patch
new file mode 100644
index 000000000000..ca4367591174
--- /dev/null
+++ b/dev-python/pychecker/files/pychecker-0.8.19-create_script.patch
@@ -0,0 +1,13 @@
+--- setup.py
++++ setup.py
+@@ -221,7 +221,9 @@
+ script_str = "%s %s %%*\n" % (sys.executable, checker_path)
+ else:
+ script_str = '#! /bin/sh\n\n%s %s "$@"\n' % (sys.executable, checker_path)
+- open(script_path, "w").write(script_str)
++ script = open(script_path, "w")
++ script.write(script_str)
++ script.close()
+ except Exception, e:
+ print "ERROR: Unable to create %s: %s" % (script_path, e)
+ raise e