summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-02-03 19:55:22 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-02-03 19:55:22 +0000
commitddffede5a734c4ab5e1e29f4d36cbf693f2a142e (patch)
tree02823853d117cfc30615721027ace97429bd0f31 /dev-python/pycipher/pycipher-0.2.ebuild
parentAim for conformance when called as c89/c99 (#257299) (diff)
downloadhistorical-ddffede5a734c4ab5e1e29f4d36cbf693f2a142e.tar.gz
historical-ddffede5a734c4ab5e1e29f4d36cbf693f2a142e.tar.bz2
historical-ddffede5a734c4ab5e1e29f4d36cbf693f2a142e.zip
Initial import. Ebuild by Fernando V. <email@missionaccomplish.com>. Closes #111802
Package-Manager: portage-2.2_rc23/cvs/Linux x86_64
Diffstat (limited to 'dev-python/pycipher/pycipher-0.2.ebuild')
-rw-r--r--dev-python/pycipher/pycipher-0.2.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/pycipher/pycipher-0.2.ebuild b/dev-python/pycipher/pycipher-0.2.ebuild
new file mode 100644
index 000000000000..1313bc20b7d1
--- /dev/null
+++ b/dev-python/pycipher/pycipher-0.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pycipher/pycipher-0.2.ebuild,v 1.1 2009/02/03 19:55:22 patrick Exp $
+
+inherit eutils python
+
+DESCRIPTION="A Python module that implements several well-known classical cipher \
+algorithms"
+HOMEPAGE="http://pycipher.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.py"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+DEPEND="dev-lang/python"
+
+src_install() {
+ cd "${WORKDIR}"
+
+ python_version
+ exeinto "${ROOT}/usr/$(get_libdir)/python${PYVER}/site-packages"
+ newexe "${DISTDIR}/${P}.py ${PN}.py"
+
+ local dir="${ROOT}/usr/$(get_libdir)/python${PYVER}/site-packages"
+ make_wrapper "${PN}" "python ./${PN}.py" "${dir}"
+}