summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-11-30 02:04:29 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-11-30 02:04:29 +0000
commit63d73198010b93169b34eea1b8d98b3d27247c42 (patch)
treee7de6de9a76560025f1aa8e8dc14dba1e239c1d8 /dev-python/pyflakes/pyflakes-0.4.0.ebuild
parentVersion bump (bug #294924). (diff)
downloadhistorical-63d73198010b93169b34eea1b8d98b3d27247c42.tar.gz
historical-63d73198010b93169b34eea1b8d98b3d27247c42.tar.bz2
historical-63d73198010b93169b34eea1b8d98b3d27247c42.zip
Version bump. Set SUPPORT_PYTHON_ABIS.
Package-Manager: portage-14920-svn/cvs/Linux x86_64
Diffstat (limited to 'dev-python/pyflakes/pyflakes-0.4.0.ebuild')
-rw-r--r--dev-python/pyflakes/pyflakes-0.4.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/pyflakes/pyflakes-0.4.0.ebuild b/dev-python/pyflakes/pyflakes-0.4.0.ebuild
new file mode 100644
index 000000000000..2799da81549c
--- /dev/null
+++ b/dev-python/pyflakes/pyflakes-0.4.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyflakes/pyflakes-0.4.0.ebuild,v 1.1 2009/11/30 02:04:29 arfrever Exp $
+
+EAPI="2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils
+
+DESCRIPTION="Passive checker for python programs."
+HOMEPAGE="http://divmod.org/trac/wiki/DivmodPyflakes http://pypi.python.org/pypi/pyflakes"
+SRC_URI="http://pypi.python.org/packages/source/p/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~x86 ~amd64-linux ~x86-linux ~x86-macos"
+IUSE="test"
+
+DEPEND="test? ( dev-python/nose )"
+RDEPEND=""
+RESTRICT_PYTHON_ABIS="3.*"
+
+src_test() {
+ testing() {
+ PYTHONPATH="build-${PYTHON_ABI}/lib" nosetests-${PYTHON_ABI}
+ }
+ python_execute_function testing
+}