summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2011-01-28 19:39:18 +0000
committerPacho Ramos <pacho@gentoo.org>2011-01-28 19:39:18 +0000
commita7739de3e12d53845f067bfa7728d345f872f00a (patch)
tree2592ed78154386bae7593a1e944a1dcf797bca0f /dev-python/pygobject/pygobject-2.26.0-r1.ebuild
parentUpdate eapi to 3. (diff)
downloadhistorical-a7739de3e12d53845f067bfa7728d345f872f00a.tar.gz
historical-a7739de3e12d53845f067bfa7728d345f872f00a.tar.bz2
historical-a7739de3e12d53845f067bfa7728d345f872f00a.zip
Fix building without threads and dependency on python (thanks a lot to Arfrever Frehtes Taifersar Arahesis for his help).
Package-Manager: portage-2.1.9.35/cvs/Linux x86_64
Diffstat (limited to 'dev-python/pygobject/pygobject-2.26.0-r1.ebuild')
-rw-r--r--dev-python/pygobject/pygobject-2.26.0-r1.ebuild10
1 files changed, 7 insertions, 3 deletions
diff --git a/dev-python/pygobject/pygobject-2.26.0-r1.ebuild b/dev-python/pygobject/pygobject-2.26.0-r1.ebuild
index 8b26ff5b1030..3bdeed882783 100644
--- a/dev-python/pygobject/pygobject-2.26.0-r1.ebuild
+++ b/dev-python/pygobject/pygobject-2.26.0-r1.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pygobject/pygobject-2.26.0-r1.ebuild,v 1.4 2011/01/27 19:05:25 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygobject/pygobject-2.26.0-r1.ebuild,v 1.5 2011/01/28 19:39:18 pacho Exp $
EAPI="2"
GCONF_DEBUG="no"
SUPPORT_PYTHON_ABIS="1"
PYTHON_DEPEND="2:2.5"
RESTRICT_PYTHON_ABIS="2.4 3.* *-jython"
-PYTHON_USE_WITH="threads" # Needed until upstream bug 640748 is fixed
+PYTHON_USE_WITH="threads="
inherit alternatives autotools gnome2 python virtualx
@@ -17,7 +17,7 @@ HOMEPAGE="http://www.pygtk.org/"
LICENSE="LGPL-2.1"
SLOT="2"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
-IUSE="doc cairo examples +introspection libffi test"
+IUSE="doc cairo examples +introspection libffi test threads"
RDEPEND=">=dev-libs/glib-2.22.4:2
!<dev-python/pygtk-2.13
@@ -41,6 +41,7 @@ pkg_setup() {
$(use_enable doc docs)
$(use_enable cairo)
$(use_enable introspection)
+ $(use_enable threads thread)
$(use_with libffi ffi)"
}
@@ -62,6 +63,9 @@ src_prepare() {
# Fix crash in instance property; bug# 344459
epatch "${FILESDIR}/${PN}-2.26.0-nocrash.patch"
+ # Disable calls to PyGILState_* when threads are disabled
+ epatch "${FILESDIR}/${PN}-2.26.0-disabled-threads.patch"
+
# disable pyc compiling
mv py-compile py-compile.orig
ln -s $(type -P true) py-compile