summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-01-18 18:10:32 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-01-18 18:10:32 +0000
commit0c237f004e62cf2c8e6bf7da130adbf2b8655811 (patch)
treed5465ff375655c5ad2be1ac45bdaca73ea06f6e5 /dev-python/pylint
parentReplace deprecated xine-config command by pkg-config. (diff)
downloadhistorical-0c237f004e62cf2c8e6bf7da130adbf2b8655811.tar.gz
historical-0c237f004e62cf2c8e6bf7da130adbf2b8655811.tar.bz2
historical-0c237f004e62cf2c8e6bf7da130adbf2b8655811.zip
Delete older ebuilds.
Diffstat (limited to 'dev-python/pylint')
-rw-r--r--dev-python/pylint/pylint-0.21.0.ebuild67
-rw-r--r--dev-python/pylint/pylint-0.21.1.ebuild67
-rw-r--r--dev-python/pylint/pylint-0.21.2.ebuild61
3 files changed, 0 insertions, 195 deletions
diff --git a/dev-python/pylint/pylint-0.21.0.ebuild b/dev-python/pylint/pylint-0.21.0.ebuild
deleted file mode 100644
index 1df2fa429d82..000000000000
--- a/dev-python/pylint/pylint-0.21.0.ebuild
+++ /dev/null
@@ -1,67 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pylint/pylint-0.21.0.ebuild,v 1.5 2010/07/18 14:07:33 nixnut Exp $
-
-EAPI="3"
-PYTHON_DEPEND="2"
-PYTHON_USE_WITH="tk"
-PYTHON_USE_WITH_OPT="tk"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.*"
-
-inherit distutils
-
-DESCRIPTION="Python code static checker"
-HOMEPAGE="http://www.logilab.org/projects/pylint/ http://pypi.python.org/pypi/pylint"
-SRC_URI="ftp://ftp.logilab.org/pub/${PN}/${P}.tar.gz http://pypi.python.org/packages/source/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ~ia64 ppc ~sparc x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
-IUSE="doc examples test tk"
-
-# Versions specified in __pkginfo__.py.
-DEPEND=">=dev-python/logilab-common-0.50.1
- >=dev-python/astng-0.20.1"
-RDEPEND="${DEPEND}"
-
-src_prepare() {
- distutils_src_prepare
-
- # Disable failing tests.
- rm -f test/input/func_arguments.py
- sed -e "s/test_exhaustivity/_&/" -i test/test_func.py || die "sed failed"
-}
-
-src_test() {
- testing() {
- PYTHONPATH="build-${PYTHON_ABI}/lib" pytest -v
- }
- python_execute_function testing
-}
-
-src_install() {
- distutils_src_install
-
- doman man/{pylint,pyreverse}.1 || die "doman failed"
- dodoc doc/FAQ.txt || die "dodoc failed"
-
- if use doc; then
- dodoc doc/*.txt || die "dodoc failed"
- fi
-
- if use examples; then
- docinto examples
- dodoc examples/* || die "dodoc failed"
- fi
-}
-
-pkg_postinst() {
- distutils_pkg_postinst
-
- if ! has_version "=dev-lang/python-2*[tk]"; then
- ewarn "dev-lang/python has been built without tk support,"
- ewarn "${PN}-gui doesn't work without Tkinter so if you really need it,"
- ewarn "re-install dev-lang/python with \"tk\" useflag enabled."
- fi
-}
diff --git a/dev-python/pylint/pylint-0.21.1.ebuild b/dev-python/pylint/pylint-0.21.1.ebuild
deleted file mode 100644
index efb5e3f950ec..000000000000
--- a/dev-python/pylint/pylint-0.21.1.ebuild
+++ /dev/null
@@ -1,67 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pylint/pylint-0.21.1.ebuild,v 1.1 2010/06/08 00:34:04 arfrever Exp $
-
-EAPI="3"
-PYTHON_DEPEND="2"
-PYTHON_USE_WITH="tk"
-PYTHON_USE_WITH_OPT="tk"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.*"
-
-inherit distutils
-
-DESCRIPTION="Python code static checker"
-HOMEPAGE="http://www.logilab.org/projects/pylint/ http://pypi.python.org/pypi/pylint"
-SRC_URI="ftp://ftp.logilab.org/pub/${PN}/${P}.tar.gz http://pypi.python.org/packages/source/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
-IUSE="doc examples test tk"
-
-# Versions specified in __pkginfo__.py.
-DEPEND=">=dev-python/logilab-common-0.50.1
- >=dev-python/astng-0.20.1"
-RDEPEND="${DEPEND}"
-
-src_prepare() {
- distutils_src_prepare
-
- # Disable failing tests.
- rm -f test/input/func_arguments.py
- sed -e "s/test_exhaustivity/_&/" -i test/test_func.py || die "sed failed"
-}
-
-src_test() {
- testing() {
- PYTHONPATH="build-${PYTHON_ABI}/lib" pytest -v
- }
- python_execute_function testing
-}
-
-src_install() {
- distutils_src_install
-
- doman man/{pylint,pyreverse}.1 || die "doman failed"
- dodoc doc/FAQ.txt || die "dodoc failed"
-
- if use doc; then
- dodoc doc/*.txt || die "dodoc failed"
- fi
-
- if use examples; then
- docinto examples
- dodoc examples/* || die "dodoc failed"
- fi
-}
-
-pkg_postinst() {
- distutils_pkg_postinst
-
- if ! has_version "=dev-lang/python-2*[tk]"; then
- ewarn "dev-lang/python has been built without tk support,"
- ewarn "${PN}-gui doesn't work without Tkinter so if you really need it,"
- ewarn "re-install dev-lang/python with \"tk\" useflag enabled."
- fi
-}
diff --git a/dev-python/pylint/pylint-0.21.2.ebuild b/dev-python/pylint/pylint-0.21.2.ebuild
deleted file mode 100644
index 888d0b08b6cf..000000000000
--- a/dev-python/pylint/pylint-0.21.2.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pylint/pylint-0.21.2.ebuild,v 1.1 2010/09/19 18:20:49 arfrever Exp $
-
-EAPI="3"
-PYTHON_DEPEND="2"
-PYTHON_USE_WITH="tk"
-PYTHON_USE_WITH_OPT="tk"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.*"
-
-inherit distutils
-
-DESCRIPTION="Python code static checker"
-HOMEPAGE="http://www.logilab.org/projects/pylint/ http://pypi.python.org/pypi/pylint"
-SRC_URI="ftp://ftp.logilab.org/pub/${PN}/${P}.tar.gz mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
-IUSE="examples tk"
-
-# Versions specified in __pkginfo__.py.
-RDEPEND=">=dev-python/logilab-common-0.50.1
- >=dev-python/astng-0.20.1"
-DEPEND="${RDEPEND}
- dev-python/setuptools"
-
-DOCS="doc/*.txt"
-
-src_prepare() {
- distutils_src_prepare
-
- # Disable failing tests.
- rm -f test/input/func_w0401.py test/input/w0401_cycle.py test/messages/func_w0401.txt
- sed -e "s/test_exhaustivity/_&/" -i test/test_func.py
- sed -e "s/test_checker_dep_graphs/_&/" -i test/test_import_graph.py
- sed -e "s/test0/_&/" -i test/smoketest.py
-}
-
-src_test() {
- testing() {
- PYTHONPATH="build-${PYTHON_ABI}/lib" pytest -v
- }
- python_execute_function testing
-}
-
-src_install() {
- distutils_src_install
-
- if ! use tk; then
- rm -f "${ED}usr/bin/pylint-gui"*
- fi
-
- doman man/{pylint,pyreverse}.1 || die "doman failed"
-
- if use examples; then
- docinto examples
- dodoc examples/* || die "dodoc failed"
- fi
-}