summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-04-18 14:24:14 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-04-18 14:24:14 +0000
commit9dde0154e68f292102f1c8f9a663f60c32e9707e (patch)
treeb568a2fbd72da2c69bbec9b98f06295bbe7e152a /dev-python/pypcap/pypcap-1.1-r1.ebuild
parentarm/m68k/s390/sh stable wrt #265376 (diff)
downloadhistorical-9dde0154e68f292102f1c8f9a663f60c32e9707e.tar.gz
historical-9dde0154e68f292102f1c8f9a663f60c32e9707e.tar.bz2
historical-9dde0154e68f292102f1c8f9a663f60c32e9707e.zip
Small patch to fix compilation issues, thanks to Mike Kazantsev. Closes #247145
Package-Manager: portage-2.2_rc30/cvs/Linux x86_64
Diffstat (limited to 'dev-python/pypcap/pypcap-1.1-r1.ebuild')
-rw-r--r--dev-python/pypcap/pypcap-1.1-r1.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/pypcap/pypcap-1.1-r1.ebuild b/dev-python/pypcap/pypcap-1.1-r1.ebuild
new file mode 100644
index 000000000000..0e830e6d9f3d
--- /dev/null
+++ b/dev-python/pypcap/pypcap-1.1-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pypcap/pypcap-1.1-r1.ebuild,v 1.1 2009/04/18 14:24:14 patrick Exp $
+
+NEED_PYTHON=2.3
+
+inherit distutils
+
+DESCRIPTION="Simplified object-oriented Python extension module for libpcap"
+HOMEPAGE="http://code.google.com/p/pypcap/"
+SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+RDEPEND="virtual/libpcap"
+DEPEND="${RDEPEND}
+ >=dev-python/pyrex-0.9.5.1a"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/include_path.patch" || die
+}
+
+src_compile() {
+ # pcap.c was generated with pyrex-0.9.3
+ # and <=pyrex-0.9.5.1a is incompatible with python-2.5.
+ # So we regenerate it. Bug #180039
+ pyrexc pcap.pyx || die "pyrexc failed"
+ "${python}" setup.py config || die "config failed"
+ distutils_src_compile
+}
+
+src_install() {
+ DOCS="CHANGES"
+ distutils_src_install
+ if use examples ; then
+ insinto /usr/share/doc/${PF}
+ doins testsniff.py
+ fi
+}
+
+src_test() {
+ # PYTHONPATH is set correctly in the test itself
+ "${python}" test.py || die "tests failed"
+}