summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenda XU <heroxbd@gentoo.org>2013-12-06 13:36:01 +0000
committerBenda XU <heroxbd@gentoo.org>2013-12-06 13:36:01 +0000
commitf012c8273c54fd6e68c0b36bb19e9aacd2760492 (patch)
treec753144eb42bddfc0bc10459b0cff740054d0d92 /dev-python/pyplusplus/pyplusplus-1.0.0_p20131206.ebuild
parentinitial inclusion (diff)
downloadhistorical-f012c8273c54fd6e68c0b36bb19e9aacd2760492.tar.gz
historical-f012c8273c54fd6e68c0b36bb19e9aacd2760492.tar.bz2
historical-f012c8273c54fd6e68c0b36bb19e9aacd2760492.zip
new snapshot with boost-numpy support.
Package-Manager: portage-2.2.7/cvs/Linux x86_64
Diffstat (limited to 'dev-python/pyplusplus/pyplusplus-1.0.0_p20131206.ebuild')
-rw-r--r--dev-python/pyplusplus/pyplusplus-1.0.0_p20131206.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/pyplusplus/pyplusplus-1.0.0_p20131206.ebuild b/dev-python/pyplusplus/pyplusplus-1.0.0_p20131206.ebuild
new file mode 100644
index 000000000000..8e198aea4269
--- /dev/null
+++ b/dev-python/pyplusplus/pyplusplus-1.0.0_p20131206.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyplusplus/pyplusplus-1.0.0_p20131206.ebuild,v 1.1 2013/12/06 13:35:53 heroxbd Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Object-oriented framework for creating a code generator for Boost.Python library"
+HOMEPAGE="http://www.language-binding.net/"
+
+if [[ ${PV} == 9999 ]]; then
+ ESVN_REPO_URI="http://svn.code.sf.net/p/pygccxml/svn/${PN}_dev"
+ inherit subversion
+ S=${WORKDIR}/${PN}_dev
+else
+ SRC_URI="http://dev.gentoo.org/~heroxbd/${P}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="freedist Boost-1.0"
+SLOT="0"
+IUSE="doc examples numpy"
+
+DEPEND="doc? ( >=dev-python/epydoc-3[${PYTHON_USEDEP}] )
+ app-arch/unzip
+ numpy? ( dev-python/numpy )"
+RDEPEND="dev-python/pygccxml[${PYTHON_USEDEP}]"
+
+src_prepare() {
+ use numpy && epatch "${FILESDIR}"/${PN}-1.0.0_p20131206-numpy.patch
+}
+
+python_compile_all() {
+ use doc && "$(PYTHON)" setup.py doc
+}
+
+python_test() {
+ "$(PYTHON)" unittests/test_all.py
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/documentation/apidocs/. )
+ use examples && local EXAMPLES=( examples/. )
+
+ distutils-r1_python_install_all
+}