summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLukasz Strzygowski <lucass@gentoo.org>2006-05-27 19:59:27 +0000
committerLukasz Strzygowski <lucass@gentoo.org>2006-05-27 19:59:27 +0000
commitbbabdaebc1cc9a43b71890f50541530b63baaf2e (patch)
tree3ef592dae870570747bcf0b1a348dda18c1185be /dev-python/pysqlite/pysqlite-2.2.2-r1.ebuild
parentVersion bump. (diff)
downloadhistorical-bbabdaebc1cc9a43b71890f50541530b63baaf2e.tar.gz
historical-bbabdaebc1cc9a43b71890f50541530b63baaf2e.tar.bz2
historical-bbabdaebc1cc9a43b71890f50541530b63baaf2e.zip
Fixed bug #134423.
Package-Manager: portage-2.1_rc1-r3
Diffstat (limited to 'dev-python/pysqlite/pysqlite-2.2.2-r1.ebuild')
-rw-r--r--dev-python/pysqlite/pysqlite-2.2.2-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/pysqlite/pysqlite-2.2.2-r1.ebuild b/dev-python/pysqlite/pysqlite-2.2.2-r1.ebuild
new file mode 100644
index 000000000000..7cfc9fd82a04
--- /dev/null
+++ b/dev-python/pysqlite/pysqlite-2.2.2-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pysqlite/pysqlite-2.2.2-r1.ebuild,v 1.1 2006/05/27 19:59:27 lucass Exp $
+
+inherit distutils
+
+DESCRIPTION="Python wrapper for the local database Sqlite"
+SRC_URI="http://initd.org/pub/software/pysqlite/releases/${PV:0:3}/${PV}/pysqlite-${PV}.tar.gz"
+HOMEPAGE="http://initd.org/tracker/pysqlite/"
+
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86"
+LICENSE="pysqlite"
+SLOT="2"
+IUSE=""
+
+DEPEND=">=dev-lang/python-2.3
+ >=dev-db/sqlite-3.1"
+
+src_install() {
+ distutils_src_install
+
+ mv "${D}"/usr/pysqlite2-doc/* "${D}"/usr/share/doc/${PF}
+ rm -rf "${D}"/usr/pysqlite2-doc
+}
+
+src_test() {
+ cd build/lib*
+ # tests use this as a nonexistant file
+ addpredict /foo/bar
+ PYTHONPATH=. "${python}" -c \
+ "from pysqlite2.test import test;import sys;sys.exit(test())" \
+ || die "test failed"
+}