summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2012-05-30 12:47:38 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2012-05-30 12:47:38 +0000
commitcf98f7158aff3738eb362ac82e29ec3be40f9414 (patch)
tree8c3ab77448d6f9c9e78afe42352361618e87c7dd /dev-python/python-musicbrainz-ngs/python-musicbrainz-ngs-0.2.ebuild
parentEnable tests, install documentation, drop empty (R)DEPEND (diff)
downloadhistorical-cf98f7158aff3738eb362ac82e29ec3be40f9414.tar.gz
historical-cf98f7158aff3738eb362ac82e29ec3be40f9414.tar.bz2
historical-cf98f7158aff3738eb362ac82e29ec3be40f9414.zip
Restrict not working ABIs, add proper PYTHON_DEPEND, enable tests, inherit vcs-snapshot to avoid messing with S, use github tarball instead of gentoo mirror, drop empty (R)DEPEND
Package-Manager: portage-2.2.0_alpha108/cvs/Linux x86_64
Diffstat (limited to 'dev-python/python-musicbrainz-ngs/python-musicbrainz-ngs-0.2.ebuild')
-rw-r--r--dev-python/python-musicbrainz-ngs/python-musicbrainz-ngs-0.2.ebuild15
1 files changed, 8 insertions, 7 deletions
diff --git a/dev-python/python-musicbrainz-ngs/python-musicbrainz-ngs-0.2.ebuild b/dev-python/python-musicbrainz-ngs/python-musicbrainz-ngs-0.2.ebuild
index 800bc63870db..3a6bda05dbab 100644
--- a/dev-python/python-musicbrainz-ngs/python-musicbrainz-ngs-0.2.ebuild
+++ b/dev-python/python-musicbrainz-ngs/python-musicbrainz-ngs-0.2.ebuild
@@ -1,20 +1,21 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-musicbrainz-ngs/python-musicbrainz-ngs-0.2.ebuild,v 1.2 2012/05/28 23:24:01 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-musicbrainz-ngs/python-musicbrainz-ngs-0.2.ebuild,v 1.3 2012/05/30 12:47:38 xarthisius Exp $
EAPI=4
-inherit distutils
+PYTHON_DEPEND="2:2.6"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.5 3.*"
+DISTUTILS_SRC_TEST=setup.py
+
+inherit distutils vcs-snapshot
DESCRIPTION="This library implements webservice bindings for the Musicbrainz NGS site"
HOMEPAGE="https://github.com/alastair/python-musicbrainz-ngs"
-# downloaded from git tag, no proper tarballs available
-SRC_URI="mirror://gentoo/${P}.tar.gz"
+SRC_URI="https://github.com/alastair/${PN}/tarball/v${PV} -> ${P}.tar.gz"
LICENSE="BSD-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
-
-DEPEND=""
-RDEPEND="${DEPEND}"