summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris PeBenito <pebenito@gentoo.org>2005-10-30 05:03:46 +0000
committerChris PeBenito <pebenito@gentoo.org>2005-10-30 05:03:46 +0000
commit7a441461247f9a1e24443689357cff7850663c40 (patch)
treedd537b3cfcf46e49f77f10bf10cfa9d8af999f0c /dev-python/python-selinux
parentInitial import. Thanks to iso, kobayashi and aisomur for the help at http://e... (diff)
downloadhistorical-7a441461247f9a1e24443689357cff7850663c40.tar.gz
historical-7a441461247f9a1e24443689357cff7850663c40.tar.bz2
historical-7a441461247f9a1e24443689357cff7850663c40.zip
new release
Package-Manager: portage-2.0.53_rc6
Diffstat (limited to 'dev-python/python-selinux')
-rw-r--r--dev-python/python-selinux/ChangeLog8
-rw-r--r--dev-python/python-selinux/Manifest19
-rw-r--r--dev-python/python-selinux/files/digest-python-selinux-2.160
-rw-r--r--dev-python/python-selinux/files/python-selinux-2.16.c.bz2bin0 -> 8500 bytes
-rw-r--r--dev-python/python-selinux/python-selinux-2.16.ebuild36
5 files changed, 59 insertions, 4 deletions
diff --git a/dev-python/python-selinux/ChangeLog b/dev-python/python-selinux/ChangeLog
index 3f25e9037195..4e6fa7a9333f 100644
--- a/dev-python/python-selinux/ChangeLog
+++ b/dev-python/python-selinux/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/python-selinux
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-selinux/ChangeLog,v 1.24 2005/05/10 18:33:41 spb Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-selinux/ChangeLog,v 1.25 2005/10/30 05:03:46 pebenito Exp $
+
+*python-selinux-2.16 (30 Oct 2005)
+
+ 30 Oct 2005; Chris PeBenito <pebenito@gentoo.org>
+ +files/python-selinux-2.16.c.bz2, +python-selinux-2.16.ebuild:
+ Overhaul error handling and SELinux-enable handling.
10 May 2005; Stephen Bennett <spb@gentoo.org> python-selinux-2.15.ebuild:
mips stable
diff --git a/dev-python/python-selinux/Manifest b/dev-python/python-selinux/Manifest
index a75f5c14c159..9815664d7893 100644
--- a/dev-python/python-selinux/Manifest
+++ b/dev-python/python-selinux/Manifest
@@ -1,5 +1,18 @@
-MD5 c998c579cfc08c6860f78304a67cfce9 metadata.xml 525
-MD5 7365a26803a8de9d0b9f28c8da46508d ChangeLog 3944
-MD5 c614ac830f5ecad17c6be55f351af604 python-selinux-2.15.ebuild 852
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+MD5 7e9124e45ea6ad95495161106fc8b040 ChangeLog 4158
MD5 d41d8cd98f00b204e9800998ecf8427e files/digest-python-selinux-2.15 0
+MD5 d41d8cd98f00b204e9800998ecf8427e files/digest-python-selinux-2.16 0
MD5 135bcb03bcb0dbed4e8bc354e1ff38f3 files/python-selinux-2.15.c.bz2 6831
+MD5 d5dc9417a58fe239af4d9e126be2ceff files/python-selinux-2.16.c.bz2 8500
+MD5 c998c579cfc08c6860f78304a67cfce9 metadata.xml 525
+MD5 c614ac830f5ecad17c6be55f351af604 python-selinux-2.15.ebuild 852
+MD5 301684f44998e3b41437cf5449a32967 python-selinux-2.16.ebuild 899
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.4.2 (GNU/Linux)
+
+iD8DBQFDZFRJJ+ChZlpDtAoRAiTgAJ9pHPG66dp8fdEtV5OzBurL6NbcTgCgjTqT
+F5xiIlVaOgqBBbzP+JvYZPw=
+=T8iF
+-----END PGP SIGNATURE-----
diff --git a/dev-python/python-selinux/files/digest-python-selinux-2.16 b/dev-python/python-selinux/files/digest-python-selinux-2.16
new file mode 100644
index 000000000000..e69de29bb2d1
--- /dev/null
+++ b/dev-python/python-selinux/files/digest-python-selinux-2.16
diff --git a/dev-python/python-selinux/files/python-selinux-2.16.c.bz2 b/dev-python/python-selinux/files/python-selinux-2.16.c.bz2
new file mode 100644
index 000000000000..65467ca0c868
--- /dev/null
+++ b/dev-python/python-selinux/files/python-selinux-2.16.c.bz2
Binary files differ
diff --git a/dev-python/python-selinux/python-selinux-2.16.ebuild b/dev-python/python-selinux/python-selinux-2.16.ebuild
new file mode 100644
index 000000000000..7bdec977a0d9
--- /dev/null
+++ b/dev-python/python-selinux/python-selinux-2.16.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-selinux/python-selinux-2.16.ebuild,v 1.1 2005/10/30 05:03:46 pebenito Exp $
+
+inherit python
+python_version
+
+DESCRIPTION="Python bindings for SELinux functions"
+HOMEPAGE="http://www.gentoo.org/proj/en/hardened/selinux/"
+LICENSE="GPL-2"
+SLOT="0"
+
+#KEYWORDS="x86 ppc sparc amd64 mips"
+KEYWORDS="~x86 ~ppc ~sparc ~amd64 ~mips"
+IUSE=""
+
+DEPEND="dev-lang/python
+ sys-libs/libselinux"
+
+S=${WORKDIR}/${PN}
+
+src_unpack() {
+ mkdir -p ${S}
+ bzcat ${FILESDIR}/${P}.c.bz2 > ${S}/selinux.c || die
+}
+
+src_compile() {
+ cd ${S}
+ einfo "Compiling selinux.so for python ${PYVER}"
+ gcc -fPIC -shared -o selinux.so -I /usr/include/python${PYVER}/ selinux.c -lselinux || die
+}
+
+src_install() {
+ insinto /usr/lib/python${PYVER}/site-packages
+ doins selinux.so
+}