summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2013-07-26 20:45:16 +0000
committerMichał Górny <mgorny@gentoo.org>2013-07-26 20:45:16 +0000
commit63ec32f739acda4e2c93e3c26d01826f8b8430d8 (patch)
tree8574dd928386cb569097fc36c610264c9a777bd4 /dev-python/pyudev/pyudev-0.16.1-r1.ebuild
parentApply upstream patch reverting a change that could cause problems with some e... (diff)
downloadhistorical-63ec32f739acda4e2c93e3c26d01826f8b8430d8.tar.gz
historical-63ec32f739acda4e2c93e3c26d01826f8b8430d8.tar.bz2
historical-63ec32f739acda4e2c93e3c26d01826f8b8430d8.zip
Convert to distutils-r1.
Package-Manager: portage-2.2.0_alpha189/cvs/Linux x86_64 Manifest-Sign-Key: 0x9627F456F9DA7643!
Diffstat (limited to 'dev-python/pyudev/pyudev-0.16.1-r1.ebuild')
-rw-r--r--dev-python/pyudev/pyudev-0.16.1-r1.ebuild68
1 files changed, 68 insertions, 0 deletions
diff --git a/dev-python/pyudev/pyudev-0.16.1-r1.ebuild b/dev-python/pyudev/pyudev-0.16.1-r1.ebuild
new file mode 100644
index 000000000000..0d103e3d35b8
--- /dev/null
+++ b/dev-python/pyudev/pyudev-0.16.1-r1.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyudev/pyudev-0.16.1-r1.ebuild,v 1.1 2013/07/26 20:45:09 mgorny Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7,3_2} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python binding to libudev"
+HOMEPAGE="http://packages.python.org/pyudev/ http://pypi.python.org/pypi/pyudev"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="pygobject pyqt4 pyside test"
+
+RDEPEND="virtual/udev
+ pygobject? ( dev-python/pygobject:2[$(python_gen_usedep 'python2*')] )
+ pyqt4? ( dev-python/PyQt4[${PYTHON_USEDEP}] )
+ pyside? ( dev-python/pyside[${PYTHON_USEDEP}] )"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/mock[${PYTHON_USEDEP}] )"
+
+DOCS=( CHANGES.rst README.rst )
+
+REQUIRED_USE="pygobject? ( || ( $(python_gen_useflags 'python2*') ) )"
+
+python_prepare_all() {
+ # tests are known to pass then fail on alternate runs
+ # tests: fix run_path
+ sed -i -e "s|== \('/run/udev'\)|in (\1,'/dev/.udev')|g" \
+ tests/test_core.py || die
+
+ if ! use pygobject; then
+ rm pyudev/glib.py || die
+ sed -i -e "s|[, ]*GlibBinding()||g" \
+ tests/test_observer.py || die
+ fi
+ if ! use pyqt4; then
+ rm pyudev/pyqt4.py || die
+ sed -i -e "s|Qt4Binding('PyQt4')[, ]*||g" \
+ tests/test_observer.py || die
+ fi
+ if ! use pyside; then
+ rm pyudev/pyside.py || die
+ sed -i -e "s|Qt4Binding('PySide')[, ]*||g" \
+ tests/test_observer.py || die
+ fi
+ if ! use pyqt4 && ! use pyside; then
+ rm pyudev/_qt_base.py || die
+ fi
+ if ! use pyqt4 && ! use pyside && ! use pygobject; then
+ rm tests/test_observer.py || die
+ fi
+
+ ewarn "If your PORTAGE_TMPDIR is longer in length then '/var/tmp/',"
+ ewarn "change it to /var/tmp to ensure tests will pass."
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ py.test || die "Tests fail with ${EPYTHON}"
+}