summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCarsten Lohrke <carlo@gentoo.org>2004-06-23 22:33:32 +0000
committerCarsten Lohrke <carlo@gentoo.org>2004-06-23 22:33:32 +0000
commit4f4401451b0a6a28c214087cca52a9018433908d (patch)
treee565b0562afba99479e7f48411be86bc6e99b643 /dev-python/sip/sip-4.0_rc2.ebuild
parentver bump #54842 (diff)
downloadhistorical-4f4401451b0a6a28c214087cca52a9018433908d.tar.gz
historical-4f4401451b0a6a28c214087cca52a9018433908d.tar.bz2
historical-4f4401451b0a6a28c214087cca52a9018433908d.zip
readd rc2
Diffstat (limited to 'dev-python/sip/sip-4.0_rc2.ebuild')
-rw-r--r--dev-python/sip/sip-4.0_rc2.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/sip/sip-4.0_rc2.ebuild b/dev-python/sip/sip-4.0_rc2.ebuild
new file mode 100644
index 000000000000..e76aba98c75e
--- /dev/null
+++ b/dev-python/sip/sip-4.0_rc2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/sip-4.0_rc2.ebuild,v 1.6 2004/06/23 22:33:32 carlo Exp $
+
+inherit distutils
+
+MY_P=${P/_/}
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="SIP is a tool for generating bindings for C++ classes so that they can be used by Python."
+HOMEPAGE="http://www.riverbankcomputing.co.uk/sip/"
+SRC_URI="mirror://gentoo/${MY_P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc amd64"
+IUSE=""
+
+DEPEND="virtual/glibc
+ x11-libs/qt
+ >=dev-lang/python-2.3"
+
+src_compile(){
+ distutils_python_version
+ python configure.py -l qt-mt \
+ -b /usr/bin \
+ -d /usr/lib/python${PYVER}/site-packages \
+ -e /usr/include/python${PYVER} \
+ "CXXFLAGS+=${CXXFLAGS}"
+ emake || die
+}
+
+src_install() {
+ einstall DESTDIR=${D} || die
+ dodoc ChangeLog LICENS NEWS README THANKS TODO
+}