summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2012-05-18 13:37:40 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2012-05-18 13:37:40 +0000
commit63253c5bcaf6407f4608b86165736e84843b78bc (patch)
tree41acdb01e386ae3ea959d17fe43d71517a4fb92a /dev-python/testify/testify-0.2.6.ebuild
parentDrop vulnerable version. (diff)
downloadhistorical-63253c5bcaf6407f4608b86165736e84843b78bc.tar.gz
historical-63253c5bcaf6407f4608b86165736e84843b78bc.tar.bz2
historical-63253c5bcaf6407f4608b86165736e84843b78bc.zip
Initial import, ebuild written by me
Package-Manager: portage-2.2.0_alpha105/cvs/Linux x86_64
Diffstat (limited to 'dev-python/testify/testify-0.2.6.ebuild')
-rw-r--r--dev-python/testify/testify-0.2.6.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/testify/testify-0.2.6.ebuild b/dev-python/testify/testify-0.2.6.ebuild
new file mode 100644
index 000000000000..150fc75e185c
--- /dev/null
+++ b/dev-python/testify/testify-0.2.6.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/testify/testify-0.2.6.ebuild,v 1.1 2012/05/18 13:37:40 xarthisius Exp $
+
+EAPI=4
+
+SUPPORT_PYTHON_ABIS=1
+# TODO: verify 2.5
+RESTRICT_PYTHON_ABIS="2.5 3.* 2.7-pypy-*"
+
+inherit eutils distutils vcs-snapshot
+
+DESCRIPTION="An sqlite-backed dictionary"
+HOMEPAGE="https://github.com/Yelp/testify http://pypi.python.org/pypi/testify/"
+SRC_URI="https://github.com/Yelp/${PN}/tarball/${PV} -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-python/pyyaml
+ dev-python/sqlalchemy
+ www-servers/tornado
+ || ( dev-lang/python:2.7 dev-lang/python:2.6 dev-python/simplejson )"
+DEPEND="dev-python/setuptools
+ test? ( ${RDEPEND} )"
+
+#DOCS="README.txt"
+
+src_prepare() {
+ distutils_src_prepare
+ epatch "${FILESDIR}"/${P}-tests.patch
+}
+
+src_test() {
+ testing() {
+ PYTHONPATH="build-${PYTHON_ABI}/lib/" "$(PYTHON)" bin/${PN} test
+ }
+ python_execute_function testing
+}