summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRob Cakebread <pythonhead@gentoo.org>2008-07-02 05:38:35 +0000
committerRob Cakebread <pythonhead@gentoo.org>2008-07-02 05:38:35 +0000
commita84a999ec20cf2c3931555298b125c4cc31f35e8 (patch)
tree61fc7bc08c3431ea7d2999af51828d18e1535c34 /dev-python/turbocheetah
parentVersion bump. Dropped amd64, ia64 and ppc because of new dependency on webtes... (diff)
downloadhistorical-a84a999ec20cf2c3931555298b125c4cc31f35e8.tar.gz
historical-a84a999ec20cf2c3931555298b125c4cc31f35e8.tar.bz2
historical-a84a999ec20cf2c3931555298b125c4cc31f35e8.zip
Version bump.
Package-Manager: portage-2.2_rc1/cvs/Linux 2.6.25-gentoo-r4 i686
Diffstat (limited to 'dev-python/turbocheetah')
-rw-r--r--dev-python/turbocheetah/ChangeLog10
-rw-r--r--dev-python/turbocheetah/turbocheetah-1.0.ebuild30
2 files changed, 38 insertions, 2 deletions
diff --git a/dev-python/turbocheetah/ChangeLog b/dev-python/turbocheetah/ChangeLog
index 3c5c597f34df..7f834ce8f0f3 100644
--- a/dev-python/turbocheetah/ChangeLog
+++ b/dev-python/turbocheetah/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/turbocheetah
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/turbocheetah/ChangeLog,v 1.2 2007/07/04 19:07:20 pythonhead Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/turbocheetah/ChangeLog,v 1.3 2008/07/02 05:38:35 pythonhead Exp $
+
+*turbocheetah-1.0 (02 Jul 2008)
+
+ 02 Jul 2008; Rob Cakebread <pythonhead@gentoo.org>
+ +turbocheetah-1.0.ebuild:
+ Version bump.
04 Jul 2007; Rob Cakebread <pythonhead@gentoo.org>
turbocheetah-0.9.5.ebuild:
diff --git a/dev-python/turbocheetah/turbocheetah-1.0.ebuild b/dev-python/turbocheetah/turbocheetah-1.0.ebuild
new file mode 100644
index 000000000000..a04716414d1b
--- /dev/null
+++ b/dev-python/turbocheetah/turbocheetah-1.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/turbocheetah/turbocheetah-1.0.ebuild,v 1.1 2008/07/02 05:38:35 pythonhead Exp $
+
+NEED_PYTHON=2.4
+
+inherit distutils
+
+KEYWORDS="~amd64 ~x86"
+
+MY_PN=TurboCheetah
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="TurboGears plugin to support use of Cheetah templates."
+HOMEPAGE="http://www.turbogears.org/docs/plugins/template.html"
+SRC_URI="http://cheeseshop.python.org/packages/source/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+LICENSE="MIT"
+SLOT="0"
+IUSE="test"
+
+RDEPEND=">=dev-python/cheetah-1.0"
+DEPEND="${RDEPEND}
+ test? ( dev-python/nose )
+ dev-python/setuptools"
+
+S=${WORKDIR}/${MY_P}
+
+src_test() {
+ PYTHONPATH=. nosetests || die "tests failed"
+}