summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Raschbacher <lordvan@gentoo.org>2005-04-08 13:59:49 +0000
committerThomas Raschbacher <lordvan@gentoo.org>2005-04-08 13:59:49 +0000
commitd4e023051324d11e8ff31286c4cafad9d781cbc3 (patch)
tree1adff1ce16fcf41747616adaa413090abf0440d5 /dev-python/twisted-web/twisted-web-0.5.0.ebuild
parentnew version (diff)
downloadhistorical-d4e023051324d11e8ff31286c4cafad9d781cbc3.tar.gz
historical-d4e023051324d11e8ff31286c4cafad9d781cbc3.tar.bz2
historical-d4e023051324d11e8ff31286c4cafad9d781cbc3.zip
initial import
Package-Manager: portage-2.0.51.19
Diffstat (limited to 'dev-python/twisted-web/twisted-web-0.5.0.ebuild')
-rw-r--r--dev-python/twisted-web/twisted-web-0.5.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/twisted-web/twisted-web-0.5.0.ebuild b/dev-python/twisted-web/twisted-web-0.5.0.ebuild
new file mode 100644
index 000000000000..4bdd56de07bf
--- /dev/null
+++ b/dev-python/twisted-web/twisted-web-0.5.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-web/twisted-web-0.5.0.ebuild,v 1.1 2005/04/08 13:59:49 lordvan Exp $
+
+inherit distutils
+
+# for alphas,..
+MY_PV="${PV/_alpha/a}"
+MY_PN="TwistedWeb"
+MY_P="${MY_PN}-${MY_PV}"
+DESCRIPTION="Twisted web has web servers and clients."
+HOMEPAGE="http://twistedmatrix.com/projects/web/"
+SRC_URI="http://tmrc.mit.edu/mirror/twisted/Web/0.5/${MY_P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~ppc ~alpha ~sparc"
+IUSE="doc"
+
+DEPEND=">=dev-python/twisted-2.0.0"
+
+S=${WORKDIR}/${MY_P}
+
+src_install() {
+ distutils_src_install
+
+ if use doc; then
+ dodir /usr/share/doc/${P}
+ cp -r ${S}/docs ${D}/usr/share/doc/${P}/
+ fi
+}