summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2012-01-17 06:24:19 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2012-01-17 06:24:19 +0000
commit12a9d6a0f2cad6129f9423ecc4d08744f13e7023 (patch)
treebd0e203bc788e81799bae1d5adaab781a99a0251 /dev-python
parentEAPI bump (diff)
downloadhistorical-12a9d6a0f2cad6129f9423ecc4d08744f13e7023.tar.gz
historical-12a9d6a0f2cad6129f9423ecc4d08744f13e7023.tar.bz2
historical-12a9d6a0f2cad6129f9423ecc4d08744f13e7023.zip
Version bump
Package-Manager: portage-2.1.10.41/cvs/Linux x86_64
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/apptools/ChangeLog10
-rw-r--r--dev-python/apptools/apptools-4.0.0.ebuild28
-rw-r--r--dev-python/apptools/apptools-4.0.1.ebuild54
-rw-r--r--dev-python/blockcanvas/ChangeLog10
-rw-r--r--dev-python/blockcanvas/blockcanvas-4.0.1.ebuild58
-rw-r--r--dev-python/chaco/ChangeLog9
-rw-r--r--dev-python/chaco/chaco-4.1.0.ebuild60
-rw-r--r--dev-python/enable/ChangeLog9
-rw-r--r--dev-python/enable/enable-4.1.0.ebuild59
-rw-r--r--dev-python/envisage/ChangeLog9
-rw-r--r--dev-python/envisage/envisage-4.1.0.ebuild50
-rw-r--r--dev-python/ets/ChangeLog9
-rw-r--r--dev-python/ets/ets-4.1.0.ebuild37
-rw-r--r--dev-python/etsproxy/ChangeLog9
-rw-r--r--dev-python/etsproxy/etsproxy-0.1.1.ebuild43
-rw-r--r--dev-python/pyface/ChangeLog9
-rw-r--r--dev-python/pyface/pyface-4.1.0.ebuild54
-rw-r--r--dev-python/scimath/ChangeLog9
-rw-r--r--dev-python/scimath/scimath-4.0.1.ebuild48
-rw-r--r--dev-python/traits/ChangeLog9
-rw-r--r--dev-python/traits/traits-4.1.0.ebuild48
-rw-r--r--dev-python/traitsui/ChangeLog9
-rw-r--r--dev-python/traitsui/traitsui-4.1.0.ebuild53
23 files changed, 652 insertions, 41 deletions
diff --git a/dev-python/apptools/ChangeLog b/dev-python/apptools/ChangeLog
index f0e746c6e6d5..1e4af623b2c2 100644
--- a/dev-python/apptools/ChangeLog
+++ b/dev-python/apptools/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/apptools
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/apptools/ChangeLog,v 1.12 2011/08/03 23:51:07 bicatali Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/apptools/ChangeLog,v 1.13 2012/01/17 06:16:44 bicatali Exp $
+
+*apptools-4.0.1 (17 Jan 2012)
+
+ 17 Jan 2012; Sébastien Fabbro <bicatali@gentoo.org> apptools-4.0.0.ebuild,
+ +apptools-4.0.1.ebuild:
+ Version bump
*apptools-4.0.0 (03 Aug 2011)
diff --git a/dev-python/apptools/apptools-4.0.0.ebuild b/dev-python/apptools/apptools-4.0.0.ebuild
index 5473ad6aa489..9aa6c70a5f48 100644
--- a/dev-python/apptools/apptools-4.0.0.ebuild
+++ b/dev-python/apptools/apptools-4.0.0.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/apptools/apptools-4.0.0.ebuild,v 1.1 2011/08/03 23:51:07 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/apptools/apptools-4.0.0.ebuild,v 1.2 2012/01/17 06:16:44 bicatali Exp $
-EAPI="3"
+EAPI=4
PYTHON_DEPEND="2"
SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.* *-jython"
+RESTRICT_PYTHON_ABIS="*-jython"
DISTUTILS_SRC_TEST="nosetests"
inherit distutils virtualx
@@ -21,7 +21,7 @@ IUSE="doc examples test"
RDEPEND="dev-python/configobj
dev-python/numpy
- >=dev-python/traits-4.0.0"
+ >=dev-python/traits-4.1.0"
DEPEND="dev-python/setuptools
doc? ( dev-python/sphinx )
test? (
@@ -33,12 +33,7 @@ DEPEND="dev-python/setuptools
src_compile() {
distutils_src_compile
- if use doc; then
- einfo "Generation of documentation"
- pushd docs > /dev/null
- emake html || die "Generation of documentation failed"
- popd > /dev/null
- fi
+ use doc && emake -C docs html
}
src_test() {
@@ -49,15 +44,10 @@ src_install() {
find -name "*LICENSE*.txt" -delete
distutils_src_install
- if use doc; then
- pushd docs/build/html > /dev/null
- insinto /usr/share/doc/${PF}/html
- doins -r [a-z]* _static || die "Installation of documentation failed"
- popd > /dev/null
- fi
+ use doc && dohtml -r docs/build/html/*
if use examples; then
- insinto /usr/share/doc/${PF}/examples
- doins -r examples/* || die "Installation of examples failed"
+ insinto /usr/share/doc/${PF}
+ doins -r examples
fi
}
diff --git a/dev-python/apptools/apptools-4.0.1.ebuild b/dev-python/apptools/apptools-4.0.1.ebuild
new file mode 100644
index 000000000000..06a55b4d4b9e
--- /dev/null
+++ b/dev-python/apptools/apptools-4.0.1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/apptools/apptools-4.0.1.ebuild,v 1.1 2012/01/17 06:16:44 bicatali Exp $
+
+EAPI=4
+
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
+DISTUTILS_SRC_TEST="nosetests"
+
+inherit distutils virtualx
+
+DESCRIPTION="Enthought Tool Suite: Application tools"
+HOMEPAGE="http://code.enthought.com/projects/app_tools/ http://pypi.python.org/pypi/apptools"
+SRC_URI="http://www.enthought.com/repo/ets/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples test"
+
+RDEPEND="dev-python/configobj
+ dev-python/numpy
+ >=dev-python/traits-4"
+DEPEND="dev-python/setuptools
+ doc? ( dev-python/sphinx )
+ test? (
+ ${RDEPEND}
+ >=dev-python/pyface-4
+ media-fonts/font-cursor-misc
+ media-fonts/font-misc-misc
+ )"
+
+src_compile() {
+ distutils_src_compile
+ use doc && emake -C docs html
+}
+
+src_test() {
+ VIRTUALX_COMMAND="distutils_src_test" virtualmake
+}
+
+src_install() {
+ find -name "*LICENSE*.txt" -delete
+ distutils_src_install
+
+ use doc && dohtml -r docs/build/html/*
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}
diff --git a/dev-python/blockcanvas/ChangeLog b/dev-python/blockcanvas/ChangeLog
index 30472872fff3..ca95aa6bb349 100644
--- a/dev-python/blockcanvas/ChangeLog
+++ b/dev-python/blockcanvas/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/blockcanvas
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/blockcanvas/ChangeLog,v 1.11 2011/08/03 23:58:18 bicatali Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/blockcanvas/ChangeLog,v 1.12 2012/01/17 06:17:23 bicatali Exp $
+
+*blockcanvas-4.0.1 (17 Jan 2012)
+
+ 17 Jan 2012; Sébastien Fabbro <bicatali@gentoo.org>
+ +blockcanvas-4.0.1.ebuild:
+ Version bump
*blockcanvas-4.0.0 (03 Aug 2011)
diff --git a/dev-python/blockcanvas/blockcanvas-4.0.1.ebuild b/dev-python/blockcanvas/blockcanvas-4.0.1.ebuild
new file mode 100644
index 000000000000..a4899f08c59a
--- /dev/null
+++ b/dev-python/blockcanvas/blockcanvas-4.0.1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/blockcanvas/blockcanvas-4.0.1.ebuild,v 1.1 2012/01/17 06:17:23 bicatali Exp $
+
+EAPI=4
+
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* -jython"
+DISTUTILS_SRC_TEST="nosetests"
+
+inherit distutils virtualx
+
+DESCRIPTION="Enthought Tool Suite: Numerical modeling"
+HOMEPAGE="http://code.enthought.com/projects/block_canvas/ http://pypi.python.org/pypi/blockcanvas"
+SRC_URI="http://www.enthought.com/repo/ets/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RDEPEND=">=dev-python/apptools-4
+ >=dev-python/chaco-4
+ >=dev-python/codetools-4
+ >=dev-python/etsdevtools-4
+ >=dev-python/pyface-4
+ >=dev-python/scimath-4
+ >=dev-python/traitsui-4
+ dev-python/configobj
+ dev-python/docutils
+ dev-python/greenlet
+ dev-python/imaging
+ dev-python/numpy"
+DEPEND="dev-python/setuptools
+ doc? ( dev-python/sphinx )
+ test? (
+ ${RDEPEND}
+ media-fonts/font-cursor-misc
+ media-fonts/font-misc-misc
+ )"
+
+DOCS="docs/*.txt"
+
+src_compile() {
+ distutils_src_compile
+ use doc && emake -C docs html
+}
+
+src_test() {
+ VIRTUALX_COMMAND="distutils_src_test" virtualmake
+}
+
+src_install() {
+ find -name "*LICENSE*.txt" -delete
+ distutils_src_install
+
+ use doc && dohtml -r docs/build/html/*
+}
diff --git a/dev-python/chaco/ChangeLog b/dev-python/chaco/ChangeLog
index cb35c0812289..5fe06b290818 100644
--- a/dev-python/chaco/ChangeLog
+++ b/dev-python/chaco/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/chaco
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/chaco/ChangeLog,v 1.11 2011/08/03 23:57:08 bicatali Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/chaco/ChangeLog,v 1.12 2012/01/17 06:17:57 bicatali Exp $
+
+*chaco-4.1.0 (17 Jan 2012)
+
+ 17 Jan 2012; Sébastien Fabbro <bicatali@gentoo.org> +chaco-4.1.0.ebuild:
+ Version bump
*chaco-4.0.0 (03 Aug 2011)
diff --git a/dev-python/chaco/chaco-4.1.0.ebuild b/dev-python/chaco/chaco-4.1.0.ebuild
new file mode 100644
index 000000000000..86f29d74e5ca
--- /dev/null
+++ b/dev-python/chaco/chaco-4.1.0.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/chaco/chaco-4.1.0.ebuild,v 1.1 2012/01/17 06:17:57 bicatali Exp $
+
+EAPI=4
+
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
+DISTUTILS_SRC_TEST="nosetests"
+
+inherit distutils virtualx
+
+DESCRIPTION="Enthought Tool Suite: Interactive plotting toolkit"
+HOMEPAGE="http://code.enthought.com/projects/chaco/ http://pypi.python.org/pypi/chaco"
+SRC_URI="http://www.enthought.com/repo/ets/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples test"
+
+RDEPEND=">=dev-python/enable-4
+ dev-python/numpy"
+DEPEND="dev-python/setuptools
+ dev-python/numpy
+ doc? (
+ >=dev-python/enable-4
+ media-fonts/font-cursor-misc
+ media-fonts/font-misc-misc
+ !prefix? ( x11-base/xorg-server[xvfb] )
+ x11-apps/xhost
+ )
+ test? (
+ >=dev-python/enable-4
+ media-fonts/font-cursor-misc
+ media-fonts/font-misc-misc
+ )"
+
+DOCS="docs/*.txt"
+
+src_compile() {
+ distutils_src_compile
+ use doc && virtualmake -C docs html
+}
+
+src_test() {
+ VIRTUALX_COMMAND="distutils_src_test" virtualmake
+}
+
+src_install() {
+ find -name "*LICENSE*.txt" -delete
+ distutils_src_install
+
+ use doc && dohtml -r docs/build/html/*
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}
diff --git a/dev-python/enable/ChangeLog b/dev-python/enable/ChangeLog
index 120cd532bb21..6421ddcd3585 100644
--- a/dev-python/enable/ChangeLog
+++ b/dev-python/enable/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/enable
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/enable/ChangeLog,v 1.14 2011/08/06 23:46:45 bicatali Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/enable/ChangeLog,v 1.15 2012/01/17 06:21:27 bicatali Exp $
+
+*enable-4.1.0 (17 Jan 2012)
+
+ 17 Jan 2012; Sébastien Fabbro <bicatali@gentoo.org> +enable-4.1.0.ebuild:
+ Version bump
06 Aug 2011; Sébastien Fabbro <bicatali@gentoo.org> enable-4.0.0.ebuild:
Syntax fix
diff --git a/dev-python/enable/enable-4.1.0.ebuild b/dev-python/enable/enable-4.1.0.ebuild
new file mode 100644
index 000000000000..ec3ff6eea711
--- /dev/null
+++ b/dev-python/enable/enable-4.1.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/enable/enable-4.1.0.ebuild,v 1.1 2012/01/17 06:21:27 bicatali Exp $
+
+EAPI=4
+
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
+DISTUTILS_SRC_TEST="nosetests"
+
+inherit distutils eutils virtualx
+
+DESCRIPTION="Enthought Tool Suite: Drawing and interaction packages"
+HOMEPAGE="http://code.enthought.com/projects/enable/ http://pypi.python.org/pypi/enable"
+SRC_URI="http://www.enthought.com/repo/ets/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples test"
+
+RDEPEND="dev-python/numpy
+ dev-python/reportlab
+ >=dev-python/traitsui-4
+ >=media-libs/freetype-2
+ virtual/opengl
+ x11-libs/libX11"
+DEPEND="dev-python/setuptools
+ dev-lang/swig
+ dev-python/cython
+ doc? ( dev-python/sphinx )
+ test? (
+ ${RDEPEND}
+ media-fonts/font-cursor-misc
+ media-fonts/font-misc-misc
+ )"
+
+DOCS="docs/*.txt"
+
+src_compile() {
+ distutils_src_compile
+ use doc && emake -C docs html
+}
+
+src_test() {
+ VIRTUALX_COMMAND="distutils_src_test" virtualmake
+}
+
+src_install() {
+ find -name "*LICENSE*.txt" -delete
+ distutils_src_install
+
+ use doc && dohtml -r docs/build/html/*
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}
diff --git a/dev-python/envisage/ChangeLog b/dev-python/envisage/ChangeLog
index 24590511e273..277b5ba3edea 100644
--- a/dev-python/envisage/ChangeLog
+++ b/dev-python/envisage/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/envisage
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/envisage/ChangeLog,v 1.1 2011/08/03 23:47:33 bicatali Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/envisage/ChangeLog,v 1.2 2012/01/17 06:21:52 bicatali Exp $
+
+*envisage-4.1.0 (17 Jan 2012)
+
+ 17 Jan 2012; Sébastien Fabbro <bicatali@gentoo.org> +envisage-4.1.0.ebuild:
+ Version bump
*envisage-4.0.0 (03 Aug 2011)
diff --git a/dev-python/envisage/envisage-4.1.0.ebuild b/dev-python/envisage/envisage-4.1.0.ebuild
new file mode 100644
index 000000000000..ca0d6ec229f0
--- /dev/null
+++ b/dev-python/envisage/envisage-4.1.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/envisage/envisage-4.1.0.ebuild,v 1.1 2012/01/17 06:21:52 bicatali Exp $
+
+EAPI=4
+
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
+DISTUTILS_SRC_TEST="nosetests"
+
+inherit distutils virtualx
+
+DESCRIPTION="Enthought Tool Suite: Extensible application framework"
+HOMEPAGE="http://code.enthought.com/projects/envisage/ http://pypi.python.org/pypi/envisage"
+SRC_URI="http://www.enthought.com/repo/ets/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples test"
+
+RDEPEND=">=dev-python/traits-4"
+DEPEND="dev-python/setuptools
+ doc? ( dev-python/sphinx )
+ test? (
+ >=dev-python/traits-4
+ media-fonts/font-cursor-misc
+ media-fonts/font-misc-misc
+ )"
+
+src_compile() {
+ distutils_src_compile
+ use doc && emake -C docs html
+}
+
+src_test() {
+ VIRTUALX_COMMAND="distutils_src_test" virtualmake
+}
+
+src_install() {
+ find -name "*LICENSE*.txt" -delete
+ distutils_src_install
+
+ use doc && dohtml -r docs/build/html/*
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}
diff --git a/dev-python/ets/ChangeLog b/dev-python/ets/ChangeLog
index 9da9bf6a099f..bdf93bf265a2 100644
--- a/dev-python/ets/ChangeLog
+++ b/dev-python/ets/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/ets
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/ets/ChangeLog,v 1.11 2011/08/05 22:18:34 bicatali Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/ets/ChangeLog,v 1.12 2012/01/17 06:22:22 bicatali Exp $
+
+*ets-4.1.0 (17 Jan 2012)
+
+ 17 Jan 2012; Sébastien Fabbro <bicatali@gentoo.org> +ets-4.1.0.ebuild:
+ Version bump
*ets-4.0.0-r1 (05 Aug 2011)
diff --git a/dev-python/ets/ets-4.1.0.ebuild b/dev-python/ets/ets-4.1.0.ebuild
new file mode 100644
index 000000000000..73f831ffac38
--- /dev/null
+++ b/dev-python/ets/ets-4.1.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/ets/ets-4.1.0.ebuild,v 1.1 2012/01/17 06:22:22 bicatali Exp $
+
+EAPI=4
+
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
+
+inherit distutils
+
+DESCRIPTION="Meta package for the Enthought Tool Suite"
+HOMEPAGE="http://code.enthought.com/projects/ http://pypi.python.org/pypi/ets"
+SRC_URI="http://www.enthought.com/repo/ets/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples"
+
+# see the setup_data.py file for version numbers
+RDEPEND="
+ >=dev-python/apptools-4.0.1[doc?,examples?]
+ >=dev-python/blockcanvas-4.0.1[doc?]
+ >=dev-python/chaco-4.1.0[doc?,examples?]
+ >=dev-python/codetools-4.0.0[doc?,examples?]
+ >=dev-python/enable-4.1.0[doc?,examples?]
+ >=dev-python/envisage-4.1.0[doc?,examples?]
+ >=dev-python/etsdevtools-4.0.0[doc?,examples?]
+ >=dev-python/graphcanvas-4.0.0[examples?]
+ >=sci-visualization/mayavi-4.1.0[doc?,examples?]
+ >=dev-python/pyface-4.1.0[doc?,examples?]
+ >=dev-python/scimath-4.0.1[doc?]
+ >=dev-python/traits-4.1.0[doc?,examples?]
+ >=dev-python/traitsui-4.1.0[doc?,examples?]"
+
+DEPEND=""
diff --git a/dev-python/etsproxy/ChangeLog b/dev-python/etsproxy/ChangeLog
index b651d8b6ce7b..15dcdf3d9cb7 100644
--- a/dev-python/etsproxy/ChangeLog
+++ b/dev-python/etsproxy/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/etsproxy
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/etsproxy/ChangeLog,v 1.2 2011/08/05 22:26:33 bicatali Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/etsproxy/ChangeLog,v 1.3 2012/01/17 06:22:48 bicatali Exp $
+
+*etsproxy-0.1.1 (17 Jan 2012)
+
+ 17 Jan 2012; Sébastien Fabbro <bicatali@gentoo.org> +etsproxy-0.1.1.ebuild:
+ Version bump
*etsproxy-0.1.0-r1 (05 Aug 2011)
diff --git a/dev-python/etsproxy/etsproxy-0.1.1.ebuild b/dev-python/etsproxy/etsproxy-0.1.1.ebuild
new file mode 100644
index 000000000000..4c2a235e07fa
--- /dev/null
+++ b/dev-python/etsproxy/etsproxy-0.1.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/etsproxy/etsproxy-0.1.1.ebuild,v 1.1 2012/01/17 06:22:48 bicatali Exp $
+
+EAPI=4
+
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
+
+inherit distutils
+
+DESCRIPTION="Enthought Tool Suite: Proxy modules for backwards compatibility"
+HOMEPAGE="http://pypi.python.org/pypi/etsproxy"
+SRC_URI="http://www.enthought.com/repo/ets/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="!<dev-python/apptools-4
+ !<dev-python/blockcanvas-4
+ !<dev-python/chaco-4
+ !<dev-python/codetools-4
+ !<dev-python/enable-4
+ !<dev-python/enthoughtbase-4
+ !<dev-python/envisagecore-4
+ !<dev-python/envisageplugins-4
+ !<dev-python/etsdevtools-4
+ !<dev-python/etsprojecttools-4
+ !<dev-python/graphcanvas-4
+ !<sci-visualization/mayavi-4
+ !<dev-python/scimath-4
+ !<dev-python/traits-4
+ !<dev-python/traitsbackendwx-4
+ !<dev-python/traitsbackendqt-4
+ !<dev-python/traitsgui-4"
+
+DEPEND="${RDEPEND}
+ dev-python/setuptools"
+
+PYTHON_MODNAME="enthought"
diff --git a/dev-python/pyface/ChangeLog b/dev-python/pyface/ChangeLog
index 06d7595419b9..3eb0c93a4029 100644
--- a/dev-python/pyface/ChangeLog
+++ b/dev-python/pyface/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/pyface
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyface/ChangeLog,v 1.1 2011/08/03 23:48:32 bicatali Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyface/ChangeLog,v 1.2 2012/01/17 06:23:19 bicatali Exp $
+
+*pyface-4.1.0 (17 Jan 2012)
+
+ 17 Jan 2012; Sébastien Fabbro <bicatali@gentoo.org> +pyface-4.1.0.ebuild:
+ Version bump
*pyface-4.0.0 (03 Aug 2011)
diff --git a/dev-python/pyface/pyface-4.1.0.ebuild b/dev-python/pyface/pyface-4.1.0.ebuild
new file mode 100644
index 000000000000..4e74ea78d9d9
--- /dev/null
+++ b/dev-python/pyface/pyface-4.1.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyface/pyface-4.1.0.ebuild,v 1.1 2012/01/17 06:23:19 bicatali Exp $
+
+EAPI=4
+
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
+DISTUTILS_SRC_TEST="nosetests"
+
+inherit distutils virtualx
+
+DESCRIPTION="Enthought Tool Suite: Traits-capable windowing framework"
+HOMEPAGE="https://github.com/enthought/pyface http://pypi.python.org/pypi/pyface"
+SRC_URI="http://www.enthought.com/repo/ets/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="doc examples test"
+
+RDEPEND=">=dev-python/traits-4.1
+ || ( dev-python/wxpython dev-python/PyQt4 dev-python/pyside )"
+DEPEND="dev-python/setuptools
+ doc? ( dev-python/sphinx )
+ test? (
+ ${RDEPEND}
+ dev-python/traitsui
+ media-fonts/font-cursor-misc
+ media-fonts/font-misc-misc
+ )"
+
+DOCS="docs/*.txt"
+
+src_compile() {
+ distutils_src_compile
+ use doc && emake -C docs html
+}
+
+src_test() {
+ VIRTUALX_COMMAND="distutils_src_test" virtualmake
+}
+
+src_install() {
+ find -name "*LICENSE*.txt" -delete
+ distutils_src_install
+
+ use doc && dohtml -r docs/build/html/*
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}
diff --git a/dev-python/scimath/ChangeLog b/dev-python/scimath/ChangeLog
index e9ef15b9788c..c5a5729070f1 100644
--- a/dev-python/scimath/ChangeLog
+++ b/dev-python/scimath/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/scimath
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/scimath/ChangeLog,v 1.9 2011/08/03 23:54:04 bicatali Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/scimath/ChangeLog,v 1.10 2012/01/17 06:23:50 bicatali Exp $
+
+*scimath-4.0.1 (17 Jan 2012)
+
+ 17 Jan 2012; Sébastien Fabbro <bicatali@gentoo.org> +scimath-4.0.1.ebuild:
+ Version bump
*scimath-4.0.0 (03 Aug 2011)
diff --git a/dev-python/scimath/scimath-4.0.1.ebuild b/dev-python/scimath/scimath-4.0.1.ebuild
new file mode 100644
index 000000000000..7d158a84de9b
--- /dev/null
+++ b/dev-python/scimath/scimath-4.0.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/scimath/scimath-4.0.1.ebuild,v 1.1 2012/01/17 06:23:50 bicatali Exp $
+
+EAPI=4
+
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
+DISTUTILS_SRC_TEST="nosetests"
+
+inherit distutils virtualx
+
+DESCRIPTION="Enthought Tool Suite: Scientific and mathematical tools"
+HOMEPAGE="http://code.enthought.com/projects/sci_math/ http://pypi.python.org/pypi/scimath"
+SRC_URI="http://www.enthought.com/repo/ets/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RDEPEND=">=dev-python/traits-4.1
+ >=dev-python/traitsui-4.1
+ sci-libs/scipy"
+DEPEND="dev-python/setuptools
+ doc? ( dev-python/sphinx )
+ test? (
+ ${RDEPEND}
+ media-fonts/font-cursor-misc
+ media-fonts/font-misc-misc
+ x11-apps/xhost
+ )"
+
+src_compile() {
+ distutils_src_compile
+ use doc && emake -C docs html
+}
+
+src_test() {
+ VIRTUALX_COMMAND="distutils_src_test" virtualmake
+}
+
+src_install() {
+ find -name "*LICENSE*.txt" -delete
+ distutils_src_install
+
+ use doc && dohtml -r docs/build/html/*
+}
diff --git a/dev-python/traits/ChangeLog b/dev-python/traits/ChangeLog
index 558a9969f9a0..d0f20580f681 100644
--- a/dev-python/traits/ChangeLog
+++ b/dev-python/traits/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/traits
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/traits/ChangeLog,v 1.26 2011/08/04 00:05:56 bicatali Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/traits/ChangeLog,v 1.27 2012/01/17 06:15:58 bicatali Exp $
+
+*traits-4.1.0 (17 Jan 2012)
+
+ 17 Jan 2012; Sébastien Fabbro <bicatali@gentoo.org> +traits-4.1.0.ebuild:
+ Version bump
04 Aug 2011; Sébastien Fabbro <bicatali@gentoo.org> traits-4.0.0.ebuild:
Typo
diff --git a/dev-python/traits/traits-4.1.0.ebuild b/dev-python/traits/traits-4.1.0.ebuild
new file mode 100644
index 000000000000..8e6d1006e6ea
--- /dev/null
+++ b/dev-python/traits/traits-4.1.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/traits/traits-4.1.0.ebuild,v 1.1 2012/01/17 06:15:58 bicatali Exp $
+
+EAPI=4
+
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
+DISTUTILS_SRC_TEST="nosetests"
+
+inherit distutils virtualx
+
+DESCRIPTION="Enthought Tool Suite: Explicitly typed attributes for Python"
+HOMEPAGE="http://code.enthought.com/projects/traits/ http://pypi.python.org/pypi/traits"
+SRC_URI="http://www.enthought.com/repo/ETS/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="doc examples test"
+
+RDEPEND="dev-python/numpy"
+DEPEND="dev-python/setuptools
+ doc? ( dev-python/sphinx )
+ test? ( dev-python/numpy )"
+
+DOCS="docs/*.txt"
+
+src_prepare() {
+ sed -i -e "s/'-O3'//g" setup.py
+}
+
+src_compile() {
+ distutils_src_compile
+ use doc && virtualmake -C docs html
+}
+
+src_install() {
+ find -name "*LICENSE*.txt" -delete
+ distutils_src_install
+
+ use doc && dohtml -r docs/build/html/*
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}
diff --git a/dev-python/traitsui/ChangeLog b/dev-python/traitsui/ChangeLog
index f9513a3bc509..54a1a444f689 100644
--- a/dev-python/traitsui/ChangeLog
+++ b/dev-python/traitsui/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/traitsui
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/traitsui/ChangeLog,v 1.1 2011/08/03 23:49:29 bicatali Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/traitsui/ChangeLog,v 1.2 2012/01/17 06:24:19 bicatali Exp $
+
+*traitsui-4.1.0 (17 Jan 2012)
+
+ 17 Jan 2012; Sébastien Fabbro <bicatali@gentoo.org> +traitsui-4.1.0.ebuild:
+ Version bump
*traitsui-4.0.1 (03 Aug 2011)
diff --git a/dev-python/traitsui/traitsui-4.1.0.ebuild b/dev-python/traitsui/traitsui-4.1.0.ebuild
new file mode 100644
index 000000000000..18e6c97e3c98
--- /dev/null
+++ b/dev-python/traitsui/traitsui-4.1.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/traitsui/traitsui-4.1.0.ebuild,v 1.1 2012/01/17 06:24:19 bicatali Exp $
+
+EAPI=4
+
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
+DISTUTILS_SRC_TEST="nosetests"
+
+inherit distutils virtualx
+
+DESCRIPTION="Enthought Tool Suite: Traits-capable user interfaces"
+HOMEPAGE="https://github.com/enthought/traitsui http://pypi.python.org/pypi/traitsui"
+SRC_URI="http://www.enthought.com/repo/ets/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="doc examples test"
+
+RDEPEND="dev-python/pyface
+ dev-python/traits"
+DEPEND="dev-python/setuptools
+ doc? ( dev-python/sphinx )
+ test? (
+ ${RDEPEND}
+ media-fonts/font-cursor-misc
+ media-fonts/font-misc-misc
+ )"
+
+DOCS="docs/*.txt"
+
+src_compile() {
+ distutils_src_compile
+ use doc && emake -C docs html
+}
+
+src_test() {
+ VIRTUALX_COMMAND="distutils_src_test" virtualmake
+}
+
+src_install() {
+ find -name "*LICENSE*.txt" -delete
+ distutils_src_install
+
+ use doc && dohtml -r docs/build/html/*
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}