summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-05-18 14:42:54 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-05-18 14:42:54 +0000
commit2cbc9ad932ec7820516630d0318168da5c0f46e8 (patch)
treeeabdbe492dcf9388585811e3ecd0becb0bf8ed2f /dev-python
parentStable for HPPA (bug #269186). (diff)
downloadhistorical-2cbc9ad932ec7820516630d0318168da5c0f46e8.tar.gz
historical-2cbc9ad932ec7820516630d0318168da5c0f46e8.tar.bz2
historical-2cbc9ad932ec7820516630d0318168da5c0f46e8.zip
Delete older ebuilds.
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/django/django-0.96.2.ebuild76
-rw-r--r--dev-python/django/django-1.0.2.ebuild108
-rw-r--r--dev-python/django/django-1.0.ebuild76
-rw-r--r--dev-python/django/files/django-1.0-fields.py.patch14
4 files changed, 0 insertions, 274 deletions
diff --git a/dev-python/django/django-0.96.2.ebuild b/dev-python/django/django-0.96.2.ebuild
deleted file mode 100644
index 06f762f13e55..000000000000
--- a/dev-python/django/django-0.96.2.ebuild
+++ /dev/null
@@ -1,76 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/django/django-0.96.2.ebuild,v 1.2 2008/08/19 09:25:27 hawking Exp $
-
-inherit bash-completion distutils eutils versionator
-
-RPV=$(get_version_component_range 1-2)
-EXTRAS_VERSION="0.96.1"
-
-MY_P="Django-${PV}"
-
-DESCRIPTION="high-level python web framework"
-HOMEPAGE="http://www.djangoproject.com/"
-SRC_URI="http://media.djangoproject.com/releases/${RPV}/${MY_P}.tar.gz
- http://media.djangoproject.com/releases/${RPV}/Django-${EXTRAS_VERSION}.tar.gz"
- # We need ${EXTRAS_VERSION} in SRC_URI, because it's the last release that
- # contains extras, tests and examples, see also src_unpack
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~x86"
-IUSE="examples mysql postgres sqlite test"
-
-RDEPEND="dev-python/imaging
- sqlite? ( || (
- ( >=dev-python/pysqlite-2.0.3 <dev-lang/python-2.5 )
- >=dev-lang/python-2.5 ) )
- test? ( || (
- ( >=dev-python/pysqlite-2.0.3 <dev-lang/python-2.5 )
- >=dev-lang/python-2.5 ) )
- postgres? ( dev-python/psycopg )
- mysql? ( >=dev-python/mysql-python-1.2.1_p2 )"
-DEPEND="${RDEPEND}"
-
-S="${WORKDIR}/${MY_P}"
-
-DOCS="docs/* AUTHORS"
-
-src_unpack() {
-
- distutils_src_unpack
-
- # Those directories are missing from 0.96.2, so we copy them over from
- # Django-${EXTRAS_VERSION}:
- cp -pPR "${WORKDIR}/Django-${EXTRAS_VERSION}/examples" "${S}/" || die
- cp -pPR "${WORKDIR}/Django-${EXTRAS_VERSION}/extras" "${S}/" || die
- cp -pPR "${WORKDIR}/Django-${EXTRAS_VERSION}/tests" "${S}/" || die
- cp -pPR "${WORKDIR}/Django-${EXTRAS_VERSION}/django/contrib/formtools/templates" \
- "${S}/django/contrib/formtools/" || die
-
-}
-
-src_test() {
- cat >> tests/settings.py << __EOF__
-DATABASE_ENGINE='sqlite3'
-ROOT_URLCONF='tests/urls.py'
-SITE_ID=1
-__EOF__
- PYTHONPATH="." ${python} tests/runtests.py --settings=settings -v1 || die "tests failed"
-}
-
-src_install() {
- distutils_python_version
-
- site_pkgs="/usr/$(get_libdir)/python${PYVER}/site-packages/"
- export PYTHONPATH="${PYTHONPATH}:${D}/${site_pkgs}"
- dodir ${site_pkgs}
-
- distutils_src_install
-
- dobashcompletion extras/django_bash_completion
-
- if use examples ; then
- insinto /usr/share/doc/${PF}
- doins -r examples
- fi
-}
diff --git a/dev-python/django/django-1.0.2.ebuild b/dev-python/django/django-1.0.2.ebuild
deleted file mode 100644
index f72c576c0a1b..000000000000
--- a/dev-python/django/django-1.0.2.ebuild
+++ /dev/null
@@ -1,108 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/django/django-1.0.2.ebuild,v 1.1 2009/02/03 09:21:28 patrick Exp $
-EAPI=2
-
-inherit bash-completion subversion distutils multilib versionator webapp
-
-MY_P="${P/#d/D}-final"
-WEBAPP_MANUAL_SLOT="yes"
-
-DESCRIPTION="High-level python web framework"
-HOMEPAGE="http://www.djangoproject.com/"
-SRC_URI="http://media.djangoproject.com/releases/${PV}/${MY_P}.tar.gz"
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86"
-IUSE="doc examples mysql postgres sqlite3 test"
-
-RDEPEND="dev-python/imaging
- sqlite3? ( || (
- ( dev-python/pysqlite:2 <dev-lang/python-2.5 )
- >=dev-lang/python-2.5[sqlite] ) )
- test? ( || (
- ( dev-python/pysqlite:2 <dev-lang/python-2.5 )
- >=dev-lang/python-2.5[sqlite] ) )
- postgres? ( dev-python/psycopg )
- mysql? ( >=dev-python/mysql-python-1.2.1_p2 )
- doc? ( >=dev-python/sphinx-0.3 )"
-DEPEND="${RDEPEND}"
-
-S="${WORKDIR}/${MY_P}"
-
-DOCS="docs/* AUTHORS"
-
-src_unpack() {
- distutils_src_unpack
- if use test; then
- local repo_uri
- repo_uri="http://code.djangoproject.com/svn/${PN}/tags/releases/${PV}/tests/"
- subversion_fetch ${repo_uri} tests
- fi
-}
-
-src_compile() {
- distutils_src_compile
- if use doc ; then
- pushd docs
- emake html || die "docs failed"
- popd
- fi
-}
-
-src_test() {
- einfo "Running tests."
- cat >> tests/settings.py << __EOF__
-DATABASE_ENGINE='sqlite3'
-ROOT_URLCONF='tests/urls.py'
-SITE_ID=1
-__EOF__
- PYTHONPATH="." ${python} tests/runtests.py --settings=settings -v1 \
- || die "tests failed"
-}
-
-src_install() {
- distutils_python_version
- site_pkgs="$(python_get_sitedir)"
- export PYTHONPATH="${PYTHONPATH}:${D}/${site_pkgs}"
- dodir ${site_pkgs}
-
- distutils_src_install
-
- dobashcompletion extras/django_bash_completion
-
- if use examples ; then
- insinto /usr/share/doc/${PF}
- doins -r examples
- fi
- if use doc ; then
- mv docs/_build/html/{_,.}sources
- dohtml txt -r docs/_build/html/*
- fi
-
- insinto "${MY_HTDOCSDIR}"
- doins -r "${D}/${site_pkgs}"/django/contrib/admin/media/*
-
- #webapp_postinst_txt en "${WORKDIR}"/postinstall-en.txt
- webapp_src_install
-}
-
-pkg_preinst() {
- :
-}
-
-pkg_postinst() {
- bash-completion_pkg_postinst
- einfo "Now, Django has the best of both worlds with Gentoo,"
- einfo "ease of deployment for production and development."
- echo
- elog "A copy of the admin media is available to"
- elog "webapp-config for installation in a webroot,"
- elog "as well as the traditional location in python's"
- elog "site-packages dir for easy development"
- echo
- echo
- ewarn "If you build Django-1.0.2 without USE=\"vhosts\""
- ewarn "webapp-config will automatically install the"
- ewarn "admin media into the localhost webroot."
-}
diff --git a/dev-python/django/django-1.0.ebuild b/dev-python/django/django-1.0.ebuild
deleted file mode 100644
index d0dff48f145e..000000000000
--- a/dev-python/django/django-1.0.ebuild
+++ /dev/null
@@ -1,76 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/django/django-1.0.ebuild,v 1.5 2008/11/05 01:17:05 fmccor Exp $
-
-EAPI="1"
-inherit bash-completion distutils versionator
-
-DESCRIPTION="high-level python web framework"
-HOMEPAGE="http://www.djangoproject.com/"
-SRC_URI="http://media.djangoproject.com/releases/${PV}/Django-${PV}.tar.gz"
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86"
-IUSE="doc examples mysql postgres sqlite3 test"
-
-RDEPEND="dev-python/imaging
- sqlite3? ( || (
- ( dev-python/pysqlite:2 <dev-lang/python-2.5 )
- >=dev-lang/python-2.5 ) )
- test? ( || (
- ( dev-python/pysqlite:2 <dev-lang/python-2.5 )
- >=dev-lang/python-2.5 ) )
- postgres? ( dev-python/psycopg )
- mysql? ( >=dev-python/mysql-python-1.2.1_p2 )
- doc? ( >=dev-python/sphinx-0.3 )"
-DEPEND="${RDEPEND}"
-
-S="${WORKDIR}/${P/#d/D}"
-
-DOCS="docs/* AUTHORS"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- #Submitted upstream http://code.djangoproject.com/ticket/8865
- #by pythonhead, accepted in trunk
- epatch "${FILESDIR}/${P}"-fields.py.patch
-}
-
-src_compile() {
- distutils_src_compile
- if use doc ; then
- cd docs
- emake html || die "docs failed"
- fi
-}
-
-src_test() {
- cat >> tests/settings.py << __EOF__
-DATABASE_ENGINE='sqlite3'
-ROOT_URLCONF='tests/urls.py'
-SITE_ID=1
-__EOF__
- PYTHONPATH="." ${python} tests/runtests.py --settings=settings -v1 || die "tests failed"
-}
-
-src_install() {
- distutils_python_version
-
- site_pkgs="$(python_get_sitedir)"
- export PYTHONPATH="${PYTHONPATH}:${D}/${site_pkgs}"
- dodir ${site_pkgs}
-
- distutils_src_install
-
- dobashcompletion extras/django_bash_completion
-
- if use examples ; then
- insinto /usr/share/doc/${PF}
- doins -r examples
- fi
- if use doc ; then
- rm -Rf docs/_build/html/_sources
- dohtml txt -r docs/_build/html/*
- fi
-}
diff --git a/dev-python/django/files/django-1.0-fields.py.patch b/dev-python/django/files/django-1.0-fields.py.patch
deleted file mode 100644
index e3bc9d11ed81..000000000000
--- a/dev-python/django/files/django-1.0-fields.py.patch
+++ /dev/null
@@ -1,14 +0,0 @@
---- tests/regressiontests/forms/fields.py.old 2008-09-06 11:13:31.000000000 -0700
-+++ tests/regressiontests/forms/fields.py 2008-09-06 11:16:06.000000000 -0700
-@@ -1300,9 +1300,10 @@
- >>> fix_os_paths(path)
- '.../django/forms/'
- >>> f = forms.FilePathField(path=path)
-+>>> f.choices = [p for p in f.choices if not p[0].endswith('.pyc')]
- >>> f.choices.sort()
- >>> fix_os_paths(f.choices)
--[('.../django/forms/__init__.py', '__init__.py'), ('.../django/forms/__init__.pyc', '__init__.pyc'), ('.../django/forms/fields.py', 'fields.py'), ('.../django/forms/fields.pyc', 'fields.pyc'), ('.../django/forms/forms.py', 'forms.py'), ('.../django/forms/forms.pyc', 'forms.pyc'), ('.../django/forms/models.py', 'models.py'), ('.../django/forms/models.pyc', 'models.pyc'), ('.../django/forms/util.py', 'util.py'), ('.../django/forms/util.pyc', 'util.pyc'), ('.../django/forms/widgets.py', 'widgets.py'), ('.../django/forms/widgets.pyc', 'widgets.pyc')]
-+[('.../django/forms/__init__.py', '__init__.py'), ('.../django/forms/fields.py', 'fields.py'), ('.../django/forms/forms.py', 'forms.py'), ('.../django/forms/models.py', 'models.py'), ('.../django/forms/util.py', 'util.py'), ('.../django/forms/widgets.py', 'widgets.py')]
- >>> f.clean('fields.py')
- Traceback (most recent call last):
- ...