summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-03-01 16:42:56 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-03-01 16:42:56 +0000
commit95ca9e92308e15a697007d7a319bbb344670669c (patch)
treeeecba3a2d64d67ea8c955f0c535d4ce06d9c550c /dev-python
parentVersion bump. (diff)
downloadhistorical-95ca9e92308e15a697007d7a319bbb344670669c.tar.gz
historical-95ca9e92308e15a697007d7a319bbb344670669c.tar.bz2
historical-95ca9e92308e15a697007d7a319bbb344670669c.zip
Delete older ebuild.
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/spyder/spyder-2.0.6.ebuild57
1 files changed, 0 insertions, 57 deletions
diff --git a/dev-python/spyder/spyder-2.0.6.ebuild b/dev-python/spyder/spyder-2.0.6.ebuild
deleted file mode 100644
index eec03f3c4836..000000000000
--- a/dev-python/spyder/spyder-2.0.6.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/spyder/spyder-2.0.6.ebuild,v 1.1 2011/01/10 18:00:15 arfrever Exp $
-
-EAPI="3"
-PYTHON_DEPEND="2:2.5"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="2.4 3.* *-jython"
-
-inherit distutils eutils
-
-DESCRIPTION="Python IDE with matlab-like features"
-HOMEPAGE="http://code.google.com/p/spyderlib/ http://pypi.python.org/pypi/spyder"
-SRC_URI="http://spyderlib.googlecode.com/files/${P}.zip"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc ipython matplotlib numpy +pyflakes pylint +rope scipy"
-
-RDEPEND=">=dev-python/PyQt4-4.4[webkit]
- ipython? ( dev-python/ipython )
- matplotlib? ( dev-python/matplotlib )
- numpy? ( dev-python/numpy )
- pyflakes? ( >=dev-python/pyflakes-0.3 )
- pylint? ( dev-python/pylint )
- rope? ( >=dev-python/rope-0.9.0 )
- scipy? ( sci-libs/scipy )"
-DEPEND="${RDEPEND}
- doc? ( dev-python/sphinx )"
-
-PYTHON_MODNAME="spyderlib spyderplugins"
-
-src_prepare() {
- distutils_src_prepare
- epatch "${FILESDIR}/${PN}-2.0.4-disable_sphinx_dependency.patch"
-}
-
-src_compile() {
- distutils_src_compile
-
- if use doc; then
- einfo "Generation of documentation"
- PYTHONPATH="build-$(PYTHON -f --ABI)" sphinx-build doc doc_output || die "Generation of documentation failed"
- fi
-}
-
-src_install() {
- distutils_src_install
-
- if use doc; then
- pushd doc_output > /dev/null
- insinto /usr/share/doc/${PF}/html
- doins -r [a-z]* _images _static || die "Installation of documentation failed"
- popd > /dev/null
- fi
-}