summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-05-16 21:22:18 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-05-16 21:22:18 +0000
commitc8d12f2ce700d66f984510b181676599d5ae4c4f (patch)
treec046ad19761679bee1ca2935bf2fed06ba0dafc7 /dev-python
parentVersion bump. (diff)
downloadhistorical-c8d12f2ce700d66f984510b181676599d5ae4c4f.tar.gz
historical-c8d12f2ce700d66f984510b181676599d5ae4c4f.tar.bz2
historical-c8d12f2ce700d66f984510b181676599d5ae4c4f.zip
Fix building with Python 2.6 (bug #267638).
Package-Manager: portage-13623-svn/cvs/Linux x86_64
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/dpkt/ChangeLog8
-rw-r--r--dev-python/dpkt/Manifest5
-rw-r--r--dev-python/dpkt/dpkt-1.6.ebuild14
-rw-r--r--dev-python/dpkt/files/dpkt-1.6-python-2.6.patch47
4 files changed, 66 insertions, 8 deletions
diff --git a/dev-python/dpkt/ChangeLog b/dev-python/dpkt/ChangeLog
index 2ff2e34ebe8a..672498d3cb9a 100644
--- a/dev-python/dpkt/ChangeLog
+++ b/dev-python/dpkt/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/dpkt
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/dpkt/ChangeLog,v 1.2 2007/06/23 07:24:31 lucass Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/dpkt/ChangeLog,v 1.3 2009/05/16 21:22:18 arfrever Exp $
+
+ 16 May 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ dpkt-1.6.ebuild, +files/dpkt-1.6-python-2.6.patch:
+ Fix building with Python 2.6 (bug #267638).
23 Jun 2007; Lukasz Strzygowski <lucass@gentoo.org> dpkt-1.6.ebuild:
Marked ~amd64.
diff --git a/dev-python/dpkt/Manifest b/dev-python/dpkt/Manifest
index 44a0736695a2..57b8602c1bec 100644
--- a/dev-python/dpkt/Manifest
+++ b/dev-python/dpkt/Manifest
@@ -1,4 +1,5 @@
+AUX dpkt-1.6-python-2.6.patch 1542 RMD160 84028ff8236620cbc8a1d25183dd38be63518e04 SHA1 d088558ef680aac9e5138c14d7ff34ddbaa33d0e SHA256 4ce022c80e0d7e275b29c946dda10cfdd6808de3ec2ee1e33dfd35be84569384
DIST dpkt-1.6.tar.gz 116518 RMD160 e6e5f5a5d439d7c6eb165f5899903c167fd21551 SHA1 2a5ee8b44968b38ad4ee15112212ffc0ed2d8a5a SHA256 65493079b94e945ef1bf05ef2986ce61a13058776f8430d509c2e6ead06e0ec5
-EBUILD dpkt-1.6.ebuild 773 RMD160 0893a3c61e65c967324ceb1ee637160c4bdf9fca SHA1 b1387e1fbcedfdcc51ac63bb24251b33301c41bb SHA256 7af623d9c21b188dae4734f36cbeec97d5165c4964a96d57abad83c0e66cae17
-MISC ChangeLog 448 RMD160 ba653f6c9ff4d84f53bdb523afb05d1a2e747f37 SHA1 c5a5b2c2280f8b0b9d09eaf874e25466ce15a4a9 SHA256 fc21979f17a4b95bd126fb8f2d2690e957189c1a3fac61abc5f6fd198c108d20
+EBUILD dpkt-1.6.ebuild 857 RMD160 d25db44d3fde25d77e5328a7e5c9f519f9ab5e2f SHA1 d3e08f81471a268451df909899300c3a3d799653 SHA256 e4d0b052764aec7b85ec782c84c84c7b58c46fd1f01f7b353f468887fa405e58
+MISC ChangeLog 623 RMD160 0fc4f070ca011477cb180d73e8bf2311eb3badfb SHA1 92fef63750d2152e4a761ba8cfa5f24c9743117d SHA256 f3b4ebc48e8e62727e1bfc6f5c3e8d7f80de1cc8c81e8bb071c253e1f5d3983a
MISC metadata.xml 159 RMD160 900a8c55d7a7d2f6312594769aaf941bf9e99c7f SHA1 c8e604d56dae898258b5254d78cfeac0b981e288 SHA256 9f01104d3484792496faff4805eed0ecea2352a897151f3397d49a13800037b4
diff --git a/dev-python/dpkt/dpkt-1.6.ebuild b/dev-python/dpkt/dpkt-1.6.ebuild
index e686d998c797..85dc106c1c17 100644
--- a/dev-python/dpkt/dpkt-1.6.ebuild
+++ b/dev-python/dpkt/dpkt-1.6.ebuild
@@ -1,10 +1,12 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/dpkt/dpkt-1.6.ebuild,v 1.2 2007/06/23 07:24:31 lucass Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/dpkt/dpkt-1.6.ebuild,v 1.3 2009/05/16 21:22:18 arfrever Exp $
-NEED_PYTHON=2.3
+EAPI="2"
-inherit distutils
+NEED_PYTHON="2.3"
+
+inherit distutils eutils
DESCRIPTION="Fast, simple packet creation / parsing, with definitions for the basic TCP/IP protocols."
HOMEPAGE="http://code.google.com/p/dpkt/"
@@ -18,6 +20,10 @@ IUSE="examples"
DEPEND=""
RDEPEND=""
+src_prepare() {
+ epatch "${FILESDIR}/${P}-python-2.6.patch"
+}
+
src_install() {
DOCS="HACKING AUTHORS CHANGES"
distutils_src_install
diff --git a/dev-python/dpkt/files/dpkt-1.6-python-2.6.patch b/dev-python/dpkt/files/dpkt-1.6-python-2.6.patch
new file mode 100644
index 000000000000..9a709802f4b5
--- /dev/null
+++ b/dev-python/dpkt/files/dpkt-1.6-python-2.6.patch
@@ -0,0 +1,47 @@
+--- dpkt/bgp.py
++++ dpkt/bgp.py
+@@ -140,7 +140,7 @@
+ class Open(dpkt.Packet):
+ __hdr__ = (
+ ('v', 'B', 4),
+- ('as', 'H', 0),
++ ('as_', 'H', 0),
+ ('holdtime', 'H', 0),
+ ('identifier', 'I', 0),
+ ('param_len', 'B', 0)
+@@ -401,7 +401,7 @@
+
+ class Aggregator(dpkt.Packet):
+ __hdr__ = (
+- ('as', 'H', 0),
++ ('as_', 'H', 0),
+ ('ip', 'I', 0)
+ )
+
+@@ -428,7 +428,7 @@
+
+ class Community(dpkt.Packet):
+ __hdr__ = (
+- ('as', 'H', 0),
++ ('as_', 'H', 0),
+ ('value', 'H', 0)
+ )
+
+@@ -675,7 +675,7 @@
+ self.failUnless(a.len == 12)
+ self.failUnless(len(a.communities.list) == 3)
+ c = a.communities.list[0]
+- self.failUnless(c.as == 65215)
++ self.failUnless(c.as_ == 65215)
+ self.failUnless(c.value == 1)
+ r = b2.update.announced[0]
+ self.failUnless(r.len == 22)
+@@ -712,7 +712,7 @@
+ b4 = BGP(self.bgp4)
+ self.failUnless(b4.len == 45)
+ self.failUnless(b4.type == OPEN)
+- self.failUnless(b4.open.as == 237)
++ self.failUnless(b4.open.as_ == 237)
+ self.failUnless(b4.open.param_len == 16)
+ self.failUnless(len(b4.open.parameters) == 3)
+ p = b4.open.parameters[0]