summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarien Zwart <marienz@gentoo.org>2012-10-05 14:46:45 +0000
committerMarien Zwart <marienz@gentoo.org>2012-10-05 14:46:45 +0000
commite37255a5749ff154f224cbf4da5dfebebe1b3104 (patch)
tree4001a5d652225b14edc4ed0e2301a95ac8b291a8 /dev-python
parentBump for Zabbix 2.0.3 (diff)
downloadhistorical-e37255a5749ff154f224cbf4da5dfebebe1b3104.tar.gz
historical-e37255a5749ff154f224cbf4da5dfebebe1b3104.tar.bz2
historical-e37255a5749ff154f224cbf4da5dfebebe1b3104.zip
Restrict pypy in twisted < 11.1.0 (bug #420653).
Package-Manager: portage-2.2.0_alpha135/cvs/Linux x86_64
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/twisted-conch/ChangeLog6
-rw-r--r--dev-python/twisted-conch/twisted-conch-10.2.0.ebuild4
-rw-r--r--dev-python/twisted-conch/twisted-conch-11.0.0.ebuild4
-rw-r--r--dev-python/twisted-lore/ChangeLog6
-rw-r--r--dev-python/twisted-lore/twisted-lore-10.2.0.ebuild6
-rw-r--r--dev-python/twisted-lore/twisted-lore-11.0.0.ebuild6
-rw-r--r--dev-python/twisted-mail/ChangeLog6
-rw-r--r--dev-python/twisted-mail/twisted-mail-10.2.0.ebuild6
-rw-r--r--dev-python/twisted-mail/twisted-mail-11.0.0.ebuild6
-rw-r--r--dev-python/twisted-names/ChangeLog6
-rw-r--r--dev-python/twisted-names/twisted-names-10.2.0.ebuild6
-rw-r--r--dev-python/twisted-names/twisted-names-11.0.0.ebuild6
-rw-r--r--dev-python/twisted-news/ChangeLog6
-rw-r--r--dev-python/twisted-news/twisted-news-10.2.0.ebuild6
-rw-r--r--dev-python/twisted-news/twisted-news-11.0.0.ebuild6
-rw-r--r--dev-python/twisted-runner/ChangeLog6
-rw-r--r--dev-python/twisted-runner/twisted-runner-10.2.0.ebuild6
-rw-r--r--dev-python/twisted-runner/twisted-runner-11.0.0.ebuild4
-rw-r--r--dev-python/twisted-web/ChangeLog6
-rw-r--r--dev-python/twisted-web/twisted-web-10.2.0.ebuild6
-rw-r--r--dev-python/twisted-web/twisted-web-11.0.0.ebuild6
-rw-r--r--dev-python/twisted-words/ChangeLog6
-rw-r--r--dev-python/twisted-words/twisted-words-10.2.0-r1.ebuild6
-rw-r--r--dev-python/twisted-words/twisted-words-11.0.0.ebuild4
-rw-r--r--dev-python/twisted/ChangeLog6
-rw-r--r--dev-python/twisted/twisted-10.2.0.ebuild6
-rw-r--r--dev-python/twisted/twisted-11.0.0.ebuild6
27 files changed, 95 insertions, 59 deletions
diff --git a/dev-python/twisted-conch/ChangeLog b/dev-python/twisted-conch/ChangeLog
index 1a51e8eb03b9..fc2bc5fe2d92 100644
--- a/dev-python/twisted-conch/ChangeLog
+++ b/dev-python/twisted-conch/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/twisted-conch
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-conch/ChangeLog,v 1.81 2012/09/27 18:15:49 marienz Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-conch/ChangeLog,v 1.82 2012/10/05 14:45:03 marienz Exp $
+
+ 05 Oct 2012; Marien Zwart <marienz@gentoo.org> twisted-conch-10.2.0.ebuild,
+ twisted-conch-11.0.0.ebuild:
+ Restrict pypy in twisted < 11.1.0 (bug #420653).
*twisted-conch-12.2.0 (27 Sep 2012)
diff --git a/dev-python/twisted-conch/twisted-conch-10.2.0.ebuild b/dev-python/twisted-conch/twisted-conch-10.2.0.ebuild
index cdb8c085e8cc..1bd7dd9552ea 100644
--- a/dev-python/twisted-conch/twisted-conch-10.2.0.ebuild
+++ b/dev-python/twisted-conch/twisted-conch-10.2.0.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-conch/twisted-conch-10.2.0.ebuild,v 1.9 2012/02/20 14:32:33 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-conch/twisted-conch-10.2.0.ebuild,v 1.10 2012/10/05 14:45:03 marienz Exp $
EAPI="3"
PYTHON_DEPEND="2"
SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.* *-jython"
+RESTRICT_PYTHON_ABIS="3.* *-jython *-pypy-*"
MY_PACKAGE="Conch"
inherit twisted versionator
diff --git a/dev-python/twisted-conch/twisted-conch-11.0.0.ebuild b/dev-python/twisted-conch/twisted-conch-11.0.0.ebuild
index c5001319f77f..6db7f6cc2ee6 100644
--- a/dev-python/twisted-conch/twisted-conch-11.0.0.ebuild
+++ b/dev-python/twisted-conch/twisted-conch-11.0.0.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-conch/twisted-conch-11.0.0.ebuild,v 1.9 2012/02/20 14:32:33 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-conch/twisted-conch-11.0.0.ebuild,v 1.10 2012/10/05 14:45:03 marienz Exp $
EAPI="3"
PYTHON_DEPEND="2"
SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.* *-jython"
+RESTRICT_PYTHON_ABIS="3.* *-jython *-pypy-*"
MY_PACKAGE="Conch"
inherit twisted versionator
diff --git a/dev-python/twisted-lore/ChangeLog b/dev-python/twisted-lore/ChangeLog
index 14365f003659..8c4af19d90f0 100644
--- a/dev-python/twisted-lore/ChangeLog
+++ b/dev-python/twisted-lore/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/twisted-lore
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-lore/ChangeLog,v 1.58 2012/09/27 18:16:07 marienz Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-lore/ChangeLog,v 1.59 2012/10/05 14:45:16 marienz Exp $
+
+ 05 Oct 2012; Marien Zwart <marienz@gentoo.org> twisted-lore-10.2.0.ebuild,
+ twisted-lore-11.0.0.ebuild:
+ Restrict pypy in twisted < 11.1.0 (bug #420653).
*twisted-lore-12.2.0 (27 Sep 2012)
diff --git a/dev-python/twisted-lore/twisted-lore-10.2.0.ebuild b/dev-python/twisted-lore/twisted-lore-10.2.0.ebuild
index 25351e49bcf6..11cb8c6fc1aa 100644
--- a/dev-python/twisted-lore/twisted-lore-10.2.0.ebuild
+++ b/dev-python/twisted-lore/twisted-lore-10.2.0.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-lore/twisted-lore-10.2.0.ebuild,v 1.6 2011/01/21 08:29:59 tomka Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-lore/twisted-lore-10.2.0.ebuild,v 1.7 2012/10/05 14:45:16 marienz Exp $
EAPI="3"
PYTHON_DEPEND="2"
SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.* *-jython"
+RESTRICT_PYTHON_ABIS="3.* *-jython *-pypy-*"
MY_PACKAGE="Lore"
inherit twisted versionator
diff --git a/dev-python/twisted-lore/twisted-lore-11.0.0.ebuild b/dev-python/twisted-lore/twisted-lore-11.0.0.ebuild
index 695c880d0dc7..9a8c9da4b750 100644
--- a/dev-python/twisted-lore/twisted-lore-11.0.0.ebuild
+++ b/dev-python/twisted-lore/twisted-lore-11.0.0.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-lore/twisted-lore-11.0.0.ebuild,v 1.6 2011/07/17 11:01:46 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-lore/twisted-lore-11.0.0.ebuild,v 1.7 2012/10/05 14:45:16 marienz Exp $
EAPI="3"
PYTHON_DEPEND="2"
SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.* *-jython"
+RESTRICT_PYTHON_ABIS="3.* *-jython *-pypy-*"
MY_PACKAGE="Lore"
inherit twisted versionator
diff --git a/dev-python/twisted-mail/ChangeLog b/dev-python/twisted-mail/ChangeLog
index ac86b26769ca..5d4f3c05e678 100644
--- a/dev-python/twisted-mail/ChangeLog
+++ b/dev-python/twisted-mail/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/twisted-mail
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-mail/ChangeLog,v 1.69 2012/09/27 18:16:26 marienz Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-mail/ChangeLog,v 1.70 2012/10/05 14:45:31 marienz Exp $
+
+ 05 Oct 2012; Marien Zwart <marienz@gentoo.org> twisted-mail-10.2.0.ebuild,
+ twisted-mail-11.0.0.ebuild:
+ Restrict pypy in twisted < 11.1.0 (bug #420653).
*twisted-mail-12.2.0 (27 Sep 2012)
diff --git a/dev-python/twisted-mail/twisted-mail-10.2.0.ebuild b/dev-python/twisted-mail/twisted-mail-10.2.0.ebuild
index a858c4b870c7..3b42792c960d 100644
--- a/dev-python/twisted-mail/twisted-mail-10.2.0.ebuild
+++ b/dev-python/twisted-mail/twisted-mail-10.2.0.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-mail/twisted-mail-10.2.0.ebuild,v 1.7 2011/01/25 17:05:25 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-mail/twisted-mail-10.2.0.ebuild,v 1.8 2012/10/05 14:45:31 marienz Exp $
EAPI="3"
PYTHON_DEPEND="2"
SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.* *-jython"
+RESTRICT_PYTHON_ABIS="3.* *-jython *-pypy-*"
MY_PACKAGE="Mail"
inherit twisted versionator
diff --git a/dev-python/twisted-mail/twisted-mail-11.0.0.ebuild b/dev-python/twisted-mail/twisted-mail-11.0.0.ebuild
index 9ea65e02952d..529cbe2770a0 100644
--- a/dev-python/twisted-mail/twisted-mail-11.0.0.ebuild
+++ b/dev-python/twisted-mail/twisted-mail-11.0.0.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-mail/twisted-mail-11.0.0.ebuild,v 1.8 2011/07/17 11:01:05 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-mail/twisted-mail-11.0.0.ebuild,v 1.9 2012/10/05 14:45:31 marienz Exp $
EAPI="3"
PYTHON_DEPEND="2"
SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.* *-jython"
+RESTRICT_PYTHON_ABIS="3.* *-jython *-pypy-*"
MY_PACKAGE="Mail"
inherit twisted versionator
diff --git a/dev-python/twisted-names/ChangeLog b/dev-python/twisted-names/ChangeLog
index 48dad4f9114b..30bbaa81589b 100644
--- a/dev-python/twisted-names/ChangeLog
+++ b/dev-python/twisted-names/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/twisted-names
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-names/ChangeLog,v 1.67 2012/09/27 18:16:45 marienz Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-names/ChangeLog,v 1.68 2012/10/05 14:45:45 marienz Exp $
+
+ 05 Oct 2012; Marien Zwart <marienz@gentoo.org> twisted-names-10.2.0.ebuild,
+ twisted-names-11.0.0.ebuild:
+ Restrict pypy in twisted < 11.1.0 (bug #420653).
*twisted-names-12.2.0 (27 Sep 2012)
diff --git a/dev-python/twisted-names/twisted-names-10.2.0.ebuild b/dev-python/twisted-names/twisted-names-10.2.0.ebuild
index f93488c77e20..3eee2f32cc5f 100644
--- a/dev-python/twisted-names/twisted-names-10.2.0.ebuild
+++ b/dev-python/twisted-names/twisted-names-10.2.0.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-names/twisted-names-10.2.0.ebuild,v 1.7 2011/01/25 17:04:52 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-names/twisted-names-10.2.0.ebuild,v 1.8 2012/10/05 14:45:45 marienz Exp $
EAPI="3"
PYTHON_DEPEND="2"
SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.* *-jython"
+RESTRICT_PYTHON_ABIS="3.* *-jython *-pypy-*"
MY_PACKAGE="Names"
inherit twisted versionator
diff --git a/dev-python/twisted-names/twisted-names-11.0.0.ebuild b/dev-python/twisted-names/twisted-names-11.0.0.ebuild
index 3af7848974f7..a82dfaa3e869 100644
--- a/dev-python/twisted-names/twisted-names-11.0.0.ebuild
+++ b/dev-python/twisted-names/twisted-names-11.0.0.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-names/twisted-names-11.0.0.ebuild,v 1.8 2011/07/17 10:58:51 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-names/twisted-names-11.0.0.ebuild,v 1.9 2012/10/05 14:45:45 marienz Exp $
EAPI="3"
PYTHON_DEPEND="2"
SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.* *-jython"
+RESTRICT_PYTHON_ABIS="3.* *-jython *-pypy-*"
MY_PACKAGE="Names"
inherit twisted versionator
diff --git a/dev-python/twisted-news/ChangeLog b/dev-python/twisted-news/ChangeLog
index fb42a82d50a6..a0578a3c97fa 100644
--- a/dev-python/twisted-news/ChangeLog
+++ b/dev-python/twisted-news/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/twisted-news
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-news/ChangeLog,v 1.56 2012/09/27 18:17:04 marienz Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-news/ChangeLog,v 1.57 2012/10/05 14:45:58 marienz Exp $
+
+ 05 Oct 2012; Marien Zwart <marienz@gentoo.org> twisted-news-10.2.0.ebuild,
+ twisted-news-11.0.0.ebuild:
+ Restrict pypy in twisted < 11.1.0 (bug #420653).
*twisted-news-12.2.0 (27 Sep 2012)
diff --git a/dev-python/twisted-news/twisted-news-10.2.0.ebuild b/dev-python/twisted-news/twisted-news-10.2.0.ebuild
index b90e15d67b37..6576eb5ec10c 100644
--- a/dev-python/twisted-news/twisted-news-10.2.0.ebuild
+++ b/dev-python/twisted-news/twisted-news-10.2.0.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-news/twisted-news-10.2.0.ebuild,v 1.6 2011/01/21 08:32:19 tomka Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-news/twisted-news-10.2.0.ebuild,v 1.7 2012/10/05 14:45:58 marienz Exp $
EAPI="3"
PYTHON_DEPEND="2"
SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.* *-jython"
+RESTRICT_PYTHON_ABIS="3.* *-jython *-pypy-*"
MY_PACKAGE="News"
inherit twisted versionator
diff --git a/dev-python/twisted-news/twisted-news-11.0.0.ebuild b/dev-python/twisted-news/twisted-news-11.0.0.ebuild
index fe5d1d2115c7..7db863d2eeda 100644
--- a/dev-python/twisted-news/twisted-news-11.0.0.ebuild
+++ b/dev-python/twisted-news/twisted-news-11.0.0.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-news/twisted-news-11.0.0.ebuild,v 1.6 2011/07/17 11:03:08 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-news/twisted-news-11.0.0.ebuild,v 1.7 2012/10/05 14:45:58 marienz Exp $
EAPI="3"
PYTHON_DEPEND="2"
SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.* *-jython"
+RESTRICT_PYTHON_ABIS="3.* *-jython *-pypy-*"
MY_PACKAGE="News"
inherit twisted versionator
diff --git a/dev-python/twisted-runner/ChangeLog b/dev-python/twisted-runner/ChangeLog
index f4b325f27be5..863eeab49131 100644
--- a/dev-python/twisted-runner/ChangeLog
+++ b/dev-python/twisted-runner/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/twisted-runner
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-runner/ChangeLog,v 1.58 2012/09/27 18:18:16 marienz Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-runner/ChangeLog,v 1.59 2012/10/05 14:46:17 marienz Exp $
+
+ 05 Oct 2012; Marien Zwart <marienz@gentoo.org> twisted-runner-10.2.0.ebuild,
+ twisted-runner-11.0.0.ebuild:
+ Restrict pypy in twisted < 11.1.0 (bug #420653).
*twisted-runner-12.2.0 (27 Sep 2012)
diff --git a/dev-python/twisted-runner/twisted-runner-10.2.0.ebuild b/dev-python/twisted-runner/twisted-runner-10.2.0.ebuild
index 94eb12fe423f..611ef688a8ee 100644
--- a/dev-python/twisted-runner/twisted-runner-10.2.0.ebuild
+++ b/dev-python/twisted-runner/twisted-runner-10.2.0.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-runner/twisted-runner-10.2.0.ebuild,v 1.7 2011/04/16 19:09:21 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-runner/twisted-runner-10.2.0.ebuild,v 1.8 2012/10/05 14:46:17 marienz Exp $
EAPI="3"
PYTHON_DEPEND="2"
SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.* *-jython"
+RESTRICT_PYTHON_ABIS="3.* *-jython *-pypy-*"
MY_PACKAGE="Runner"
inherit twisted versionator
diff --git a/dev-python/twisted-runner/twisted-runner-11.0.0.ebuild b/dev-python/twisted-runner/twisted-runner-11.0.0.ebuild
index 5f68c5e004b4..35b7df5ae50d 100644
--- a/dev-python/twisted-runner/twisted-runner-11.0.0.ebuild
+++ b/dev-python/twisted-runner/twisted-runner-11.0.0.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-runner/twisted-runner-11.0.0.ebuild,v 1.8 2012/01/02 00:59:55 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-runner/twisted-runner-11.0.0.ebuild,v 1.9 2012/10/05 14:46:17 marienz Exp $
EAPI="3"
PYTHON_DEPEND="2"
SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.* *-jython"
+RESTRICT_PYTHON_ABIS="3.* *-jython *-pypy-*"
MY_PACKAGE="Runner"
inherit twisted versionator
diff --git a/dev-python/twisted-web/ChangeLog b/dev-python/twisted-web/ChangeLog
index fcb4058eae29..cc3926b4af73 100644
--- a/dev-python/twisted-web/ChangeLog
+++ b/dev-python/twisted-web/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/twisted-web
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-web/ChangeLog,v 1.79 2012/09/27 18:18:35 marienz Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-web/ChangeLog,v 1.80 2012/10/05 14:46:31 marienz Exp $
+
+ 05 Oct 2012; Marien Zwart <marienz@gentoo.org> twisted-web-10.2.0.ebuild,
+ twisted-web-11.0.0.ebuild:
+ Restrict pypy in twisted < 11.1.0 (bug #420653).
*twisted-web-12.2.0 (27 Sep 2012)
diff --git a/dev-python/twisted-web/twisted-web-10.2.0.ebuild b/dev-python/twisted-web/twisted-web-10.2.0.ebuild
index 8109344d1e00..a34d8ca61901 100644
--- a/dev-python/twisted-web/twisted-web-10.2.0.ebuild
+++ b/dev-python/twisted-web/twisted-web-10.2.0.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-web/twisted-web-10.2.0.ebuild,v 1.8 2011/01/25 17:06:18 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-web/twisted-web-10.2.0.ebuild,v 1.9 2012/10/05 14:46:31 marienz Exp $
EAPI="3"
PYTHON_DEPEND="2"
SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.* *-jython"
+RESTRICT_PYTHON_ABIS="3.* *-jython *-pypy-*"
MY_PACKAGE="Web"
inherit twisted versionator
diff --git a/dev-python/twisted-web/twisted-web-11.0.0.ebuild b/dev-python/twisted-web/twisted-web-11.0.0.ebuild
index 6ee6da49859a..7486b9e015e7 100644
--- a/dev-python/twisted-web/twisted-web-11.0.0.ebuild
+++ b/dev-python/twisted-web/twisted-web-11.0.0.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-web/twisted-web-11.0.0.ebuild,v 1.8 2011/07/17 10:58:00 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-web/twisted-web-11.0.0.ebuild,v 1.9 2012/10/05 14:46:31 marienz Exp $
EAPI="3"
PYTHON_DEPEND="2"
SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.* *-jython"
+RESTRICT_PYTHON_ABIS="3.* *-jython *-pypy-*"
MY_PACKAGE="Web"
inherit twisted versionator
diff --git a/dev-python/twisted-words/ChangeLog b/dev-python/twisted-words/ChangeLog
index 5d62f79d120a..6bdb1110a777 100644
--- a/dev-python/twisted-words/ChangeLog
+++ b/dev-python/twisted-words/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/twisted-words
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-words/ChangeLog,v 1.74 2012/09/27 18:18:54 marienz Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-words/ChangeLog,v 1.75 2012/10/05 14:46:45 marienz Exp $
+
+ 05 Oct 2012; Marien Zwart <marienz@gentoo.org> twisted-words-10.2.0-r1.ebuild,
+ twisted-words-11.0.0.ebuild:
+ Restrict pypy in twisted < 11.1.0 (bug #420653).
*twisted-words-12.2.0 (27 Sep 2012)
diff --git a/dev-python/twisted-words/twisted-words-10.2.0-r1.ebuild b/dev-python/twisted-words/twisted-words-10.2.0-r1.ebuild
index a844d001011b..ece5e5554b0b 100644
--- a/dev-python/twisted-words/twisted-words-10.2.0-r1.ebuild
+++ b/dev-python/twisted-words/twisted-words-10.2.0-r1.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-words/twisted-words-10.2.0-r1.ebuild,v 1.4 2011/12/29 04:55:27 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-words/twisted-words-10.2.0-r1.ebuild,v 1.5 2012/10/05 14:46:45 marienz Exp $
EAPI="3"
PYTHON_DEPEND="2"
SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.* *-jython"
+RESTRICT_PYTHON_ABIS="3.* *-jython *-pypy-*"
MY_PACKAGE="Words"
inherit eutils twisted versionator
diff --git a/dev-python/twisted-words/twisted-words-11.0.0.ebuild b/dev-python/twisted-words/twisted-words-11.0.0.ebuild
index 38bb07180aab..f7ada7364c86 100644
--- a/dev-python/twisted-words/twisted-words-11.0.0.ebuild
+++ b/dev-python/twisted-words/twisted-words-11.0.0.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-words/twisted-words-11.0.0.ebuild,v 1.10 2012/01/02 01:03:36 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-words/twisted-words-11.0.0.ebuild,v 1.11 2012/10/05 14:46:45 marienz Exp $
EAPI="3"
PYTHON_DEPEND="2"
SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.* *-jython"
+RESTRICT_PYTHON_ABIS="3.* *-jython *-pypy-*"
MY_PACKAGE="Words"
inherit twisted versionator
diff --git a/dev-python/twisted/ChangeLog b/dev-python/twisted/ChangeLog
index 135e03cd3ed5..fc5c8a62dc6a 100644
--- a/dev-python/twisted/ChangeLog
+++ b/dev-python/twisted/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/twisted
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted/ChangeLog,v 1.156 2012/09/27 18:14:32 marienz Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted/ChangeLog,v 1.157 2012/10/05 14:44:44 marienz Exp $
+
+ 05 Oct 2012; Marien Zwart <marienz@gentoo.org> twisted-10.2.0.ebuild,
+ twisted-11.0.0.ebuild:
+ Restrict pypy in twisted < 11.1.0 (bug #420653).
*twisted-12.2.0 (27 Sep 2012)
diff --git a/dev-python/twisted/twisted-10.2.0.ebuild b/dev-python/twisted/twisted-10.2.0.ebuild
index 2320359a9729..a8081d6fa366 100644
--- a/dev-python/twisted/twisted-10.2.0.ebuild
+++ b/dev-python/twisted/twisted-10.2.0.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted/twisted-10.2.0.ebuild,v 1.8 2011/01/25 17:03:06 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted/twisted-10.2.0.ebuild,v 1.9 2012/10/05 14:44:44 marienz Exp $
EAPI="3"
PYTHON_DEPEND="2"
SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.* *-jython"
+RESTRICT_PYTHON_ABIS="3.* *-jython *-pypy-*"
MY_PACKAGE="Core"
inherit eutils twisted versionator
diff --git a/dev-python/twisted/twisted-11.0.0.ebuild b/dev-python/twisted/twisted-11.0.0.ebuild
index 3bc45a268491..ea17fb33f447 100644
--- a/dev-python/twisted/twisted-11.0.0.ebuild
+++ b/dev-python/twisted/twisted-11.0.0.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted/twisted-11.0.0.ebuild,v 1.8 2011/07/17 10:57:03 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted/twisted-11.0.0.ebuild,v 1.9 2012/10/05 14:44:44 marienz Exp $
EAPI="3"
PYTHON_DEPEND="2"
SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.* *-jython"
+RESTRICT_PYTHON_ABIS="3.* *-jython *-pypy-*"
MY_PACKAGE="Core"
inherit eutils twisted versionator