summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2010-02-14 20:44:54 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2010-02-14 20:44:54 +0000
commit520488c937ff4640f3db072a6c9868017012ef5b (patch)
tree06439f41c92d8aacf711472f33d8dcaeef8485d6 /dev-ruby/annoy
parentenable-test ./configure option only enables build of extra programs, so no ne... (diff)
downloadhistorical-520488c937ff4640f3db072a6c9868017012ef5b.tar.gz
historical-520488c937ff4640f3db072a6c9868017012ef5b.tar.bz2
historical-520488c937ff4640f3db072a6c9868017012ef5b.zip
Initial import of annoy, needed for Rudy.
Package-Manager: portage-2.2_rc62/cvs/Linux x86_64
Diffstat (limited to 'dev-ruby/annoy')
-rw-r--r--dev-ruby/annoy/ChangeLog10
-rw-r--r--dev-ruby/annoy/Manifest15
-rw-r--r--dev-ruby/annoy/annoy-0.5.5.ebuild32
-rw-r--r--dev-ruby/annoy/files/annoy-0.5.5-hanna.patch40
-rw-r--r--dev-ruby/annoy/metadata.xml5
5 files changed, 102 insertions, 0 deletions
diff --git a/dev-ruby/annoy/ChangeLog b/dev-ruby/annoy/ChangeLog
new file mode 100644
index 000000000000..ea23e6b38ed7
--- /dev/null
+++ b/dev-ruby/annoy/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-ruby/annoy
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/annoy/ChangeLog,v 1.1 2010/02/14 20:44:52 flameeyes Exp $
+
+*annoy-0.5.5 (14 Feb 2010)
+
+ 14 Feb 2010; Diego E. Pettenò <flameeyes@gentoo.org> +annoy-0.5.5.ebuild,
+ +files/annoy-0.5.5-hanna.patch, +metadata.xml:
+ Initial import of annoy, needed for Rudy.
+
diff --git a/dev-ruby/annoy/Manifest b/dev-ruby/annoy/Manifest
new file mode 100644
index 000000000000..55b943b5360c
--- /dev/null
+++ b/dev-ruby/annoy/Manifest
@@ -0,0 +1,15 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+AUX annoy-0.5.5-hanna.patch 1051 RMD160 4f2779721e71eed31a3bdb6d30b4d55555045f12 SHA1 10dfbe3adc7556e9b612f2eafb73ba6986f03a8d SHA256 59a22fd2dac54c1653fd94c14b63caaeeefcb5ed9e48b54afa9b1cf3f984a2bf
+DIST annoy-0.5.5.gem 9728 RMD160 e02e3eb8e69a0d4810f47087b243e31fa29647d4 SHA1 f9c1ba97822dcb4e691b1278c6fdd010d7521c01 SHA256 264ac91ef5fa6e866f96113189de6330956bd9f354502b719d79d097eae9b000
+EBUILD annoy-0.5.5.ebuild 725 RMD160 ac8217d3ac80082c27de31b2aa68378533a11bf0 SHA1 4cb8a2dfcccd2d6f1c86f3bcd00c30fe802a20a6 SHA256 49270e35fedb11dba2729a3df082c0c4647492377ea9bcba7bb2e31eb7ea6e24
+MISC ChangeLog 403 RMD160 47a4ec862a6cbd854d758fa3c9d788fe7b1d4473 SHA1 4d51768901612b9ea5c02947af04b48b3175f3a4 SHA256 66483badf1f2c6fcd811a64161a36c19ab9bf051d10d0cce19e5ab16fa93af95
+MISC metadata.xml 157 RMD160 5d9e2c7ecba96ffebd936d38acedf859cdea84e1 SHA1 8ce15dcc608eeb5616aeec610dc695cbe6f93e02 SHA256 11fba03a217e2d996f5cd8895493a5692ece8ddac2c1a2dfc71d0e830555121c
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2.0.14 (GNU/Linux)
+
+iEYEARECAAYFAkt4YLwACgkQAiZjviIA2Xh1IACgnbpJnjP4xNyUOD7/cLZouRhB
+2GoAnjbD5JXWHZXIwnpIcJCXPcQeee/y
+=09Ws
+-----END PGP SIGNATURE-----
diff --git a/dev-ruby/annoy/annoy-0.5.5.ebuild b/dev-ruby/annoy/annoy-0.5.5.ebuild
new file mode 100644
index 000000000000..fc6bde0c5ec0
--- /dev/null
+++ b/dev-ruby/annoy/annoy-0.5.5.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/annoy/annoy-0.5.5.ebuild,v 1.1 2010/02/14 20:44:52 flameeyes Exp $
+
+EAPI=2
+
+USE_RUBY="ruby18 ruby19 jruby"
+
+RESTRICT=test
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_FAKEGEM_TASK_DOC="rdoc"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGES.txt README.rdoc"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="Like your annoying friend that asks you questions all the time"
+HOMEPAGE="http://solutious.com/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+ruby_add_rdepend '>=dev-ruby/highline-1.5.0'
+
+all_ruby_prepare() {
+ epatch "${FILESDIR}"/${P}-hanna.patch
+}
diff --git a/dev-ruby/annoy/files/annoy-0.5.5-hanna.patch b/dev-ruby/annoy/files/annoy-0.5.5-hanna.patch
new file mode 100644
index 000000000000..eaff019208ae
--- /dev/null
+++ b/dev-ruby/annoy/files/annoy-0.5.5-hanna.patch
@@ -0,0 +1,40 @@
+From 4ab673e77653d2342556c1c7495cbeac59887557 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Diego=20Elio=20'Flameeyes'=20Petten=C3=B2?= <flameeyes@gmail.com>
+Date: Sun, 14 Feb 2010 21:22:30 +0100
+Subject: [PATCH] Don't force Hanna usage for documentation building.
+
+Since Hanna is not always available (and requires a specific version of
+RDoc gem), don't force to use it with no alternative. Instead, if not
+available, fallback to the standard rdoc support within rake.
+---
+ Rakefile | 7 ++++++-
+ 1 files changed, 6 insertions(+), 1 deletions(-)
+
+diff --git a/Rakefile b/Rakefile
+index 85d1c50..d1a2721 100644
+--- a/Rakefile
++++ b/Rakefile
+@@ -1,7 +1,6 @@
+ require 'rubygems'
+ require 'rake/clean'
+ require 'rake/gempackagetask'
+-require 'hanna/rdoctask'
+ require 'fileutils'
+ include FileUtils
+
+@@ -66,6 +65,12 @@ end
+
+ # RUBY DOCS TASK ==================================
+
++begin
++ require 'hanna/rdoctask'
++rescue LoadError
++ require 'rake/rdoctask'
++end
++
+ Rake::RDocTask.new do |t|
+ t.rdoc_dir = 'doc'
+ t.title = @spec.summary
+--
+1.7.0
+
diff --git a/dev-ruby/annoy/metadata.xml b/dev-ruby/annoy/metadata.xml
new file mode 100644
index 000000000000..852136183369
--- /dev/null
+++ b/dev-ruby/annoy/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ruby</herd>
+</pkgmetadata>