summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2012-01-14 07:32:25 +0000
committerHans de Graaff <graaff@gentoo.org>2012-01-14 07:32:25 +0000
commitefb5ad51aea3a560f1cd06bb0b6eb97f88d0b7d4 (patch)
tree8a118db396f3c28391fbc6790ac60e3e2dabed88 /dev-ruby/arel/arel-3.0.0.ebuild
parentAdd ~hppa since spruz also has that keyword and this is essentially just a ne... (diff)
downloadhistorical-efb5ad51aea3a560f1cd06bb0b6eb97f88d0b7d4.tar.gz
historical-efb5ad51aea3a560f1cd06bb0b6eb97f88d0b7d4.tar.bz2
historical-efb5ad51aea3a560f1cd06bb0b6eb97f88d0b7d4.zip
Version bump.
Package-Manager: portage-2.1.10.41/cvs/Linux x86_64
Diffstat (limited to 'dev-ruby/arel/arel-3.0.0.ebuild')
-rw-r--r--dev-ruby/arel/arel-3.0.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-ruby/arel/arel-3.0.0.ebuild b/dev-ruby/arel/arel-3.0.0.ebuild
new file mode 100644
index 000000000000..df94960ae00a
--- /dev/null
+++ b/dev-ruby/arel/arel-3.0.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/arel/arel-3.0.0.ebuild,v 1.1 2012/01/14 07:32:25 graaff Exp $
+
+EAPI="2"
+USE_RUBY="ruby18 ruby19 ree18 jruby"
+
+RUBY_FAKEGEM_TASK_DOC="docs"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="History.txt README.markdown"
+
+# Generating the gemspec from metadata causes a crash in jruby
+RUBY_FAKEGEM_GEMSPEC="arel.gemspec"
+
+inherit ruby-fakegem versionator
+
+DESCRIPTION="Arel is a Relational Algebra for Ruby."
+HOMEPAGE="http://github.com/rails/arel"
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_bdepend "
+ doc? ( >=dev-ruby/hoe-2.10 )
+ test? (
+ >=dev-ruby/hoe-2.10
+ virtual/ruby-minitest
+ )"