summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-05-01 07:35:30 +0000
committerHans de Graaff <graaff@gentoo.org>2011-05-01 07:35:30 +0000
commit80aa1d8af3bcc95533277064e9c1b2c80944ddcf (patch)
tree9dce514cdc7d1972b556092239e111c3dceb9c74 /dev-ruby/coderay/coderay-0.9.8.ebuild
parentRemove old version. (diff)
downloadhistorical-80aa1d8af3bcc95533277064e9c1b2c80944ddcf.tar.gz
historical-80aa1d8af3bcc95533277064e9c1b2c80944ddcf.tar.bz2
historical-80aa1d8af3bcc95533277064e9c1b2c80944ddcf.zip
Version bump.
Package-Manager: portage-2.1.9.42/cvs/Linux x86_64
Diffstat (limited to 'dev-ruby/coderay/coderay-0.9.8.ebuild')
-rw-r--r--dev-ruby/coderay/coderay-0.9.8.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-ruby/coderay/coderay-0.9.8.ebuild b/dev-ruby/coderay/coderay-0.9.8.ebuild
new file mode 100644
index 000000000000..67c4061b8938
--- /dev/null
+++ b/dev-ruby/coderay/coderay-0.9.8.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/coderay/coderay-0.9.8.ebuild,v 1.1 2011/05/01 07:30:45 graaff Exp $
+
+EAPI=2
+
+USE_RUBY="ruby18 ree18 ruby19 jruby"
+
+RUBY_FAKEGEM_TASK_DOC="doc"
+RUBY_FAKEGEM_DOCDIR="doc"
+
+RUBY_FAKEGEM_EXTRADOC="lib/README"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Ruby library for syntax highlighting."
+HOMEPAGE="http://coderay.rubychan.de/"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE=""
+
+# Redcloth is optional but automagically tested, so we add this
+# dependency to ensure that we get at least a version that works: bug
+# 330621. We use this convoluted way because redcloth isn't available
+# yet for jruby.
+USE_RUBY=ruby18 ruby_add_bdepend "ruby_targets_ruby18 test" ">=dev-ruby/redcloth-4.2.2"
+USE_RUBY=ruby19 ruby_add_bdepend "ruby_targets_ruby19 test" ">=dev-ruby/redcloth-4.2.2"
+USE_RUBY=ree18 ruby_add_bdepend "ruby_targets_ree18 test" ">=dev-ruby/redcloth-4.2.2"