summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2013-09-23 07:16:36 +0000
committerManuel Rüger <mrueg@gentoo.org>2013-09-23 07:16:36 +0000
commit42e28854c7784a967b0430efd7e723fefbf87306 (patch)
tree679be14ae76d10f2c419f4794ae66e481f6889f4 /dev-ruby/fcgi/fcgi-0.9.2.ebuild
parentRemove older versions (diff)
downloadhistorical-42e28854c7784a967b0430efd7e723fefbf87306.tar.gz
historical-42e28854c7784a967b0430efd7e723fefbf87306.tar.bz2
historical-42e28854c7784a967b0430efd7e723fefbf87306.zip
Version bump. Add ruby20 support.
Package-Manager: portage-2.2.6/cvs/Linux x86_64
Diffstat (limited to 'dev-ruby/fcgi/fcgi-0.9.2.ebuild')
-rw-r--r--dev-ruby/fcgi/fcgi-0.9.2.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-ruby/fcgi/fcgi-0.9.2.ebuild b/dev-ruby/fcgi/fcgi-0.9.2.ebuild
new file mode 100644
index 000000000000..4a828953665e
--- /dev/null
+++ b/dev-ruby/fcgi/fcgi-0.9.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/fcgi/fcgi-0.9.2.ebuild,v 1.1 2013/09/23 07:16:33 mrueg Exp $
+
+EAPI=5
+USE_RUBY="ruby18 ruby19 ruby20 jruby"
+
+RUBY_FAKEGEM_TASK_TEST=""
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRADOC="README.rdoc README.signals"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="FastCGI library for Ruby"
+HOMEPAGE="http://github.com/alphallc/ruby-fcgi-ng"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+LICENSE="Ruby"
+
+DEPEND+=" dev-libs/fcgi"
+RDEPEND+=" dev-libs/fcgi"
+
+IUSE=""
+SLOT="0"
+
+each_ruby_configure() {
+ case ${RUBY} in
+ *ruby18|*ruby19|*ruby20)
+ ${RUBY} -C ext/fcgi extconf.rb || die "extconf failed"
+ ;;
+ esac
+}
+
+each_ruby_compile() {
+ case ${RUBY} in
+ *ruby18|*ruby19|*ruby20)
+ emake V=1 -C ext/fcgi
+ cp ext/fcgi/fcgi$(get_modname) lib || die
+ ;;
+ esac
+}