summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2012-08-14 00:00:01 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2012-08-14 00:00:01 +0000
commit7c74583723d4f67be19404465ad023e15729bde5 (patch)
treeb77068e0d16b179a72b22ce3a1823af430d24046 /dev-ruby/hashie/hashie-1.2.0.ebuild
parentStable ppc, bug #431206 (diff)
downloadhistorical-7c74583723d4f67be19404465ad023e15729bde5.tar.gz
historical-7c74583723d4f67be19404465ad023e15729bde5.tar.bz2
historical-7c74583723d4f67be19404465ad023e15729bde5.zip
Use the new rspec recipe for tests; bump to EAPI 4.
Package-Manager: portage-2.2.0_alpha120/cvs/Linux x86_64
Diffstat (limited to 'dev-ruby/hashie/hashie-1.2.0.ebuild')
-rw-r--r--dev-ruby/hashie/hashie-1.2.0.ebuild11
1 files changed, 6 insertions, 5 deletions
diff --git a/dev-ruby/hashie/hashie-1.2.0.ebuild b/dev-ruby/hashie/hashie-1.2.0.ebuild
index e1959ea6b87a..4965db574a1c 100644
--- a/dev-ruby/hashie/hashie-1.2.0.ebuild
+++ b/dev-ruby/hashie/hashie-1.2.0.ebuild
@@ -1,11 +1,12 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/hashie/hashie-1.2.0.ebuild,v 1.1 2011/10/16 07:31:27 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/hashie/hashie-1.2.0.ebuild,v 1.2 2012/08/14 00:00:01 flameeyes Exp $
+
+EAPI=4
-EAPI="2"
USE_RUBY="ruby18 ruby19 jruby ree18"
-RUBY_FAKEGEM_TASK_TEST="spec"
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
RUBY_FAKEGEM_TASK_DOC=""
RUBY_FAKEGEM_EXTRADOC="README.rdoc"
@@ -20,7 +21,7 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
-ruby_add_bdepend "test? ( >=dev-ruby/rspec-2.5:2 dev-ruby/json )"
+ruby_add_bdepend "test? ( dev-ruby/json )"
all_ruby_prepare() {
# Remove bundler