summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2013-10-04 16:05:03 +0000
committerManuel Rüger <mrueg@gentoo.org>2013-10-04 16:05:03 +0000
commitd42bff7e0980d00761bb1e5dcf27544316d14f85 (patch)
treee04606ed1d0cb1011a3aeb05e23fdb6013f67b85 /dev-ruby/hoe-seattlerb/hoe-seattlerb-1.3.2-r1.ebuild
parentStable for HPPA (bug #467274). (diff)
downloadhistorical-d42bff7e0980d00761bb1e5dcf27544316d14f85.tar.gz
historical-d42bff7e0980d00761bb1e5dcf27544316d14f85.tar.bz2
historical-d42bff7e0980d00761bb1e5dcf27544316d14f85.zip
Add ruby20 target. Fix USE=doc. Drop old.
Package-Manager: portage-2.2.7/cvs/Linux x86_64
Diffstat (limited to 'dev-ruby/hoe-seattlerb/hoe-seattlerb-1.3.2-r1.ebuild')
-rw-r--r--dev-ruby/hoe-seattlerb/hoe-seattlerb-1.3.2-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-ruby/hoe-seattlerb/hoe-seattlerb-1.3.2-r1.ebuild b/dev-ruby/hoe-seattlerb/hoe-seattlerb-1.3.2-r1.ebuild
new file mode 100644
index 000000000000..c514fd3834cf
--- /dev/null
+++ b/dev-ruby/hoe-seattlerb/hoe-seattlerb-1.3.2-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/hoe-seattlerb/hoe-seattlerb-1.3.2-r1.ebuild,v 1.1 2013/10/04 16:04:59 mrueg Exp $
+
+EAPI=5
+USE_RUBY="ruby18 ruby19 ruby20 jruby"
+
+# no tests present
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_FAKEGEM_TASK_DOC="docs"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="README.txt History.txt"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Hoe plugins providing tasks used by seattle.rb"
+HOMEPAGE="http://seattlerb.rubyforge.org/hoe-seattlerb"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_bdepend "doc? ( >=dev-ruby/hoe-2.12 )"
+
+all_ruby_prepare() {
+ # Not a real fix, but otherwise USE="doc" breaks and defaulte license is MIT
+ sed -i -e "/license/d" Rakefile || die
+}