summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-06-23 17:38:09 +0000
committerHans de Graaff <graaff@gentoo.org>2011-06-23 17:38:09 +0000
commitb676f1b524090152b8ff4193c74bcebe7549b3a5 (patch)
tree90ca9ab84d6667aef3163f261ecc6621da8bf15b /dev-ruby/libxml/libxml-2.0.5.ebuild
parentx86 stable wrt bug #366699 (diff)
downloadhistorical-b676f1b524090152b8ff4193c74bcebe7549b3a5.tar.gz
historical-b676f1b524090152b8ff4193c74bcebe7549b3a5.tar.bz2
historical-b676f1b524090152b8ff4193c74bcebe7549b3a5.zip
Work around broken test suite that expects files in alphabetical order, bug 370501.
Package-Manager: portage-2.1.9.42/cvs/Linux x86_64
Diffstat (limited to 'dev-ruby/libxml/libxml-2.0.5.ebuild')
-rw-r--r--dev-ruby/libxml/libxml-2.0.5.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/dev-ruby/libxml/libxml-2.0.5.ebuild b/dev-ruby/libxml/libxml-2.0.5.ebuild
index 7bb4c5c054ef..c477595e07e2 100644
--- a/dev-ruby/libxml/libxml-2.0.5.ebuild
+++ b/dev-ruby/libxml/libxml-2.0.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/libxml/libxml-2.0.5.ebuild,v 1.3 2011/06/19 11:45:55 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/libxml/libxml-2.0.5.ebuild,v 1.4 2011/06/23 17:38:09 graaff Exp $
EAPI=2
@@ -11,6 +11,8 @@ RUBY_FAKEGEM_NAME="libxml-ruby"
RUBY_FAKEGEM_DOCDIR="doc"
RUBY_FAKEGEM_EXTRADOC="README.rdoc HISTORY"
+RUBY_FAKEGEM_TASK_TEST="none"
+
inherit ruby-fakegem
DESCRIPTION="Ruby libxml with a user friendly API, akin to REXML, but feature complete and significantly faster."
@@ -43,3 +45,7 @@ each_ruby_compile() {
emake -C ext/libxml
cp ext/libxml/libxml_ruby.so lib/ || die
}
+
+each_ruby_test() {
+ ${RUBY} -Ilib -r test/test_helper.rb test/test_suite.rb || die
+}