summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2014-05-03 08:23:11 +0000
committerHans de Graaff <graaff@gentoo.org>2014-05-03 08:23:11 +0000
commit01022b7454389649daa3a3e3b9978c792fa82dcc (patch)
tree3a4e05b0e88be7dc4540dfc74537e667f0ccade0 /dev-ruby/net-scp/net-scp-1.2.1.ebuild
parentVersion bump. (diff)
downloadhistorical-01022b7454389649daa3a3e3b9978c792fa82dcc.tar.gz
historical-01022b7454389649daa3a3e3b9978c792fa82dcc.tar.bz2
historical-01022b7454389649daa3a3e3b9978c792fa82dcc.zip
Version bump.
Package-Manager: portage-2.2.8-r1/cvs/Linux x86_64 Manifest-Sign-Key: 0x8883FA56A308A8D7!
Diffstat (limited to 'dev-ruby/net-scp/net-scp-1.2.1.ebuild')
-rw-r--r--dev-ruby/net-scp/net-scp-1.2.1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-ruby/net-scp/net-scp-1.2.1.ebuild b/dev-ruby/net-scp/net-scp-1.2.1.ebuild
new file mode 100644
index 000000000000..3e14b08e1b80
--- /dev/null
+++ b/dev-ruby/net-scp/net-scp-1.2.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/net-scp/net-scp-1.2.1.ebuild,v 1.1 2014/05/03 08:23:10 graaff Exp $
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGES.txt README.rdoc"
+
+RUBY_FAKEGEM_TASK_TEST=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="A pure Ruby implementation of the SCP client protocol"
+HOMEPAGE="http://net-ssh.rubyforge.org/scp"
+
+LICENSE="GPL-2"
+SLOT="2"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_bdepend "
+ doc? ( >=dev-ruby/net-ssh-2.6.5 )
+ test? (
+ >=dev-ruby/net-ssh-2.9.0
+ dev-ruby/mocha
+ )"
+
+ruby_add_rdepend ">=dev-ruby/net-ssh-2.6.5"
+
+each_ruby_test() {
+ ${RUBY} -Ilib:test test/test_all.rb || die
+}