summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2010-06-05 10:59:26 +0000
committerHans de Graaff <graaff@gentoo.org>2010-06-05 10:59:26 +0000
commite08cb232aa2c6d9a8830fd57af172178a0ba8284 (patch)
tree39d8c4fe0e5aa684e8b2114754d462e05247c459 /dev-ruby/oniguruma/oniguruma-1.1.0-r2.ebuild
parentRemove LICENSE file from dodoc (diff)
downloadhistorical-e08cb232aa2c6d9a8830fd57af172178a0ba8284.tar.gz
historical-e08cb232aa2c6d9a8830fd57af172178a0ba8284.tar.bz2
historical-e08cb232aa2c6d9a8830fd57af172178a0ba8284.zip
Fix dependencies. Install documentation.
Package-Manager: portage-2.1.8.3/cvs/Linux x86_64
Diffstat (limited to 'dev-ruby/oniguruma/oniguruma-1.1.0-r2.ebuild')
-rw-r--r--dev-ruby/oniguruma/oniguruma-1.1.0-r2.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/dev-ruby/oniguruma/oniguruma-1.1.0-r2.ebuild b/dev-ruby/oniguruma/oniguruma-1.1.0-r2.ebuild
new file mode 100644
index 000000000000..7410c5b50472
--- /dev/null
+++ b/dev-ruby/oniguruma/oniguruma-1.1.0-r2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/oniguruma/oniguruma-1.1.0-r2.ebuild,v 1.1 2010/06/05 10:59:26 graaff Exp $
+
+EAPI="2"
+USE_RUBY="ruby18"
+
+RUBY_FAKEGEM_TASK_DOC="docs"
+RUBY_FAKEGEM_DOCDIR="doc"
+
+RUBY_FAKEGEM_EXTRADOC="History.txt README.txt Syntax.txt"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Ruby bindings to the Oniguruma"
+HOMEPAGE="http://oniguruma.rubyforge.org/"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE=""
+
+DEPEND="${DEPEND} dev-libs/oniguruma"
+RDEPEND="${RDEPEND} dev-libs/oniguruma"
+
+RUBY_PATCHES=( "${P}-unmonkey.patch" )
+
+ruby_add_bdepend "
+ doc? ( dev-ruby/hoe )
+ test? (
+ dev-ruby/hoe
+ virtual/ruby-test-unit
+ )"
+
+each_ruby_configure() {
+ pushd ext >& /dev/null
+ ${RUBY} extconf.rb
+ popd >& /dev/null
+}
+
+each_ruby_compile() {
+ pushd ext >& /dev/null
+ emake || die "Compilation failed."
+ popd >& /dev/null
+ mv ext/oregexp.so lib || die "Unable to move oregexp.so"
+}
+
+each_ruby_install() {
+ each_fakegem_install
+}