summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCaleb Tennis <caleb@gentoo.org>2005-02-28 18:01:23 +0000
committerCaleb Tennis <caleb@gentoo.org>2005-02-28 18:01:23 +0000
commita08d5e94be335ee64f5f2af8867daa02298481fa (patch)
treeddff18f06c8893cb65fdc4da94abe7d2683efac4 /dev-ruby/rails
parentfix spacing (diff)
downloadhistorical-a08d5e94be335ee64f5f2af8867daa02298481fa.tar.gz
historical-a08d5e94be335ee64f5f2af8867daa02298481fa.tar.bz2
historical-a08d5e94be335ee64f5f2af8867daa02298481fa.zip
Version bump - #83446
Package-Manager: portage-2.0.51-r15
Diffstat (limited to 'dev-ruby/rails')
-rw-r--r--dev-ruby/rails/ChangeLog7
-rw-r--r--dev-ruby/rails/files/digest-rails-0.10.01
-rw-r--r--dev-ruby/rails/rails-0.10.0.ebuild27
-rw-r--r--dev-ruby/rails/rails-0.9.5.ebuild7
4 files changed, 38 insertions, 4 deletions
diff --git a/dev-ruby/rails/ChangeLog b/dev-ruby/rails/ChangeLog
index 8174f40370c1..6d865462d856 100644
--- a/dev-ruby/rails/ChangeLog
+++ b/dev-ruby/rails/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/rails
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rails/ChangeLog,v 1.1 2005/02/16 05:48:13 pythonhead Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rails/ChangeLog,v 1.2 2005/02/28 18:01:23 caleb Exp $
+
+*rails-0.10.0 (28 Feb 2005)
+
+ 28 Feb 2005; Caleb Tennis <caleb@gentoo.org> +rails-0.10.0.ebuild:
+ Version bump - bug #83446
*rails-0.9.5 (15 Feb 2005)
diff --git a/dev-ruby/rails/files/digest-rails-0.10.0 b/dev-ruby/rails/files/digest-rails-0.10.0
new file mode 100644
index 000000000000..2b653b525d3c
--- /dev/null
+++ b/dev-ruby/rails/files/digest-rails-0.10.0
@@ -0,0 +1 @@
+MD5 6d8e05bee54523a317470009d6556c76 rails-0.10.0.gem 40960
diff --git a/dev-ruby/rails/rails-0.10.0.ebuild b/dev-ruby/rails/rails-0.10.0.ebuild
new file mode 100644
index 000000000000..05fe9080ef66
--- /dev/null
+++ b/dev-ruby/rails/rails-0.10.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rails/rails-0.10.0.ebuild,v 1.1 2005/02/28 18:01:23 caleb Exp $
+
+inherit ruby gems
+
+USE_RUBY="ruby18"
+DESCRIPTION="ruby on rails is a web-application and persistance framework"
+HOMEPAGE="http://www.rubyonrails.org"
+# The URL depends implicitly on the version, unfortunately. Even if you
+# change the filename on the end, it still downloads the same file.
+SRC_URI="http://rubyforge.org/frs/download.php/2764/${P}.gem"
+
+LICENSE="Ruby"
+SLOT="0"
+KEYWORDS="~x86"
+
+IUSE="mysql sqlite postgres"
+DEPEND="=dev-lang/ruby-1.8*
+ >=dev-ruby/rake-0.4.15-r1
+ >=dev-ruby/activesupport-1.0.0
+ >=dev-ruby/activerecord-1.7.0
+ >=dev-ruby/actionmailer-0.6.1
+ sqlite? ( >=dev-ruby/sqlite-ruby-2.2.2)
+ mysql? ( >=dev-ruby/mysql-ruby-2.5 )
+ postgres? ( >=dev-ruby/ruby-postgres-0.7.1 )"
+
diff --git a/dev-ruby/rails/rails-0.9.5.ebuild b/dev-ruby/rails/rails-0.9.5.ebuild
index 3b0e820037d5..e51e0ab6becc 100644
--- a/dev-ruby/rails/rails-0.9.5.ebuild
+++ b/dev-ruby/rails/rails-0.9.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rails/rails-0.9.5.ebuild,v 1.1 2005/02/16 05:48:13 pythonhead Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rails/rails-0.9.5.ebuild,v 1.2 2005/02/28 18:01:23 caleb Exp $
inherit ruby gems
@@ -9,7 +9,7 @@ DESCRIPTION="ruby on rails is a web-application and persistance framework"
HOMEPAGE="http://www.rubyonrails.org"
# The URL depends implicitly on the version, unfortunately. Even if you
# change the filename on the end, it still downloads the same file.
-SRC_URI="http://rubyforge.org/frs/download.php/2764/${P}.gem"
+SRC_URI="http://rubyforge.org/frs/download.php/3205/${P}.gem"
LICENSE="Ruby"
SLOT="0"
@@ -19,7 +19,8 @@ IUSE="mysql sqlite postgres"
DEPEND="=dev-lang/ruby-1.8*
>=dev-ruby/rake-0.4.15-r1
>=dev-ruby/activerecord-1.6.0
- >=dev-ruby/actionmailer-0.6.1
+ >=dev-ruby/actionmailer-0.7.0
+ >=dev-ruby/actionwebservice-0.5.0
sqlite? ( >=dev-ruby/sqlite-ruby-2.2.2)
mysql? ( >=dev-ruby/mysql-ruby-2.5 )
postgres? ( >=dev-ruby/ruby-postgres-0.7.1 )"