summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2012-07-15 07:04:56 +0000
committerHans de Graaff <graaff@gentoo.org>2012-07-15 07:04:56 +0000
commitbf26e91a36e69793f32fb9238ec3772e3d972579 (patch)
tree5f6f6e0794cb360b5e1264c1ce77d6d0ec90e16f /dev-ruby/rspec-expectations
parentVersion bump. (diff)
downloadhistorical-bf26e91a36e69793f32fb9238ec3772e3d972579.tar.gz
historical-bf26e91a36e69793f32fb9238ec3772e3d972579.tar.bz2
historical-bf26e91a36e69793f32fb9238ec3772e3d972579.zip
Version bump.
Package-Manager: portage-2.1.10.65/cvs/Linux x86_64
Diffstat (limited to 'dev-ruby/rspec-expectations')
-rw-r--r--dev-ruby/rspec-expectations/ChangeLog8
-rw-r--r--dev-ruby/rspec-expectations/rspec-expectations-2.11.1.ebuild42
2 files changed, 49 insertions, 1 deletions
diff --git a/dev-ruby/rspec-expectations/ChangeLog b/dev-ruby/rspec-expectations/ChangeLog
index 74f4982d2506..9258ae51f679 100644
--- a/dev-ruby/rspec-expectations/ChangeLog
+++ b/dev-ruby/rspec-expectations/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/rspec-expectations
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec-expectations/ChangeLog,v 1.23 2012/06/10 06:51:00 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec-expectations/ChangeLog,v 1.24 2012/07/15 06:57:20 graaff Exp $
+
+*rspec-expectations-2.11.1 (15 Jul 2012)
+
+ 15 Jul 2012; Hans de Graaff <graaff@gentoo.org>
+ +rspec-expectations-2.11.1.ebuild:
+ Version bump.
*rspec-expectations-2.10.0 (10 Jun 2012)
diff --git a/dev-ruby/rspec-expectations/rspec-expectations-2.11.1.ebuild b/dev-ruby/rspec-expectations/rspec-expectations-2.11.1.ebuild
new file mode 100644
index 000000000000..bccbaa4263a8
--- /dev/null
+++ b/dev-ruby/rspec-expectations/rspec-expectations-2.11.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec-expectations/rspec-expectations-2.11.1.ebuild,v 1.1 2012/07/15 06:57:20 graaff Exp $
+
+EAPI=4
+USE_RUBY="ruby18 ree18 ruby19 jruby"
+
+RUBY_FAKEGEM_TASK_TEST="none"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="Changelog.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Behaviour Driven Development (BDD) framework for Ruby"
+HOMEPAGE="http://rspec.rubyforge.org/"
+SRC_URI="https://github.com/rspec/${PN}/tarball/v${PV} -> ${P}-git.tgz"
+RUBY_S="rspec-${PN}-*"
+
+LICENSE="MIT"
+SLOT="2"
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/diff-lcs-1.1.3"
+
+ruby_add_bdepend "test? (
+ >=dev-ruby/rspec-core-2.11.0:2
+ dev-ruby/rspec-mocks:2
+ )"
+
+all_ruby_prepare() {
+ # Don't set up bundler: it doesn't understand our setup.
+ sed -i -e '/[Bb]undler/d' Rakefile || die
+
+ # Remove the Gemfile to avoid running through 'bundle exec'
+ rm Gemfile || die
+}
+
+each_ruby_test() {
+ PATH="${S}/bin:${PATH}" RUBYLIB="${S}/lib" ${RUBY} -S rspec spec || die
+}