summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2014-07-10 10:06:56 +0000
committerHans de Graaff <graaff@gentoo.org>2014-07-10 10:06:56 +0000
commitde935554735956e0168a4fb0fb5cd67d4af7e4d3 (patch)
tree0ec70aaabee5819e4717ce3066c5e150a30959ad /dev-ruby/rspec/rspec-1.3.2-r1.ebuild
parentAdd ruby20, ruby21. Drop sparc keyword, bug 465948. (diff)
downloadhistorical-de935554735956e0168a4fb0fb5cd67d4af7e4d3.tar.gz
historical-de935554735956e0168a4fb0fb5cd67d4af7e4d3.tar.bz2
historical-de935554735956e0168a4fb0fb5cd67d4af7e4d3.zip
Fix dependencies for ruby20 and ruby21.
Package-Manager: portage-2.2.8-r1/cvs/Linux x86_64 Manifest-Sign-Key: 0x8883FA56A308A8D7!
Diffstat (limited to 'dev-ruby/rspec/rspec-1.3.2-r1.ebuild')
-rw-r--r--dev-ruby/rspec/rspec-1.3.2-r1.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/dev-ruby/rspec/rspec-1.3.2-r1.ebuild b/dev-ruby/rspec/rspec-1.3.2-r1.ebuild
index 0ad838f3207b..2c85ddff6343 100644
--- a/dev-ruby/rspec/rspec-1.3.2-r1.ebuild
+++ b/dev-ruby/rspec/rspec-1.3.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec/rspec-1.3.2-r1.ebuild,v 1.1 2014/07/10 09:53:46 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec/rspec-1.3.2-r1.ebuild,v 1.2 2014/07/10 10:06:55 graaff Exp $
EAPI=5
USE_RUBY="ruby19 ruby20 ruby21 jruby"
@@ -36,13 +36,13 @@ RDEPEND="!<dev-ruby/rspec-rails-${PV}"
# We should add nokogiri here to make sure that we test as much as
# possible, but since it's yet unported to 1.9 and the nokogiri-due
# tests fail for sure, we'll be waiting on it.
-USE_RUBY="ruby19" \
+USE_RUBY="ruby19 ruby20 ruby21" \
ruby_add_bdepend "test? (
>=dev-ruby/hoe-2.0.0
dev-ruby/zentest
>=dev-ruby/syntax-1.0
>=dev-ruby/fakefs-0.2.1 )"
-USE_RUBY="ruby19" ruby_add_bdepend "test? ( =dev-ruby/test-unit-1.2.3 )"
+USE_RUBY="ruby19 ruby20 ruby21" ruby_add_bdepend "test? ( ~dev-ruby/test-unit-1.2.3 )"
all_ruby_prepare() {
# Avoid dependency on git.