summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2012-01-28 09:04:24 +0000
committerHans de Graaff <graaff@gentoo.org>2012-01-28 09:04:24 +0000
commit3a44c24d2a654673e51c6e8e5b3a8c6f31cacb04 (patch)
treeb3d26988fcfb5809ae9ab0fe1f973e513b92e51a /dev-ruby/ruby-rc4/ruby-rc4-0.1.4.ebuild
parentVersion bump. Update patch to remove fix applied upstream. (diff)
downloadhistorical-3a44c24d2a654673e51c6e8e5b3a8c6f31cacb04.tar.gz
historical-3a44c24d2a654673e51c6e8e5b3a8c6f31cacb04.tar.bz2
historical-3a44c24d2a654673e51c6e8e5b3a8c6f31cacb04.zip
Version bump.
Package-Manager: portage-2.1.10.44/cvs/Linux x86_64
Diffstat (limited to 'dev-ruby/ruby-rc4/ruby-rc4-0.1.4.ebuild')
-rw-r--r--dev-ruby/ruby-rc4/ruby-rc4-0.1.4.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-ruby/ruby-rc4/ruby-rc4-0.1.4.ebuild b/dev-ruby/ruby-rc4/ruby-rc4-0.1.4.ebuild
new file mode 100644
index 000000000000..72fd94581e41
--- /dev/null
+++ b/dev-ruby/ruby-rc4/ruby-rc4-0.1.4.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-rc4/ruby-rc4-0.1.4.ebuild,v 1.1 2012/01/28 09:04:24 graaff Exp $
+
+EAPI=4
+USE_RUBY="ruby18 ree18 ruby19 jruby"
+
+RUBY_FAKEGEM_TASK_TEST="spec"
+
+RUBY_FAKEGEM_DOCDIR="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A pure Ruby implementation of the Rc4 algorithm."
+HOMEPAGE="https://github.com/caiges/Ruby-RC4"
+SRC_URI="https://github.com/caiges/Ruby-RC4/tarball/9e70c22a5f05deb0d19b9f91bac4cf2332acaf28 -> ${P}-git.tgz"
+RUBY_S="caiges-Ruby-RC4-*"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/rspec:2 )"
+
+all_ruby_prepare() {
+ sed -i -e 's/"README"/"README.md"/' Rakefile || die
+}