summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Kohl <citizen428@gentoo.org>2005-02-15 19:06:36 +0000
committerMichael Kohl <citizen428@gentoo.org>2005-02-15 19:06:36 +0000
commite8dadeb8fa9623a7e27b1761eb559ce2f911cdd8 (patch)
treea8b7a7135fbdd8ca11e71e6784474cd09cf9a7fc /dev-ruby/rubytorrent/rubytorrent-0.3.ebuild
parent~ppc-macos keyword (diff)
downloadhistorical-e8dadeb8fa9623a7e27b1761eb559ce2f911cdd8.tar.gz
historical-e8dadeb8fa9623a7e27b1761eb559ce2f911cdd8.tar.bz2
historical-e8dadeb8fa9623a7e27b1761eb559ce2f911cdd8.zip
Initial import.
Package-Manager: portage-2.0.51-r15
Diffstat (limited to 'dev-ruby/rubytorrent/rubytorrent-0.3.ebuild')
-rw-r--r--dev-ruby/rubytorrent/rubytorrent-0.3.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-ruby/rubytorrent/rubytorrent-0.3.ebuild b/dev-ruby/rubytorrent/rubytorrent-0.3.ebuild
new file mode 100644
index 000000000000..7c982a4c183c
--- /dev/null
+++ b/dev-ruby/rubytorrent/rubytorrent-0.3.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rubytorrent/rubytorrent-0.3.ebuild,v 1.1 2005/02/15 19:06:36 citizen428 Exp $
+
+DESCRIPTION="A pure-Ruby BitTorrent peer library and toolset"
+HOMEPAGE="http://rubytorrent.rubyforge.org/"
+SRC_URI="http://rubyforge.org/frs/download.php/3017/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="virtual/ruby"
+
+USE_RUBY="ruby18 ruby19"
+
+src_install() {
+ local sitelibdir=`ruby -r rbconfig -e 'puts Config::CONFIG["sitelibdir"]'`
+ insinto "$sitelibdir"
+ doins rubytorrent.rb
+ insinto "$sitelibdir/rubytorrent"
+ doins rubytorrent/*
+ dodoc doc/* README ReleaseNotes.txt
+ docinto examples
+ dodoc dump-metainfo.rb dump-peers.rb make-metainfo.rb \
+ rtpeer-ncurses.rb rtpeer.rb
+}
+
+pkg_postinstall() {
+ einfo
+ einfo "Examples on how to use this package can be found at /usr/share/doc/${PF}/examples/"
+ einfo
+}