summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2012-10-16 12:14:02 +0000
committerHans de Graaff <graaff@gentoo.org>2012-10-16 12:14:02 +0000
commit458aed82cb676c3703a0c5aee6ae23ba2f225372 (patch)
tree8269a93db589f4314409b25220ae6dfdc67e05f7 /dev-ruby/temple/temple-0.5.4.ebuild
parentForce python-2, wrt bug #409375. (diff)
downloadhistorical-458aed82cb676c3703a0c5aee6ae23ba2f225372.tar.gz
historical-458aed82cb676c3703a0c5aee6ae23ba2f225372.tar.bz2
historical-458aed82cb676c3703a0c5aee6ae23ba2f225372.zip
Version bump.
Package-Manager: portage-2.1.11.9/cvs/Linux x86_64
Diffstat (limited to 'dev-ruby/temple/temple-0.5.4.ebuild')
-rw-r--r--dev-ruby/temple/temple-0.5.4.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-ruby/temple/temple-0.5.4.ebuild b/dev-ruby/temple/temple-0.5.4.ebuild
new file mode 100644
index 000000000000..8faef3ff2797
--- /dev/null
+++ b/dev-ruby/temple/temple-0.5.4.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/temple/temple-0.5.4.ebuild,v 1.1 2012/10/16 12:14:02 graaff Exp $
+
+EAPI=4
+USE_RUBY="ruby18 ruby19 ree18"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGES EXPRESSIONS.md README.md"
+
+RUBY_FAKEGEM_TASK_TEST=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="An abstraction and a framework for compiling templates to pure Ruby."
+HOMEPAGE="http://github.com/judofyr/temple"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/bacon dev-ruby/tilt )"
+
+each_ruby_test() {
+ ${RUBY} -S bacon -Ilib -Itest --automatic --quiet || die
+}