summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2012-10-05 10:09:28 +0000
committerHans de Graaff <graaff@gentoo.org>2012-10-05 10:09:28 +0000
commit3051ea7bdb43ecbcedf3061967b9069da93f3eac (patch)
treed744948a3573d75bfb6b361ca73022bbcba23618 /dev-ruby
parentFlip dependencies around in || ( ) atom wrt #436672 (diff)
downloadhistorical-3051ea7bdb43ecbcedf3061967b9069da93f3eac.tar.gz
historical-3051ea7bdb43ecbcedf3061967b9069da93f3eac.tar.bz2
historical-3051ea7bdb43ecbcedf3061967b9069da93f3eac.zip
Version bump.
Package-Manager: portage-2.1.11.9/cvs/Linux x86_64
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/fast_gettext/ChangeLog7
-rw-r--r--dev-ruby/fast_gettext/fast_gettext-0.6.10.ebuild46
-rw-r--r--dev-ruby/file-tail/ChangeLog7
-rw-r--r--dev-ruby/file-tail/file-tail-1.0.12.ebuild33
-rw-r--r--dev-ruby/gettext_i18n_rails/ChangeLog8
-rw-r--r--dev-ruby/gettext_i18n_rails/gettext_i18n_rails-0.7.1.ebuild35
6 files changed, 133 insertions, 3 deletions
diff --git a/dev-ruby/fast_gettext/ChangeLog b/dev-ruby/fast_gettext/ChangeLog
index 229c008f49be..ef47a66d09b3 100644
--- a/dev-ruby/fast_gettext/ChangeLog
+++ b/dev-ruby/fast_gettext/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/fast_gettext
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/fast_gettext/ChangeLog,v 1.17 2012/08/06 17:29:08 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/fast_gettext/ChangeLog,v 1.18 2012/10/05 10:03:43 graaff Exp $
+
+*fast_gettext-0.6.10 (05 Oct 2012)
+
+ 05 Oct 2012; Hans de Graaff <graaff@gentoo.org> +fast_gettext-0.6.10.ebuild:
+ Version bump.
*fast_gettext-0.6.9 (06 Aug 2012)
diff --git a/dev-ruby/fast_gettext/fast_gettext-0.6.10.ebuild b/dev-ruby/fast_gettext/fast_gettext-0.6.10.ebuild
new file mode 100644
index 000000000000..7700fe59d7a3
--- /dev/null
+++ b/dev-ruby/fast_gettext/fast_gettext-0.6.10.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/fast_gettext/fast_gettext-0.6.10.ebuild,v 1.1 2012/10/05 10:03:43 graaff Exp $
+
+EAPI="4"
+
+# jruby support requires sqlite3 support for jruby.
+USE_RUBY="ruby18 ruby19 ree18"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG Readme.md"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="GetText but 3.5 x faster, 560 x less memory, simple, clean namespace (7 vs 34) and threadsave!"
+HOMEPAGE="https://github.com/grosser/fast_gettext"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/activerecord dev-ruby/bundler )"
+
+all_ruby_prepare() {
+ rm Gemfile.lock || die
+
+ # Remove jeweler from Gemfile since it is not needed for tests.
+ sed -i '/jeweler/d' Gemfile || die
+
+ # Avoid unneeded dependency on git.
+ sed -i -e '/git ls-files/ s:^:#:' fast_gettext.gemspec || die
+
+ # Don't run a test that requires safe mode which we can't provide
+ # due to insecure directory settings for the portage dir. This spec
+ # also calls out to ruby which won't work with different ruby
+ # implementations.
+ sed -i -e '/can work in SAFE mode/,/end/ s:^:#:' spec/fast_gettext/translation_repository/mo_spec.rb || die
+}
+
+each_ruby_prepare() {
+ # Make sure the right ruby interpreter is used
+ sed -i -e "s:bundle exec ruby:bundle exec ${RUBY}:" spec/fast_gettext/vendor/*spec.rb || die
+}
diff --git a/dev-ruby/file-tail/ChangeLog b/dev-ruby/file-tail/ChangeLog
index 58f2b76e320e..b1e066e05880 100644
--- a/dev-ruby/file-tail/ChangeLog
+++ b/dev-ruby/file-tail/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/file-tail
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/file-tail/ChangeLog,v 1.8 2012/08/21 16:51:34 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/file-tail/ChangeLog,v 1.9 2012/10/05 10:07:55 graaff Exp $
+
+*file-tail-1.0.12 (05 Oct 2012)
+
+ 05 Oct 2012; Hans de Graaff <graaff@gentoo.org> +file-tail-1.0.12.ebuild:
+ Version bump.
*file-tail-1.0.11 (21 Aug 2012)
diff --git a/dev-ruby/file-tail/file-tail-1.0.12.ebuild b/dev-ruby/file-tail/file-tail-1.0.12.ebuild
new file mode 100644
index 000000000000..4182ac3458d7
--- /dev/null
+++ b/dev-ruby/file-tail/file-tail-1.0.12.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/file-tail/file-tail-1.0.12.ebuild,v 1.1 2012/10/05 10:07:55 graaff Exp $
+
+EAPI=4
+
+USE_RUBY="ruby18 ruby19 ree18 jruby"
+
+RUBY_FAKEGEM_RECIPE_TEST="none"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_DOC_SOURCES="lib README.rdoc"
+
+RUBY_FAKEGEM_EXTRADOC="README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A small ruby library that allows it to 'tail' files in Ruby"
+HOMEPAGE="http://flori.github.com/file-tail"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/tins-0.5"
+ruby_add_bdepend "test? ( >=dev-ruby/test-unit-2.5.1-r1 )"
+
+each_ruby_test() {
+ ruby-ng_testrb-2 -Ilib tests/*_test.rb
+}
diff --git a/dev-ruby/gettext_i18n_rails/ChangeLog b/dev-ruby/gettext_i18n_rails/ChangeLog
index 1119c32153a6..d3760b296ea2 100644
--- a/dev-ruby/gettext_i18n_rails/ChangeLog
+++ b/dev-ruby/gettext_i18n_rails/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/gettext_i18n_rails
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/gettext_i18n_rails/ChangeLog,v 1.16 2012/08/06 18:13:45 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/gettext_i18n_rails/ChangeLog,v 1.17 2012/10/05 10:09:28 graaff Exp $
+
+*gettext_i18n_rails-0.7.1 (05 Oct 2012)
+
+ 05 Oct 2012; Hans de Graaff <graaff@gentoo.org>
+ +gettext_i18n_rails-0.7.1.ebuild:
+ Version bump.
*gettext_i18n_rails-0.6.6 (06 Aug 2012)
diff --git a/dev-ruby/gettext_i18n_rails/gettext_i18n_rails-0.7.1.ebuild b/dev-ruby/gettext_i18n_rails/gettext_i18n_rails-0.7.1.ebuild
new file mode 100644
index 000000000000..961cd508a007
--- /dev/null
+++ b/dev-ruby/gettext_i18n_rails/gettext_i18n_rails-0.7.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/gettext_i18n_rails/gettext_i18n_rails-0.7.1.ebuild,v 1.1 2012/10/05 10:09:28 graaff Exp $
+
+EAPI="4"
+
+# jruby support requires sqlite3 support for jruby.
+USE_RUBY="ruby18 ruby19 ree18"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="Readme.md"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+RUBY_FAKEGEM_EXTRAINSTALL="init.rb"
+
+inherit ruby-fakegem
+
+DESCRIPTION="FastGettext / Rails integration."
+HOMEPAGE="https://github.com/grosser/gettext_i18n_rails"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/activerecord[sqlite3] dev-ruby/temple )"
+ruby_add_rdepend ">=dev-ruby/fast_gettext-0.4.8"
+
+all_ruby_prepare() {
+ rm Gemfile Gemfile.lock || die
+
+ # Remove specs for slim and hamlet, template engines we don't package.
+ rm spec/gettext_i18n_rails/slim_parser_spec.rb spec/gettext_i18n_rails/hamlet_parser_spec.rb || die
+}