summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-04-12 18:09:58 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-04-12 18:09:58 +0000
commit9e3df2d6e2a806569638228b80dc35249d1acae0 (patch)
tree38bfd0d50f52f4dbdcc20fae6be7a01a15436c2c /dev-tcltk/snack
parentCall Python-related functions only with USE="python". (diff)
downloadhistorical-9e3df2d6e2a806569638228b80dc35249d1acae0.tar.gz
historical-9e3df2d6e2a806569638228b80dc35249d1acae0.tar.bz2
historical-9e3df2d6e2a806569638228b80dc35249d1acae0.zip
Delete older ebuilds.
Diffstat (limited to 'dev-tcltk/snack')
-rw-r--r--dev-tcltk/snack/snack-2.2.10-r2.ebuild75
-rw-r--r--dev-tcltk/snack/snack-2.2.10-r3.ebuild82
-rw-r--r--dev-tcltk/snack/snack-2.2.9.ebuild53
3 files changed, 0 insertions, 210 deletions
diff --git a/dev-tcltk/snack/snack-2.2.10-r2.ebuild b/dev-tcltk/snack/snack-2.2.10-r2.ebuild
deleted file mode 100644
index fd14b250ab7a..000000000000
--- a/dev-tcltk/snack/snack-2.2.10-r2.ebuild
+++ /dev/null
@@ -1,75 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/snack/snack-2.2.10-r2.ebuild,v 1.10 2011/04/05 05:29:01 ulm Exp $
-
-inherit eutils multilib
-
-DESCRIPTION="The Snack Sound Toolkit (Tcl)"
-HOMEPAGE="http://www.speech.kth.se/snack/"
-SRC_URI="http://www.speech.kth.se/snack/dist/${PN}${PV}.tar.gz"
-
-LICENSE="GPL-2"
-KEYWORDS="alpha amd64 hppa ppc ppc64 sparc x86"
-SLOT="0"
-IUSE="alsa examples python threads vorbis"
-
-RESTRICT="test" # Bug 78354
-
-DEPEND=">dev-lang/tcl-8.4.3
- >dev-lang/tk-8.4.3
- alsa? ( media-libs/alsa-lib )
- vorbis? ( media-libs/libvorbis )
- python? ( dev-lang/python )"
-RDEPEND="${DEPEND}"
-
-S="${WORKDIR}/${PN}${PV}/unix"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- # bug 226137 - snack depends on alsa private symbol _snd_pcm_mmap_hw_ptr
- epatch "${FILESDIR}"/alsa-undef-sym.patch
- # bug 270839 - error from /usr/include/bits/mathcalls.h:310
- sed -i -e 's|^\(#define roundf(.*\)|//\1|' ../generic/jkFormatMP3.c
-}
-
-src_compile() {
- local myconf="--libdir=/usr/$(get_libdir) --includedir=/usr/include"
-
- use alsa && myconf="${myconf} --enable-alsa"
- use threads && myconf="${myconf} --enable-threads"
-
- if use vorbis ; then
- myconf="${myconf} --with-ogg-include=/usr/include"
- myconf="${myconf} --with-ogg-lib=/usr/$(get_libdir)"
- fi
-
- econf ${myconf} || die "configure failed"
- emake || die "make failed"
-
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "make install failed"
-
- if use python ; then
- cd "${S}"/../python
- python setup.py install --root="${D}" || die
- fi
-
- cd "${S}"/..
-
- dodoc README changes
- dohtml doc/*
-
- if use examples ; then
- sed -i -e 's/wish[0-9.]+/wish/g' demos/tcl/* || die
- docinto examples/tcl
- dodoc demos/tcl/*
-
- if use python ; then
- docinto examples/python
- dodoc demos/python/*
- fi
- fi
-}
diff --git a/dev-tcltk/snack/snack-2.2.10-r3.ebuild b/dev-tcltk/snack/snack-2.2.10-r3.ebuild
deleted file mode 100644
index fb1c05e93d1f..000000000000
--- a/dev-tcltk/snack/snack-2.2.10-r3.ebuild
+++ /dev/null
@@ -1,82 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/snack/snack-2.2.10-r3.ebuild,v 1.1 2010/03/31 21:18:12 jlec Exp $
-
-EAPI="3"
-
-PYTHON_DEPEND="python? 2"
-
-inherit eutils multilib python
-
-DESCRIPTION="The Snack Sound Toolkit (Tcl)"
-HOMEPAGE="http://www.speech.kth.se/snack/"
-SRC_URI="http://www.speech.kth.se/snack/dist/${PN}${PV}.tar.gz"
-
-LICENSE="GPL-2"
-KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
-SLOT="0"
-IUSE="alsa examples python threads vorbis"
-
-RESTRICT="test" # Bug 78354
-
-DEPEND="
- >dev-lang/tk-8.4.3
- alsa? ( media-libs/alsa-lib )
- vorbis? ( media-libs/libvorbis )"
-RDEPEND="${DEPEND}"
-
-S="${WORKDIR}/${PN}${PV}/unix"
-
-src_prepare() {
- # bug 226137 - snack depends on alsa private symbol _snd_pcm_mmap_hw_ptr
- epatch "${FILESDIR}"/alsa-undef-sym.patch
- # bug 270839 - error from /usr/include/bits/mathcalls.h:310
- sed -i -e 's|^\(#define roundf(.*\)|//\1|' ../generic/jkFormatMP3.c
-}
-
-src_configure() {
- local myconf="--libdir=/usr/$(get_libdir) --includedir=/usr/include"
-
- use alsa && myconf="${myconf} --enable-alsa"
- use threads && myconf="${myconf} --enable-threads"
-
- if use vorbis ; then
- myconf="${myconf} --with-ogg-include=/usr/include"
- myconf="${myconf} --with-ogg-lib=/usr/$(get_libdir)"
- fi
-
- econf ${myconf}
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "make install failed"
-
- if use python ; then
- cd "${S}"/../python
- python setup.py install --root="${D}" || die
- fi
-
- cd "${S}"/..
-
- dodoc README changes
- dohtml doc/*
-
- if use examples ; then
- sed -i -e 's/wish[0-9.]+/wish/g' demos/tcl/* || die
- docinto examples/tcl
- dodoc demos/tcl/*
-
- if use python ; then
- docinto examples/python
- dodoc demos/python/*
- fi
- fi
-}
-
-pkg_postinst() {
- python_mod_optimize tkSnack.py
-}
-
-pkg_postrm() {
- python_mod_cleanup tkSnack.py
-}
diff --git a/dev-tcltk/snack/snack-2.2.9.ebuild b/dev-tcltk/snack/snack-2.2.9.ebuild
deleted file mode 100644
index d173a813c8dd..000000000000
--- a/dev-tcltk/snack/snack-2.2.9.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/snack/snack-2.2.9.ebuild,v 1.9 2011/04/05 05:29:01 ulm Exp $
-
-inherit eutils multilib
-
-DESCRIPTION="The Snack Sound Toolkit (Tcl)"
-HOMEPAGE="http://www.speech.kth.se/snack/"
-SRC_URI="http://www.speech.kth.se/~kare/${PN}${PV}.tar.gz"
-
-LICENSE="GPL-2"
-KEYWORDS="amd64 ~ppc ppc64 sparc x86"
-SLOT="0"
-IUSE="alsa python threads vorbis"
-
-DEPEND=">dev-lang/tcl-8.4.3
- >dev-lang/tk-8.4.3
- alsa? ( media-libs/alsa-lib )
- vorbis? ( media-libs/libvorbis )
- python? ( dev-lang/python )"
-
-S="${WORKDIR}/${PN}${PV}"
-
-src_compile() {
- local myconf="--libdir=/usr/$(get_libdir) --includedir=/usr/include"
-
- use alsa && myconf="${myconf} --enable-alsa"
- use threads && myconf="${myconf} --enable-threads"
-
- if use vorbis ; then
- myconf="${myconf} --with-ogg-include=/usr/include"
- myconf="${myconf} --with-ogg-lib=/usr/$(get_libdir)"
- fi
-
- cd ${S}/unix
- econf ${myconf} || die "configure failed"
- emake || die "make failed"
-}
-
-src_install() {
- cd ${S}/unix
- make DESTDIR=${D} install || die "make install failed"
-
- if use python ; then
- cd ${S}/python
- python setup.py install --root=${D} || die
- fi
-
- cd ${S}
-
- dodoc README changes
- dohtml doc/*
-}