summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gardiner <obz@gentoo.org>2003-09-15 14:53:43 +0000
committerMike Gardiner <obz@gentoo.org>2003-09-15 14:53:43 +0000
commit3e09fbb573384d71043e54b40ffe97da1a386842 (patch)
tree267f033cc78d85e96038374b1bedffadfb12ae7c /dev-tex/cpp2latex/cpp2latex-2.3.ebuild
parentNew version, big cleanup, removed old version (diff)
downloadhistorical-3e09fbb573384d71043e54b40ffe97da1a386842.tar.gz
historical-3e09fbb573384d71043e54b40ffe97da1a386842.tar.bz2
historical-3e09fbb573384d71043e54b40ffe97da1a386842.zip
New version, big cleanup, removed old version
Diffstat (limited to 'dev-tex/cpp2latex/cpp2latex-2.3.ebuild')
-rw-r--r--dev-tex/cpp2latex/cpp2latex-2.3.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-tex/cpp2latex/cpp2latex-2.3.ebuild b/dev-tex/cpp2latex/cpp2latex-2.3.ebuild
new file mode 100644
index 000000000000..9531bbd0a972
--- /dev/null
+++ b/dev-tex/cpp2latex/cpp2latex-2.3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tex/cpp2latex/cpp2latex-2.3.ebuild,v 1.1 2003/09/15 14:53:33 obz Exp $
+
+# eutils is in portage proper now, no need to inherit
+
+DESCRIPTION="A program to convert C++ code to LaTeX source"
+HOMEPAGE="http://www.arnoldarts.de/cpp2latex.html"
+SRC_URI="http://www.arnoldarts.de/${P}.tar.gz"
+LICENSE="GPL-2"
+
+IUSE=""
+SLOT="0"
+KEYWORDS="x86 ppc"
+
+# although it makes sense to have tex installed, it is
+# neither a compile or runtime dependency
+
+src_compile() {
+
+ econf || die
+ emake || die
+
+}
+
+src_install() {
+
+ make install DESTDIR=${D} || die
+
+}