summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Buisse <nattfodd@gentoo.org>2005-12-20 19:28:52 +0000
committerAlexandre Buisse <nattfodd@gentoo.org>2005-12-20 19:28:52 +0000
commitde1960f2a2ed33496deac6a85c5ba623e11f7641 (patch)
treef05d0742112f0abf45a48bb058a6fce56aad0d89 /dev-tex/latex2rtf/latex2rtf-1.9.16.ebuild
parentclean up (diff)
downloadhistorical-de1960f2a2ed33496deac6a85c5ba623e11f7641.tar.gz
historical-de1960f2a2ed33496deac6a85c5ba623e11f7641.tar.bz2
historical-de1960f2a2ed33496deac6a85c5ba623e11f7641.zip
Bump to 1.9.16 (security fixes and other improvements).
Package-Manager: portage-2.0.51.22-r3
Diffstat (limited to 'dev-tex/latex2rtf/latex2rtf-1.9.16.ebuild')
-rw-r--r--dev-tex/latex2rtf/latex2rtf-1.9.16.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-tex/latex2rtf/latex2rtf-1.9.16.ebuild b/dev-tex/latex2rtf/latex2rtf-1.9.16.ebuild
new file mode 100644
index 000000000000..b93798626d6b
--- /dev/null
+++ b/dev-tex/latex2rtf/latex2rtf-1.9.16.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tex/latex2rtf/latex2rtf-1.9.16.ebuild,v 1.1 2005/12/20 19:28:52 nattfodd Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="LaTeX to RTF converter"
+HOMEPAGE="http://latex2rtf.sourceforge.net/"
+SRC_URI="mirror://sourceforge/latex2rtf/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc ~amd64"
+SLOT="0"
+IUSE="doc"
+
+DEPEND="virtual/libc
+ virtual/tetex
+ media-gfx/imagemagick"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${PN}-Makefile-gentoo.diff
+ epatch ${FILESDIR}/${P}-direntry.patch
+}
+
+src_compile() {
+ emake CC=$(tc-getCC) || die
+}
+
+src_install() {
+ make PREFIX=${D}/usr CC=$(tc-getCC) install || die
+ dodoc README doc/latex2rtf.txt
+ # if doc is not used, only the text version is intalled.
+ if use doc; then
+ dohtml doc/latex2rtf.html
+ dodoc doc/latex2rtf.pdf doc/latex2rtf.txt
+ sed -i "s/\r/\n/g" doc/latex2rtf.info
+ doinfo doc/latex2rtf.info
+ fi
+}