summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2012-03-02 17:26:38 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2012-03-02 17:26:38 +0000
commit2d412b20c98630717e79e362f065868eba5db36d (patch)
tree9deb4f1f9aaa3330fb105c4e472619260cf969c3 /dev-util/astyle/files
parentSupport switching GLES implementations as well, fix bug #406501 (diff)
downloadhistorical-2d412b20c98630717e79e362f065868eba5db36d.tar.gz
historical-2d412b20c98630717e79e362f065868eba5db36d.tar.bz2
historical-2d412b20c98630717e79e362f065868eba5db36d.zip
Version bump wrt bug #311281 by Arseny Solokha <asolokha@gmx.com>. Use package's build system and helpers instead of rewriting it from scratch. Drop useless debug flag, install docs and build/install static lib conditionally
Package-Manager: portage-2.2.0_alpha89/cvs/Linux x86_64
Diffstat (limited to 'dev-util/astyle/files')
-rw-r--r--dev-util/astyle/files/astyle-2.02.1-build_system.patch54
1 files changed, 54 insertions, 0 deletions
diff --git a/dev-util/astyle/files/astyle-2.02.1-build_system.patch b/dev-util/astyle/files/astyle-2.02.1-build_system.patch
new file mode 100644
index 000000000000..1d63a512e9bc
--- /dev/null
+++ b/dev-util/astyle/files/astyle-2.02.1-build_system.patch
@@ -0,0 +1,54 @@
+--- a/build/gcc/Makefile
++++ b/build/gcc/Makefile
+@@ -34,25 +34,25 @@
+ ipath=$(prefix)/bin
+ CBASEFLAGS = -W -Wall -fno-rtti -fno-exceptions
+ JAVAINCS = -I$(JAVA_HOME)/include
+-CXX = g++
++CXX ?= g++
+ INSTALL=install -o $(USER) -g $(USER)
+
+ ##################################################
+
+ # define compile options for each build
+-ifdef CFLAGS
+- CFLAGSr = -DNDEBUG $(CBASEFLAGS) $(CFLAGS)
+- CFLAGSd = -g $(CBASEFLAGS) $(CFLAGS)
++ifdef CXXFLAGS
++ CFLAGSr = -DNDEBUG $(CBASEFLAGS) $(CXXFLAGS)
++ CFLAGSd = -g $(CBASEFLAGS) $(CXXFLAGS)
+ else
+ CFLAGSr = -DNDEBUG -O3 $(CBASEFLAGS)
+ CFLAGSd = -g $(CBASEFLAGS)
+ endif
+-CFLAGSs = -DASTYLE_LIB -fpic $(CFLAGSr)
+-CFLAGSsd = -DASTYLE_LIB -fpic $(CFLAGSd)
++CFLAGSs = -DASTYLE_LIB -fPIC $(CFLAGSr)
++CFLAGSsd = -DASTYLE_LIB -fPIC $(CFLAGSd)
+ CFLAGSa = -DASTYLE_LIB $(CFLAGSr)
+ CFLAGSad = -DASTYLE_LIB $(CFLAGSd)
+-CFLAGSsj = -DASTYLE_JNI -fpic $(CFLAGSr) $(JAVAINCS)
+-CFLAGSsjd = -DASTYLE_JNI -fpic $(CFLAGSd) $(JAVAINCS)
++CFLAGSsj = -DASTYLE_JNI -fPIC $(CFLAGSr) $(JAVAINCS)
++CFLAGSsjd = -DASTYLE_JNI -fPIC $(CFLAGSd) $(JAVAINCS)
+
+ # define link options
+ ifdef LDFLAGS
+@@ -134,7 +134,7 @@
+ shared: libastyle.so
+ libastyle.so: $(OBJs)
+ @ mkdir -p $(bindir)
+- $(CXX) -shared $(LDFLAGSr) -o $(bindir)/$@ $^
++ $(CXX) -shared -Wl,-soname,$@.0 $(LDFLAGSr) -o $(bindir)/$@.0.0.0 $^
+ @ echo
+
+ shareddebug: libastyled.so
+@@ -158,7 +158,7 @@
+ java: libastylej.so
+ libastylej.so: $(OBJsj)
+ @ mkdir -p $(bindir)
+- $(CXX) -shared $(LDFLAGSr) -o $(bindir)/$@ $^
++ $(CXX) -shared -Wl,-soname,$@.0 $(LDFLAGSr) -o $(bindir)/$@.0.0.0 $^
+ @ echo
+
+ javadebug: libastylejd.so