summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Ullmann <jokey@gentoo.org>2007-10-29 14:30:58 +0000
committerMarkus Ullmann <jokey@gentoo.org>2007-10-29 14:30:58 +0000
commit488cfabf329b875a8444a79f7cfe66171d485302 (patch)
treea30f3c3d1096b28287d6728a32ef0198316a28d3 /dev-util/bugle/bugle-0.0.20071009.ebuild
parentStable on x86 and drop old (diff)
downloadhistorical-488cfabf329b875a8444a79f7cfe66171d485302.tar.gz
historical-488cfabf329b875a8444a79f7cfe66171d485302.tar.bz2
historical-488cfabf329b875a8444a79f7cfe66171d485302.zip
Version bump
Package-Manager: portage-2.1.3.16
Diffstat (limited to 'dev-util/bugle/bugle-0.0.20071009.ebuild')
-rw-r--r--dev-util/bugle/bugle-0.0.20071009.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-util/bugle/bugle-0.0.20071009.ebuild b/dev-util/bugle/bugle-0.0.20071009.ebuild
new file mode 100644
index 000000000000..3b3cd3d864d8
--- /dev/null
+++ b/dev-util/bugle/bugle-0.0.20071009.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/bugle/bugle-0.0.20071009.ebuild,v 1.1 2007/10/29 14:30:57 jokey Exp $
+
+inherit autotools toolchain-funcs
+
+DESCRIPTION="A tool for OpenGL debugging"
+HOMEPAGE="http://www.opengl.org/sdk/tools/BuGLe/"
+SRC_URI="mirror://sourceforge/bugle/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ffmpeg gtk readline"
+
+DEPEND="ffmpeg? ( media-video/ffmpeg )
+ gtk? ( >=x11-libs/gtk+-2.4.0 >=x11-libs/gtkglext-1.0.0 )
+ readline? ( sys-libs/readline )
+ sys-libs/ncurses"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ if [ "$(gcc-version)" == "4.0" ]; then
+ die "BuGLe doesn't work with gcc-4.0. Use gcc-3.x or >=gcc-4.1."
+ fi
+
+ econf \
+ $(use_with ffmpeg) \
+ $(use_with readline) \
+ $(use_with gtk) \
+ $(use_with gtk gtkglext) \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ dodoc README TODO TROUBLESHOOTING FAQ doc/*.{txt,html}
+ docinto examples
+ dodoc doc/examples/*
+ emake DESTDIR="${D}" install || die "emake install failed"
+}
+
+pkg_postinst() {
+ elog "See man 3 bugle for an introduction to BuGLe."
+}