summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Kursawe <phosphan@gentoo.org>2009-07-07 18:40:44 +0000
committerPatrick Kursawe <phosphan@gentoo.org>2009-07-07 18:40:44 +0000
commitc059c964cc136bcbb8bc02f89013fd9e5f81cd21 (patch)
treeeba199e72abefbe422a2135a7d3510c6e38b9b94 /dev-util/cdecl/files
parentversion bump to 0.5, bug 276949 (diff)
downloadhistorical-c059c964cc136bcbb8bc02f89013fd9e5f81cd21.tar.gz
historical-c059c964cc136bcbb8bc02f89013fd9e5f81cd21.tar.bz2
historical-c059c964cc136bcbb8bc02f89013fd9e5f81cd21.zip
Fixing build with glibc-2.10, see bug #276068.
Package-Manager: portage-2.1.6.13/cvs/Linux i686
Diffstat (limited to 'dev-util/cdecl/files')
-rw-r--r--dev-util/cdecl/files/cdecl-2.5.patch37
1 files changed, 33 insertions, 4 deletions
diff --git a/dev-util/cdecl/files/cdecl-2.5.patch b/dev-util/cdecl/files/cdecl-2.5.patch
index 62a8a9ffdba9..f6fad3948720 100644
--- a/dev-util/cdecl/files/cdecl-2.5.patch
+++ b/dev-util/cdecl/files/cdecl-2.5.patch
@@ -1,5 +1,5 @@
---- cdecl-2.5.orig/Makefile
-+++ cdecl-2.5/Makefile
+--- Makefile
++++ Makefile.new
@@ -15,9 +15,9 @@
#
# add -DUSE_READLINE To compile in support for the GNU readline library.
@@ -12,8 +12,8 @@
ALLFILES= makefile cdgram.y cdlex.l cdecl.c cdecl.1 testset testset++
BINDIR= /usr/bin
MANDIR= /usr/man/man1
---- cdecl-2.5.orig/cdecl.c
-+++ cdecl-2.5/cdecl.c
+--- cdecl.c
++++ cdecl.c.new
@@ -67,6 +67,7 @@
# include <stddef.h>
# include <string.h>
@@ -31,3 +31,32 @@
int yywrap(void);
int dostdin(void);
+--- cdecl.c 2009-07-07 13:20:37.000000000 +0200
++++ cdecl.c.new 2009-07-07 13:25:00.000000000 +0200
+@@ -91,7 +91,7 @@
+ #ifdef USE_READLINE
+ # include <readline/readline.h>
+ /* prototypes for functions related to readline() */
+- char * getline();
++ char * mygetline();
+ char ** attempt_completion(char *, int, int);
+ char * keyword_completion(char *, int);
+ char * command_completion(char *, int);
+@@ -375,7 +375,7 @@
+ static char *line_read = NULL;
+
+ /* Read a string, and return a pointer to it. Returns NULL on EOF. */
+-char * getline ()
++char * mygetline ()
+ {
+ /* If the buffer has already been allocated, return the memory
+ to the free pool. */
+@@ -887,7 +887,7 @@
+
+ if (!quiet) (void) printf("Type `help' or `?' for help\n");
+ ret = 0;
+- while ((line = getline())) {
++ while ((line = mygetline())) {
+ if (!strcmp(line, "quit") || !strcmp(line, "exit")) {
+ free(line);
+ return ret;