summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2013-10-19 12:19:05 +0000
committerJohannes Huber <johu@gentoo.org>2013-10-19 12:19:05 +0000
commita09adf6649970dca49a3d8a159b142fef8de53d2 (patch)
treea84b2bd8ace2054931a1e8a6b865f844fda0f9f1 /dev-util/cmake/files
parentadded missing DEPEND: virtual/perl-Module-Build wrt bug #488290 (diff)
downloadhistorical-a09adf6649970dca49a3d8a159b142fef8de53d2.tar.gz
historical-a09adf6649970dca49a3d8a159b142fef8de53d2.tar.bz2
historical-a09adf6649970dca49a3d8a159b142fef8de53d2.zip
Remove old.
Package-Manager: portage-2.2.7/cvs/Linux x86_64 Manifest-Sign-Key: 0xF3CFD2BD
Diffstat (limited to 'dev-util/cmake/files')
-rw-r--r--dev-util/cmake/files/cmake-2.8.10-FindPythonLibs.patch13
-rw-r--r--dev-util/cmake/files/cmake-2.8.10-tests.patch83
-rw-r--r--dev-util/cmake/files/cmake-2.8.10.2-qt5.patch16
3 files changed, 0 insertions, 112 deletions
diff --git a/dev-util/cmake/files/cmake-2.8.10-FindPythonLibs.patch b/dev-util/cmake/files/cmake-2.8.10-FindPythonLibs.patch
deleted file mode 100644
index d4f18ff50f80..000000000000
--- a/dev-util/cmake/files/cmake-2.8.10-FindPythonLibs.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/Modules/FindPythonLibs.cmake b/Modules/FindPythonLibs.cmake
-index 0a9a990..6a13d22 100644
---- a/Modules/FindPythonLibs.cmake
-+++ b/Modules/FindPythonLibs.cmake
-@@ -79,6 +79,8 @@ unset(_PYTHON1_VERSIONS)
- unset(_PYTHON2_VERSIONS)
- unset(_PYTHON3_VERSIONS)
-
-+EXECUTE_PROCESS(COMMAND python -c "import sys; sys.stdout.write('.'.join([str(x) for x in sys.version_info[:2]]))"
-+ OUTPUT_VARIABLE _Python_VERSIONS)
- foreach(_CURRENT_VERSION ${_Python_VERSIONS})
- string(REPLACE "." "" _CURRENT_VERSION_NO_DOTS ${_CURRENT_VERSION})
- if(WIN32)
diff --git a/dev-util/cmake/files/cmake-2.8.10-tests.patch b/dev-util/cmake/files/cmake-2.8.10-tests.patch
deleted file mode 100644
index 944e3c56a782..000000000000
--- a/dev-util/cmake/files/cmake-2.8.10-tests.patch
+++ /dev/null
@@ -1,83 +0,0 @@
-Removes the following tests:
-
-- DeployQt4, which tries to break sandbox and ignores prefix
-- CTest.updatecvs, which fails to commit as root
-- TestUpload, which requires network access
-
-diff --git a/Tests/CMakeLists.txt b/Tests/CMakeLists.txt
-index b404333..50f4292 100644
---- a/Tests/CMakeLists.txt
-+++ b/Tests/CMakeLists.txt
-@@ -271,23 +271,6 @@ if(BUILD_TESTING)
- )
- list(APPEND TEST_BUILD_DIRS "${CMake_BINARY_DIR}/Tests/BundleUtilities")
-
-- # run test for DeployQt4 on supported platforms/compilers (which depends on BundleUtilities)
-- # this test also depends on the existence of the standard qtiff plugin
-- if(QT4_WORKS AND QT_QTSQL_FOUND)
-- add_test(Qt4Deploy ${CMAKE_CTEST_COMMAND}
-- --build-and-test
-- "${CMake_SOURCE_DIR}/Tests/Qt4Deploy"
-- "${CMake_BINARY_DIR}/Tests/Qt4Deploy"
-- --build-generator ${CMAKE_TEST_GENERATOR}
-- --build-makeprogram ${CMAKE_TEST_MAKEPROGRAM}
-- --build-project Qt4Deploy
-- --build-options
-- -DCMAKE_BUILD_TYPE:STRING=${CMAKE_BUILD_TYPE}
-- -DQT_QMAKE_EXECUTABLE:FILEPATH=${QT_QMAKE_EXECUTABLE}
-- )
-- list(APPEND TEST_BUILD_DIRS "${CMake_BINARY_DIR}/Tests/Qt4Deploy")
-- endif()
--
- endif()
- endif()
-
-@@ -1587,30 +1570,6 @@ ${CMake_BINARY_DIR}/bin/cmake -DVERSION=master -P ${CMake_SOURCE_DIR}/Utilities/
- list(APPEND TEST_BUILD_DIRS "${CMake_BINARY_DIR}/Tests/${CTestUpdateSVN_DIR}")
- endif()
-
-- # Test CTest Update with CVS
-- if(EXISTS ${CMAKE_ROOT}/Modules/FindCVS.cmake)
-- find_package(CVS QUIET)
-- else()
-- find_program(CVS_EXECUTABLE NAMES cvs)
-- set(CVS_FOUND ${CVS_EXECUTABLE})
-- endif()
-- set(CTEST_TEST_UPDATE_CVS ${CVS_FOUND})
-- if(CTEST_TEST_UPDATE_CVS AND NOT UNIX)
-- if("${CVS_EXECUTABLE}" MATCHES "cygwin")
-- message(STATUS "No CTest.UpdateCVS test with cygwin cvs.exe outside cygwin!")
-- set(CTEST_TEST_UPDATE_CVS 0)
-- endif()
-- endif()
-- if(CTEST_TEST_UPDATE_CVS)
-- set(CTestUpdateCVS_DIR "CTest UpdateCVS")
-- configure_file("${CMake_SOURCE_DIR}/Tests/CTestUpdateCVS.cmake.in"
-- "${CMake_BINARY_DIR}/Tests/CTestUpdateCVS.cmake" @ONLY)
-- add_test(CTest.UpdateCVS ${CMAKE_CMAKE_COMMAND}
-- -P "${CMake_BINARY_DIR}/Tests/CTestUpdateCVS.cmake"
-- )
-- list(APPEND TEST_BUILD_DIRS "${CMake_BINARY_DIR}/Tests/${CTestUpdateCVS_DIR}")
-- endif()
--
- # Test CTest Update with BZR
- find_program(BZR_EXECUTABLE NAMES bzr)
- mark_as_advanced(BZR_EXECUTABLE)
-@@ -1706,17 +1665,6 @@ ${CMake_BINARY_DIR}/bin/cmake -DVERSION=master -P ${CMake_SOURCE_DIR}/Utilities/
- FAIL_REGULAR_EXPRESSION "SegFault")
-
- configure_file(
-- "${CMake_SOURCE_DIR}/Tests/CTestTestUpload/test.cmake.in"
-- "${CMake_BINARY_DIR}/Tests/CTestTestUpload/test.cmake"
-- @ONLY ESCAPE_QUOTES)
-- add_test(CTestTestUpload ${CMAKE_CTEST_COMMAND}
-- -S "${CMake_BINARY_DIR}/Tests/CTestTestUpload/test.cmake" -V
-- --output-log "${CMake_BINARY_DIR}/Tests/CTestTestUpload/testOut.log"
-- )
-- set_tests_properties(CTestTestUpload PROPERTIES
-- PASS_REGULAR_EXPRESSION "Upload\\.xml")
--
-- configure_file(
- "${CMake_SOURCE_DIR}/Tests/CTestTestConfigFileInBuildDir/test1.cmake.in"
- "${CMake_BINARY_DIR}/Tests/CTestTestConfigFileInBuildDir1/test1.cmake"
- @ONLY ESCAPE_QUOTES)
diff --git a/dev-util/cmake/files/cmake-2.8.10.2-qt5.patch b/dev-util/cmake/files/cmake-2.8.10.2-qt5.patch
deleted file mode 100644
index 1f2bef0cec14..000000000000
--- a/dev-util/cmake/files/cmake-2.8.10.2-qt5.patch
+++ /dev/null
@@ -1,16 +0,0 @@
---- Source/QtDoalog/CMakeLists.txt
-+++ Source/QtDialog/CMakeLists.txt
-@@ -11,7 +11,12 @@
- #=============================================================================
-
- project(QtDialog)
--find_package(Qt5Widgets QUIET)
-+option(WITH_Qt5 ON)
-+
-+if(WITH_Qt5)
-+ find_package(Qt5Widgets QUIET)
-+endif()
-+
- if (Qt5Widgets_FOUND)
- include_directories(${Qt5Widgets_INCLUDE_DIRS})
- add_definitions(${Qt5Widgets_DEFINITONS})