summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Holm <dholm@gentoo.org>2004-11-29 10:46:08 +0000
committerDavid Holm <dholm@gentoo.org>2004-11-29 10:46:08 +0000
commit47947cc21bb47b966d92f4da5a738bcaf526c6f2 (patch)
tree89d0b21074193d06fde769459b6d3ee90130c283 /dev-util/cocom
parentFixed completion function to use POSIX-sh compliant identifier (s/-/_/) so ba... (diff)
downloadhistorical-47947cc21bb47b966d92f4da5a738bcaf526c6f2.tar.gz
historical-47947cc21bb47b966d92f4da5a738bcaf526c6f2.tar.bz2
historical-47947cc21bb47b966d92f4da5a738bcaf526c6f2.zip
Initial import
Diffstat (limited to 'dev-util/cocom')
-rw-r--r--dev-util/cocom/ChangeLog10
-rw-r--r--dev-util/cocom/cocom-0.995.ebuild21
-rw-r--r--dev-util/cocom/files/digest-cocom-0.9951
-rw-r--r--dev-util/cocom/metadata.xml20
4 files changed, 52 insertions, 0 deletions
diff --git a/dev-util/cocom/ChangeLog b/dev-util/cocom/ChangeLog
new file mode 100644
index 000000000000..186ba684b662
--- /dev/null
+++ b/dev-util/cocom/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-util/cocom
+# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cocom/ChangeLog,v 1.1 2004/11/29 10:46:08 dholm Exp $
+
+*cocom-0.995 (29 Nov 2004)
+
+ 29 Nov 2004; David Holm <dholm@gentoo.org> +metadata.xml,
+ +cocom-0.995.ebuild:
+ Initial import
+
diff --git a/dev-util/cocom/cocom-0.995.ebuild b/dev-util/cocom/cocom-0.995.ebuild
new file mode 100644
index 000000000000..f587ff49da48
--- /dev/null
+++ b/dev-util/cocom/cocom-0.995.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cocom/cocom-0.995.ebuild,v 1.1 2004/11/29 10:46:08 dholm Exp $
+
+DESCRIPTION="Tool set oriented onto the creation of compilers, cross-compilers, interpreters, and other language processors"
+HOMEPAGE="http://cocom.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~ppc"
+IUSE=""
+DEPEND="virtual/libc"
+
+src_compile() {
+ econf || die
+ emake -j1 || die "emake failed"
+}
+
+src_install() {
+ make install DESTDIR=${D} || die
+}
diff --git a/dev-util/cocom/files/digest-cocom-0.995 b/dev-util/cocom/files/digest-cocom-0.995
new file mode 100644
index 000000000000..0ba26d6a6ffd
--- /dev/null
+++ b/dev-util/cocom/files/digest-cocom-0.995
@@ -0,0 +1 @@
+MD5 94040380e63afd6cb12d2abacb87f8c8 cocom-0.995.tar.gz 3152815
diff --git a/dev-util/cocom/metadata.xml b/dev-util/cocom/metadata.xml
new file mode 100644
index 000000000000..702fa585c551
--- /dev/null
+++ b/dev-util/cocom/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+ <email>dholm@gentoo.org</email>
+</maintainer>
+<longdescription>
+COCOM tool set is oriented towards the creation of compilers, cross-compilers, interpreters, and other language processors. Now COCOM tool set consists of the following components:
+
+ * Ammunition (reusable packages)
+ * Sprut (internal representation description translator)
+ * Nona (code selector description translator)
+ * Msta (syntax description translator)
+ * Oka (pipeline hazards description translator)
+ * Shilka (keywords description translator)
+
+All of these components are written in ANSI C and have common style input languages (a la YACC). All code generated by the components is in also strict ANSI C and in standard C++. All documentation exists in ASCII, TeX dvi, Postsrcipt, HTML, and GNU info formats.
+</longdescription>
+</pkgmetadata>