summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Arnold <nerdboy@gentoo.org>2007-04-03 05:57:40 +0000
committerSteve Arnold <nerdboy@gentoo.org>2007-04-03 05:57:40 +0000
commit3bd6046ea12c0107f2bddd2ba8bb7fc31544ee78 (patch)
tree04325bcf736673168b61c3ba39c7e40e49838762 /dev-util/duma/duma-2.4.27.ebuild
parentInclude proper headers and respect LDFLAGS. (diff)
downloadhistorical-3bd6046ea12c0107f2bddd2ba8bb7fc31544ee78.tar.gz
historical-3bd6046ea12c0107f2bddd2ba8bb7fc31544ee78.tar.bz2
historical-3bd6046ea12c0107f2bddd2ba8bb7fc31544ee78.zip
updated fork of electric fence (fixes bug 160695)
Package-Manager: portage-2.1.2.2
Diffstat (limited to 'dev-util/duma/duma-2.4.27.ebuild')
-rw-r--r--dev-util/duma/duma-2.4.27.ebuild78
1 files changed, 78 insertions, 0 deletions
diff --git a/dev-util/duma/duma-2.4.27.ebuild b/dev-util/duma/duma-2.4.27.ebuild
new file mode 100644
index 000000000000..95152dfcda50
--- /dev/null
+++ b/dev-util/duma/duma-2.4.27.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/duma/duma-2.4.27.ebuild,v 1.1 2007/04/03 05:57:40 nerdboy Exp $
+
+inherit eutils versionator multilib toolchain-funcs
+# flag-o-matic
+
+MY_P="${PN}_$(replace_all_version_separators '_')"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="DUMA (Detect Unintended Memory Access) is a memory debugging library."
+HOMEPAGE="http://duma.sourceforge.net/"
+
+SRC_URI="mirror://sourceforge/duma/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="virtual/libc"
+RDEPEND="${DEPEND}
+ app-shells/bash"
+
+pkg_setup() {
+ #DUMA_OPTIONS="-DDUMA_LIB_NO_LEAKDETECTION"
+ DUMA_OPTIONS="-DDUMA_USE_FRAMENO"
+ if [ -n "${DUMA_OPTIONS}" ]; then
+ ewarn ""
+ elog "Custom build options are ${DUMA_OPTIONS}."
+ ewarn ""
+ else
+ ewarn ""
+ elog "Custom build options are not set!"
+ elog "See the package Makefile for more options."
+ ewarn ""
+ fi
+}
+
+src_unpack(){
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-types.patch"
+ epatch "${FILESDIR}/${P}-make.patch"
+ # source has carriage returns scattered throughout...
+ #edos2unix *
+}
+
+src_compile(){
+ # filter parallel make, because it generate header and that header needed
+ # for next part of compile
+ use amd64 && export DUMA_ALIGNMENT=16
+ # append-flags doesn't work here (stupid static makefile)
+ emake CFLAGS="${DUMA_OPTIONS} ${CFLAGS}" CC=$(tc-getCC) \
+ || die "emake failed"
+}
+
+src_test() {
+ einfo "Control-C now if you want to disable tests..."
+ epause 5
+
+ cd ${S}
+ use amd64 && export DUMA_ALIGNMENT=16
+ make CFLAGS="${DUMA_OPTIONS} ${CFLAGS}" \
+ CC=$(tc-getCC) check || die "make check failed"
+
+ einfo "Check output above to verify all tests have passed..."
+}
+
+src_install(){
+ make prefix="${D}usr" LIB_INSTALL_DIR="${D}usr/$(get_libdir)" install \
+ || die "make install failed"
+ insinto /usr/include
+ doins duma.h duma_config.h duma_hlp.h dumapp.h noduma.h paging.h print.h \
+ sem_inc.h || die " failed install headers"
+ dodoc CHANGELOG README
+}
+