summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Arnold <nerdboy@gentoo.org>2007-10-10 00:35:22 +0000
committerSteve Arnold <nerdboy@gentoo.org>2007-10-10 00:35:22 +0000
commit66971fbe5b12b95f5ee4e8e403f0ec33c60a83d4 (patch)
treeca6dd18704638ff7345611e77befcbc0caf33848 /dev-util/duma/duma-2.4.27.ebuild
parentQA fixes - Removed WANT_AUTO{MAKE,CONF} assignments since we were assigning t... (diff)
downloadhistorical-66971fbe5b12b95f5ee4e8e403f0ec33c60a83d4.tar.gz
historical-66971fbe5b12b95f5ee4e8e403f0ec33c60a83d4.tar.bz2
historical-66971fbe5b12b95f5ee4e8e403f0ec33c60a83d4.zip
version bump and stable bump (special case) for bug 195203
Package-Manager: portage-2.1.3.12
Diffstat (limited to 'dev-util/duma/duma-2.4.27.ebuild')
-rw-r--r--dev-util/duma/duma-2.4.27.ebuild12
1 files changed, 5 insertions, 7 deletions
diff --git a/dev-util/duma/duma-2.4.27.ebuild b/dev-util/duma/duma-2.4.27.ebuild
index 2ce12e8c478a..692a1a4f131d 100644
--- a/dev-util/duma/duma-2.4.27.ebuild
+++ b/dev-util/duma/duma-2.4.27.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/duma/duma-2.4.27.ebuild,v 1.2 2007/07/12 01:05:42 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/duma/duma-2.4.27.ebuild,v 1.3 2007/10/10 00:35:22 nerdboy Exp $
inherit eutils versionator multilib toolchain-funcs
# flag-o-matic
@@ -15,7 +15,7 @@ SRC_URI="mirror://sourceforge/duma/${MY_P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="amd64 x86"
IUSE=""
DEPEND="virtual/libc"
@@ -38,12 +38,10 @@ pkg_setup() {
}
src_unpack(){
- unpack ${A}
+ unpack "${A}"
cd "${S}"
epatch "${FILESDIR}/${P}-types.patch"
epatch "${FILESDIR}/${P}-make.patch"
- # source has carriage returns scattered throughout...
- #edos2unix *
}
src_compile(){
@@ -51,7 +49,7 @@ src_compile(){
# for next part of compile
use amd64 && export DUMA_ALIGNMENT=16
# append-flags doesn't work here (stupid static makefile)
- emake CFLAGS="${DUMA_OPTIONS} ${CFLAGS}" CC=$(tc-getCC) \
+ make CFLAGS="${DUMA_OPTIONS} ${CFLAGS}" CC=$(tc-getCC) \
|| die "emake failed"
}
@@ -59,7 +57,7 @@ src_test() {
einfo "Control-C now if you want to disable tests..."
epause 5
- cd ${S}
+ cd "${S}"
use amd64 && export DUMA_ALIGNMENT=16
make CFLAGS="${DUMA_OPTIONS} ${CFLAGS}" \
CC=$(tc-getCC) check || die "make check failed"