summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2002-07-25 02:57:06 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2002-07-25 02:57:06 +0000
commit711201adfdfc6e97e702f431ff5a5ab6a65a02f1 (patch)
tree17726518db84f5952d5e839bd7f24b6ce51a7b3d /dev-util/gcvs/gcvs-1.0_beta3-r1.ebuild
parentSLOT KEYWORDS and LICENSE (diff)
downloadhistorical-711201adfdfc6e97e702f431ff5a5ab6a65a02f1.tar.gz
historical-711201adfdfc6e97e702f431ff5a5ab6a65a02f1.tar.bz2
historical-711201adfdfc6e97e702f431ff5a5ab6a65a02f1.zip
fix for gcc3.1
Diffstat (limited to 'dev-util/gcvs/gcvs-1.0_beta3-r1.ebuild')
-rw-r--r--dev-util/gcvs/gcvs-1.0_beta3-r1.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/dev-util/gcvs/gcvs-1.0_beta3-r1.ebuild b/dev-util/gcvs/gcvs-1.0_beta3-r1.ebuild
new file mode 100644
index 000000000000..3941cc5d6616
--- /dev/null
+++ b/dev-util/gcvs/gcvs-1.0_beta3-r1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/dev-util/gcvs/gcvs-1.0_beta3-r1.ebuild,v 1.1 2002/07/25 02:57:06 mkennedy Exp $
+
+MY_P=${P/eta/}
+MY_P=${MY_P/_/}
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="GUI frontend for CVS from the CVSGUI project"
+SRC_URI="mirror://sourceforge/cvsgui/${MY_P}.tar.gz"
+HOMEPAGE="http://cvsgui.sourceforge.net/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86"
+
+DEPEND="=x11-libs/gtk+-1.2*
+ >=dev-lang/tcl-8.3.3
+ sys-devel/perl
+ sys-devel/bison
+ gnome-extra/libglademm"
+
+RDEPEND="${DEPEND}
+ >=dev-util/cvs-1.11-r1"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ patch -p1 <${FILESDIR}/gcvs-1.0b3-gcc3-gentoo.patch || die
+}
+
+src_compile() {
+
+ ./make_configure || die
+ ./configure --prefix=/usr --host=${CHOST} || die
+
+ # Ladies and Gentlemen... The following is pure evil...
+ export HOME=${S}
+ # Yes, thats right... the build process ends up trying to create
+ # something in root's home directory... why? they use glade,
+ # a full blown gnome gui application to generate source code...
+
+ # more evil... without this it builds its own copy of cvs
+ # which of course installs itself on top of the real cvs package
+ mv Makefile Makefile.old
+ sed 's|cvsunix||g' Makefile.old > Makefile
+
+ emake all || die
+
+}
+
+src_install () {
+
+ make prefix=${D}/usr install
+
+ # note: html docs ignored because they focus on the mac and windows
+ # version and seem to be of questionable use with gcvs
+
+ dodoc AUTHORS COPYING ChangeLog INSTALL README
+
+
+}