summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2010-03-17 00:40:16 +0000
committerSebastian Pipping <sping@gentoo.org>2010-03-17 00:40:16 +0000
commit9c6e03b50aa5f6257962b115f0bc995d1c0ff6b8 (patch)
treeba82297d08476e00f7526ab9d06653cae79f4509 /dev-util/gprof2dot
parentFix message (diff)
downloadhistorical-9c6e03b50aa5f6257962b115f0bc995d1c0ff6b8.tar.gz
historical-9c6e03b50aa5f6257962b115f0bc995d1c0ff6b8.tar.bz2
historical-9c6e03b50aa5f6257962b115f0bc995d1c0ff6b8.zip
dev-util/gprof2dot: New package
Package-Manager: portage-2.2_rc67/cvs/Linux i686
Diffstat (limited to 'dev-util/gprof2dot')
-rw-r--r--dev-util/gprof2dot/ChangeLog10
-rw-r--r--dev-util/gprof2dot/Manifest3
-rw-r--r--dev-util/gprof2dot/gprof2dot-0_p20100216.ebuild53
-rw-r--r--dev-util/gprof2dot/metadata.xml9
4 files changed, 75 insertions, 0 deletions
diff --git a/dev-util/gprof2dot/ChangeLog b/dev-util/gprof2dot/ChangeLog
new file mode 100644
index 000000000000..9eeb66c2a30c
--- /dev/null
+++ b/dev-util/gprof2dot/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-util/gprof2dot
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/gprof2dot/ChangeLog,v 1.1 2010/03/17 00:40:16 sping Exp $
+
+*gprof2dot-0_p20100216 (17 Mar 2010)
+
+ 17 Mar 2010; Sebastian Pipping <sping@gentoo.org>
+ +gprof2dot-0_p20100216.ebuild, +metadata.xml:
+ New package
+
diff --git a/dev-util/gprof2dot/Manifest b/dev-util/gprof2dot/Manifest
new file mode 100644
index 000000000000..6577031588a8
--- /dev/null
+++ b/dev-util/gprof2dot/Manifest
@@ -0,0 +1,3 @@
+EBUILD gprof2dot-0_p20100216.ebuild 1238 RMD160 06947f59b6be6c38840a51313af7b3f4f44878e3 SHA1 d360f444116228f98f35c8d35613058bb16fcd81 SHA256 aa6a560fd86504baf710dba2afad8ee116030726413189e08e83a78ff05c2b5b
+MISC ChangeLog 361 RMD160 9802ad449eb6f58387b230326582df01aa66898f SHA1 03692033a914c00007d0f1ed7f0b03269e08554c SHA256 ef158648502f57da803a3befa2d40c8ef50fc64e384764338b5d00b2017edcba
+MISC metadata.xml 257 RMD160 04e4c6e678ba8e8ffde93f57d06a40b60f9eaa69 SHA1 e3c39bf9a25beebbe626726bb94f6e22db4fa06d SHA256 b4a209de2bfbbcc5ceab61bf458a1ee79da4c60a30e4aabf54b76e9709b56db8
diff --git a/dev-util/gprof2dot/gprof2dot-0_p20100216.ebuild b/dev-util/gprof2dot/gprof2dot-0_p20100216.ebuild
new file mode 100644
index 000000000000..086754d84f31
--- /dev/null
+++ b/dev-util/gprof2dot/gprof2dot-0_p20100216.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/gprof2dot/gprof2dot-0_p20100216.ebuild,v 1.1 2010/03/17 00:40:16 sping Exp $
+
+SUPPORT_PYTHON_ABIS="1"
+PYTHON_DEPEND="*"
+PYTHON_USE_WITH="xml"
+
+inherit mercurial python
+
+DESCRIPTION="Converts profiling output to dot graphs"
+HOMEPAGE="http://code.google.com/p/jrfonseca/wiki/Gprof2Dot"
+SRC_URI=""
+EHG_REPO_URI="https://gprof2dot.jrfonseca.googlecode.com/hg/"
+EHG_REVISION="9c41dcfc9906"
+
+if [[ ${PV} != 0_p20100216 ]]; then
+ die 'Broken bump detected: same \${EHG_REVISION} again'
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+S="${WORKDIR}/hg"
+
+src_install() {
+ abi_specific_install() {
+ local code_dir="$(python_get_sitedir)"/${PN}
+ exeinto "${code_dir}"
+ doexe ${PN}.py || die "doexe failed"
+
+ dodir /usr/bin
+ dosym "${code_dir}"/${PN}.py /usr/bin/${PN}-${PYTHON_ABI} \
+ || die "dosym failed"
+ }
+ python_execute_function abi_specific_install
+
+ python_generate_wrapper_scripts "${D}"/usr/bin/${PN} \
+ || die 'python_generate_wrapper_scripts failed'
+}
+
+pkg_postinst() {
+ python_mod_optimize ${PN}
+}
+
+pkg_postrm() {
+ python_mod_cleanup ${PN}
+}
diff --git a/dev-util/gprof2dot/metadata.xml b/dev-util/gprof2dot/metadata.xml
new file mode 100644
index 000000000000..328fbd146a56
--- /dev/null
+++ b/dev-util/gprof2dot/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>no-herd</herd>
+ <maintainer>
+ <email>sping@gentoo.org</email>
+ <name>Sebastian Pipping</name>
+ </maintainer>
+</pkgmetadata>