summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2011-11-11 19:24:06 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2011-11-11 19:24:06 +0000
commit39c82be399b886ba32cf0485d282529120850f79 (patch)
tree057daa23b777dd479700f30d9fb87a054f1c04c1 /dev-util/scons/files/scons-2.1.0-jython.patch
parentDon't inherit unused eclass. Set PYTHONPATH in src_test(). Patch by Arfrever (diff)
downloadhistorical-39c82be399b886ba32cf0485d282529120850f79.tar.gz
historical-39c82be399b886ba32cf0485d282529120850f79.tar.bz2
historical-39c82be399b886ba32cf0485d282529120850f79.zip
Fix building with Jython. Patch by Arfrever.
Package-Manager: portage-2.2.0_alpha73/cvs/Linux x86_64
Diffstat (limited to 'dev-util/scons/files/scons-2.1.0-jython.patch')
-rw-r--r--dev-util/scons/files/scons-2.1.0-jython.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/dev-util/scons/files/scons-2.1.0-jython.patch b/dev-util/scons/files/scons-2.1.0-jython.patch
new file mode 100644
index 000000000000..ca04e12031e1
--- /dev/null
+++ b/dev-util/scons/files/scons-2.1.0-jython.patch
@@ -0,0 +1,13 @@
+http://scons.tigris.org/issues/show_bug.cgi?id=2791
+
+--- setup.py
++++ setup.py
+@@ -325,7 +325,7 @@
+ self.copy_scons(src, scons_version_bat)
+
+ # --- distutils copy/paste ---
+- if os.name == 'posix':
++ if hasattr(os, 'chmod'):
+ # Set the executable bits (owner, group, and world) on
+ # all the scripts we just installed.
+ for file in self.get_outputs():