summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBryan Østergaard <kloeri@gentoo.org>2004-02-26 01:47:58 +0000
committerBryan Østergaard <kloeri@gentoo.org>2004-02-26 01:47:58 +0000
commita13f5595c277e60e39ce8a17184fab69e9ceb2ee (patch)
tree625c4d949ce8960105f564b83e3a0489fd400aa9 /dev-util/scons/scons-0.94-r2.ebuild
parentUpdating to -r2 to solve bug 42335 (diff)
downloadhistorical-a13f5595c277e60e39ce8a17184fab69e9ceb2ee.tar.gz
historical-a13f5595c277e60e39ce8a17184fab69e9ceb2ee.tar.bz2
historical-a13f5595c277e60e39ce8a17184fab69e9ceb2ee.zip
Byte-compile .py files, closing bug #42660.
Diffstat (limited to 'dev-util/scons/scons-0.94-r2.ebuild')
-rw-r--r--dev-util/scons/scons-0.94-r2.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-util/scons/scons-0.94-r2.ebuild b/dev-util/scons/scons-0.94-r2.ebuild
new file mode 100644
index 000000000000..c9a703ec9034
--- /dev/null
+++ b/dev-util/scons/scons-0.94-r2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/scons/scons-0.94-r2.ebuild,v 1.1 2004/02/26 01:47:58 kloeri Exp $
+
+inherit python distutils
+
+DESCRIPTION="Extensible python-based build utility"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+RESTRICT="nomirror"
+HOMEPAGE="http://www.scons.org"
+
+SLOT="0"
+LICENSE="as-is"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~hppa ~mips ~amd64 ~ia64"
+
+DEPEND=">=dev-lang/python-2.0"
+
+DOCS="RELEASE.txt CHANGES.txt LICENSE.txt"
+
+src_install () {
+ distutils_src_install
+ doman scons.1 sconsign.1
+}
+
+pkg_postinst() {
+ python_mod_optimize /usr/lib/scons/SCons
+}
+
+pkg_postrm() {
+ python_mod_cleanup
+}